Bug Hunting Session
Bug 97481 - DPI scaling doesn't work with export to png or jpg
Summary: DPI scaling doesn't work with export to png or jpg
Status: RESOLVED DUPLICATE of bug 85761
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-01 13:24 UTC by Yan Pas
Modified: 2016-03-06 02:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yan Pas 2016-02-01 13:24:25 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.97 Safari/537.36
Build Identifier: LibreOffice 5.0.4.2

I have exported table from calc to pdf and then opened it in draw. Exporting this pdf to jpg is impossible with good quallity

Reproducible: Always

Steps to Reproduce:
1. Open any vector graphics in Draw
2. Select some objects and press export
3. No matter which DPI (default 96) you have selected - the image resolution will stay the same!!!



[Information automatically included from LibreOffice]
Locale: ru
Module: DrawingDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 MM 2016-02-01 21:14:26 UTC
Think the DPI with jpg's was set to 96, to fix some other issue in bug 65695
http://cgit.freedesktop.org/libreoffice/core/commit/?id=d0d8e0a2a7244814f783f16c6c8b342fe6d16e79
Comment 2 Yan Pas 2016-02-01 21:24:17 UTC
The same for png. DPI value does not affect on anything (but should affect on resolution). Only changing resolution values affects on resulting image
Comment 3 Regina Henschel 2016-02-02 22:26:34 UTC
You have to set first the resolution and then the size. Then correct number of pixels is generated. The dpi information in the png-file is correct for me. The dpi information in the jpeg-file is wrong. That is already tracked in bug 85761.

*** This bug has been marked as a duplicate of bug 85761 ***
Comment 4 Chris Sherlock 2016-02-13 07:33:58 UTC
Asking for a review on Gerrit:

https://gerrit.libreoffice.org/22339
Comment 5 Chris Sherlock 2016-02-14 21:30:17 UTC
Chris Sherlock committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f8355221ae62b89a706f2d04b63eda658f3ccfa5

tdf#85761 vcl: JPEG export does not save PPI values correctly

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Chris Sherlock 2016-03-06 02:17:53 UTC
Backport is now in 5.1.2 and 5.0.6