Bug Hunting Session
Bug 97482 - Presentation-mode: Pen - drawing in presenter's view
Summary: Presentation-mode: Pen - drawing in presenter's view
Status: RESOLVED DUPLICATE of bug 62366
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: annotation(pen) Presenter-Console
  Show dependency treegraph
 
Reported: 2016-02-01 14:08 UTC by Tobias Burnus
Modified: 2019-03-30 20:16 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Burnus 2016-02-01 14:08:29 UTC
I have a dual screen system; in presentation mode, one shows full-screen the presentation, the other shows the presenter's view with current/next slide, notes etc.

Right click in the audience's view and choose "Mouse pointer as pen" - that changes its shape from an arrow into a pen. Move then the mouse to the presenter's view. When over the current slide, it has the pen shape. Click now draw something and release.

Result: No drawing is visible.

If one now moves the mouse pointer over to the audience's screen, the previous drawing instantly is shown on both screens.

Expected: The drawing appears instantly while one draws on the current slide on the presenter's screen.
Comment 1 Mark Saper 2016-02-10 18:18:04 UTC
Tobias describes exactly what I am seeing on Mac OS X 9.5 with second monitor.
Comment 2 QA Administrators 2017-03-06 15:47:25 UTC Comment hidden (obsolete)
Comment 3 Tobias Burnus 2017-03-06 16:13:20 UTC
Problem unchanged with LO 5.3.0.3 on Window 7 (SP1, 32bit)
Comment 4 QA Administrators 2018-03-07 03:40:41 UTC Comment hidden (obsolete)
Comment 5 Tobias Burnus 2018-03-07 08:38:06 UTC
Testing with 6.1.0.0.alpha0+2018-02-21 and 6.0.1.1 on 32-bit Windows.

Currently:
1. Mouse as Pen menu only shows up on the audience screen
   Right click on the presenter's view doesn't work.

2. Mouse pointer in pen shape, but drawing on the audience screen
   does nothing.  (Seems to get completely ignored.)

3. Mouse pointer on the presenter's screen - likewise, drawing doesn't seem to
   show up anywhere, but when one moves the pointer to the audience screen,
   this drawing now appears on both screens, audience and presenter.

I vaguely recall that (2) did work before, but I might be mistaken.
Comment 6 QA Administrators 2019-03-08 03:40:34 UTC Comment hidden (obsolete)
Comment 7 Tobias Burnus 2019-03-08 08:04:08 UTC
With 6.2.0.3/Windows 7 (32bit):

* Right click only works on the audience's view

* Drawing (mouse: click, move, release) on the audience's screen doesn't do anything

* Drawing (click, move, release) on the presenter's screen does not show anything on either screen, but when the mouse pointer moves (after finishing drawing) to the audience's screen, the drawn line appears on both screens.
Comment 8 Roman Kuznetsov 2019-03-30 20:16:23 UTC

*** This bug has been marked as a duplicate of bug 62366 ***