Bug Hunting Session
Bug 97509 - Path of inserted linked image breaks after file is moved
Summary: Path of inserted linked image breaks after file is moved
Status: RESOLVED DUPLICATE of bug 45435
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-02 16:00 UTC by Sašo Smolej
Modified: 2016-02-02 16:02 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sašo Smolej 2016-02-02 16:00:12 UTC
At the moment I am using linked images as page headers (which is a workaround of using header background images), which break when the document is moved.
(File:/// is ommited for clarity)
The following should be sufficient for reproduction:

The document path:
Z:\Documents\Pricelists\pricelist1.ods
The image path (linked):
Z:\Documents\Headers\header.png


The document is then moved from:
Z:\Documents\Pricelists\
To:
Z:\Documents\Pricelists\Export\Partner1\

As the document is reopened, the linked images show the following path (and not the image of course):
Z:\Documents\Pricelists\Export\Headers\header.png



Checking the source, the document uses "../../Header/header.png" which is fine and dandy, but it is not displayed in such manner in the program itself.
While displaying absolute paths for the user, the program internally uses relative paths, which break on file moves.
Either absolute paths should be used or it should be made clear what sort of pathing is used (or, in best case scenario, make both an option).
Comment 1 Sašo Smolej 2016-02-02 16:02:43 UTC

*** This bug has been marked as a duplicate of bug 45435 ***