Bug Hunting Session
Bug 97579 - Unable to link Access 2010 and Access mdb databases causing LibreOffice to freeze and requiring force kill
Summary: Unable to link Access 2010 and Access mdb databases causing LibreOffice to fr...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
: 94189 107890 (view as bug list)
Depends on: 56904
Blocks: Database-MS_Access
  Show dependency treegraph
 
Reported: 2016-02-04 18:05 UTC by markl536
Modified: 2017-10-23 08:22 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description markl536 2016-02-04 18:05:42 UTC
I am unable to link an Access 2010 database to Base.
Comment 1 markl536 2016-02-04 18:08:26 UTC
Libre crashes and says it recovers the database but can not open.  I am using windows 10 on 64 bit machine.
Comment 2 MM 2016-02-04 18:50:54 UTC
Dup from bug 91189 ?!
Comment 3 markl536 2016-02-04 19:45:31 UTC
(In reply to MM from comment #2)
> Dup from bug 91189 ?!

No duplicate because I cannot open the linked database.
Comment 4 Cor Nouws 2016-02-04 19:51:01 UTC
LibreOffice version?
Driver version?
Comment 5 markl536 2016-02-04 20:22:02 UTC
(In reply to Cor Nouws from comment #4)
> LibreOffice version?
> Driver version?

Version: 5.0.4.2 (x64)
Comment 6 Cor Nouws 2016-02-04 21:12:17 UTC
Thanks Mark, Did it ever work in previous versions for you (maybe 32 bits)?
Comment 7 Cor Nouws 2016-02-04 21:21:55 UTC
Looks similar to 
  https://bugs.documentfoundation.org/show_bug.cgi?id=91189
And sometimes driver info indeed is useful. see e.g.
  https://bugs.documentfoundation.org/show_bug.cgi?id=43187#c12
Comment 8 MM 2016-02-05 19:46:01 UTC
(In reply to markl536 from comment #3)
> (In reply to MM from comment #2)
> > Dup from bug 91189 ?!
> 
> No duplicate because I cannot open the linked database.

Well, as I said in bug 91189 , I couldn't open my supplied database (http://www.ms-access2010.com/tutorials/Access2010DB.zip).

Not problems with .mdb files though.
Comment 9 Buovjaga 2016-02-10 19:18:34 UTC
Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information requested in comment 6.
Comment 10 Alex Thurgood 2016-06-03 09:55:00 UTC
Confirming on LO 5122 64 bit

The problem is the following from my own tests :

I have :
Win 10
LO 5122 64 bit
MS OFfice 2010 32bit
MDAC 2.8 32bit
MS JET.OLEDB driver 32bit

LO can not see or load any of the 32 bit drivers.

You can not install (the OS refuses to run the installation routine) 64 bit drivers for MDAC (Database Access Engine) unless you have a 64bit version of MS Office !

This essentially means that you can no longer open ACCDB files.
I also have the same problem with regard to MDB files too, contrary to comment 8.
Comment 11 Alex Thurgood 2016-06-03 09:56:52 UTC
The current situation also causes LO to freez requiring force kill from the task manager.
Comment 12 Alex Thurgood 2016-06-03 11:27:16 UTC
*** Bug 94189 has been marked as a duplicate of this bug. ***
Comment 13 Elie 2016-06-03 20:46:55 UTC
Well, Alex,
I run on Win7 SP1  64bits  AMD10 quad.
Versie LibO: 5.0.5.2 (x64)
Build ID: 55b006a02d247b5f7215fc6ea0fde844b30035b3
Locale: nl-BE (nl_BE)
As said: can't open .mdb (so not .accdb but .mdb).  (I converted the file on another computer to .accdb, but same result).
The .mdb file opens with MDB Plus.
My original comment:
<<Base crashes, says file needs to be repaired --> 'repairs' ('succeeds') --> crashes again, repairs, etc.  Until infinity.>>
Comment 14 Alex Thurgood 2016-06-20 08:42:39 UTC
This is a regression over the 32bit release of LO, where at least accbd/mdb files can be read with the appropriate driver
Comment 15 Xisco Faulí 2016-09-13 10:29:08 UTC
Since we have a bibisect repository for windows covering the branch where this regression was introduced, adding keyword 'bibisectRequest'.
More info: https://wiki.documentfoundation.org/QA/Bibisect/Windows
Comment 16 Julien Nabet 2017-05-17 08:12:15 UTC
I noticed this link:
https://www.microsoft.com/en-us/download/details.aspx?id=13255
"Microsoft Access Database Engine 2010 Redistributable"

which proposes 32 and 64 bits drivers.
System requirements don't indicate the need to have MSOffice installed (but perhaps it's implicit).
Comment 17 Alex Thurgood 2017-05-24 07:46:37 UTC
*** Bug 107890 has been marked as a duplicate of this bug. ***
Comment 18 Julien Nabet 2017-05-24 08:09:29 UTC
It could be interesting to detect the use of LO 64 bits and popups an error message indicating this feature is not compatible yet.
Comment 19 Alex Thurgood 2017-10-20 13:53:00 UTC
I suggest closing this, and other similar reports as either WONTFIX, or NOTOURBUG, or else WFM in 64bit everything and Access >= 2010.
Comment 20 Alex Thurgood 2017-10-20 14:14:21 UTC
As far as I'm  concerned an all-64bit setup works :

- 64bit OS
- 64bit accdb Access >= 2010
- 64bit Data Acess Engine (2016) - database drivers provided by MS

WFM in the above situation

On a 64bit OS with 64bit programs, MS no longer supports 32bit access to Access MDB files made on a 32bit system (see MS' own support forums and the MSDN forums). We rely on the support provided by MS. If there is no MS support, there is not much we can do.

I suggest closing this, and other similar reports as either WONTFIX, or NOTOURBUG, or else WFM in 64bit everything and Access >= 2010.
Comment 21 Joseph DeVore 2017-10-20 16:56:26 UTC
this is not resolved... meh...
but from what you said... 

all I can do is a workaround...

and that is us an ADMIn-INSTALL, ie loose file dump...
of the 32bit LO to access an old db...


ps: my report...
https://bugs.documentfoundation.org/show_bug.cgi?id=107890


having the ability to access a M$ office db is almost pointless..
all I can do is read it with LO(x86) 

if you guys are going to DO nothing... at least put warnings or somthing in
LO's DB app so we know we cannot open older M$ database files in LO(x64)
:P