Bug 97586 - Accelerator keys missing from 'Save document?' dialog with gtk2
Summary: Accelerator keys missing from 'Save document?' dialog with gtk2
Status: RESOLVED DUPLICATE of bug 92630
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2016-02-04 19:50 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-04-20 12:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (17.12 KB, image/png)
2016-02-04 19:50 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-02-04 19:50:31 UTC
Created attachment 122396 [details]
screenshot

Steps:
1) Open Writer
2) Type 'a'
3) Close the document
4) Notice there isnt any underlined letter in the 'Don't Save', 'Cancel' and 'Save' buttons.

Regression as it is there in 5.0.4.

Version: 5.2.0.0.alpha0+
Build ID: 513d5c5781ec14f8512432f31290a3d54c8d57df
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-01_10:25:20
Locale: en-US (en_US.UTF-8)
Comment 1 Maxim Monastirsky 2016-02-04 20:12:26 UTC
It's a feature - see Bug 92630. Underlined letters appear after you press Alt.
Comment 2 V Stuart Foote 2016-02-04 21:53:38 UTC
duplicate of bug 97260 for the bug 92630 GTK+ 3 support, but still its a wont fix.

*** This bug has been marked as a duplicate of bug 97260 ***
Comment 3 Maxim Monastirsky 2016-02-04 21:58:41 UTC
(In reply to V Stuart Foote from comment #2)
> duplicate of bug 97260 for the bug 92630 GTK+ 3 support
Except that this bug report was about gtk2...
Comment 4 Adolfo Jayme 2016-02-05 03:07:31 UTC
(In reply to Maxim Monastirsky from comment #3)
> Except that this bug report was about gtk2...

I think Jay was using the GTK+ 3 port of Clearlooks in his screenshot.
Comment 5 Yousuf Philips (jay) (retired) 2016-02-05 12:44:58 UTC
I'm running Mate which is gtk+2 with gtk+3 Clearlooks theme.

Using `$ SAL_USE_VCLPLUGIN=gtk ./soffice` to force gtk+2 didnt make any difference, so its not a duplicate of bug 97260.

*** This bug has been marked as a duplicate of bug 92630 ***
Comment 6 Yousuf Philips (jay) (retired) 2016-02-05 12:56:18 UTC
I was wondering if this feature is being enabled based on a user's theme or across the board on gtk 2 and 3.
Comment 7 Maxim Monastirsky 2016-02-06 18:37:25 UTC
(In reply to Adolfo Jayme from comment #4)
> I think Jay was using the GTK+ 3 port of Clearlooks in his screenshot.
Well, I concluded that Jay is using gtk2 based on this:

(In reply to Yousuf (Jay) Philips from comment #0)
> Version: 5.2.0.0.alpha0+
> Build ID: 513d5c5781ec14f8512432f31290a3d54c8d57df
> CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
> TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time:
> 2016-02-01_10:25:20
> Locale: en-US (en_US.UTF-8)

AFAIK Linux-rpm_deb-x86_64@70-TDF tb doesn't provide the gtk3 plugin...

(In reply to Yousuf (Jay) Philips from comment #6)
> I was wondering if this feature is being enabled based on a user's theme or
> across the board on gtk 2 and 3.
For gtk3 unconditionally, for gtk2 based on gtk-auto-mnemonics/gtk-enable-mnemonics.
Comment 8 Adolfo Jayme 2016-02-07 20:58:52 UTC
Right Maxim, forgot about the tinderbox. Not that it matters a lot…