Download it now!
Bug 97618 - FILEOPEN drawing object (flow chart shapes) distorted in DOCX because of drawing canvas
Summary: FILEOPEN drawing object (flow chart shapes) distorted in DOCX because of draw...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All All
: medium normal
Assignee: Balázs Regényi
URL:
Whiteboard: target:7.1.0
Keywords: filter:docx
: 123112 (view as bug list)
Depends on:
Blocks: OOXML-Shapes
  Show dependency treegraph
 
Reported: 2016-02-07 13:32 UTC by Aldo
Modified: 2020-09-14 07:40 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
.docx file with graphics (51.51 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-02-07 13:32 UTC, Aldo
Details
Pdf of the proper situation created with Office 2013 (294.98 KB, application/pdf)
2016-02-07 19:31 UTC, Aldo
Details
Comparison MSO 2010 and LibreOffice 7.0 master (89.82 KB, image/png)
2020-03-04 10:18 UTC, Xisco Faulí
Details
The example file opened in Word and current Writer (119.55 KB, image/png)
2020-08-29 07:01 UTC, NISZ LibreOffice Team
Details
Minimized test document with only the diamond shapes and their non-breaking text (33.26 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-08-29 07:23 UTC, NISZ LibreOffice Team
Details
Screenshot of the minimized document in Word and Writer (77.59 KB, image/png)
2020-08-29 07:24 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aldo 2016-02-07 13:32:58 UTC
Created attachment 122423 [details]
.docx file with graphics

import .docx: graphics distorted
Comment 1 Cor Nouws 2016-02-07 14:50:46 UTC
I can confirm the issue.
Thanks for reporting Aldo.
Can you post a pdf or image of the proper situation?
Ciao - Cor
Comment 2 Aldo 2016-02-07 19:31:47 UTC
Created attachment 122427 [details]
Pdf of the proper situation created with Office 2013
Comment 3 Cor Nouws 2016-02-07 21:57:22 UTC
thanks!
Comment 4 QA Administrators 2017-12-08 08:06:47 UTC Comment hidden (obsolete)
Comment 5 Aron Budea 2018-07-04 20:38:26 UTC
Still occurs in 6.1 beta2.
Comment 6 Xisco Faulí 2020-03-04 10:18:53 UTC
Created attachment 158375 [details]
Comparison MSO 2010 and LibreOffice 7.0 master

Stil reproducible in

Version: 7.0.0.0.alpha0+
Build ID: c57d6d39c80844c9d4c6bfed85cc151e52a67b34
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 Xisco Faulí 2020-03-04 10:55:42 UTC
Problem with the diamond shapes reported in bug 131118
Comment 8 NISZ LibreOffice Team 2020-08-29 07:01:58 UTC
Created attachment 164843 [details]
The example file opened in Word and current Writer

Version: 7.1.0.0.alpha0+ (x86)
Build ID: 6640d7f405d2970ba2825a9455926cc803284d01
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

Solving this will require multiple patches and sub-bugs I'm told.
Comment 9 NISZ LibreOffice Team 2020-08-29 07:23:00 UTC
Created attachment 164845 [details]
Minimized test document with only the diamond shapes and their non-breaking text
Comment 10 NISZ LibreOffice Team 2020-08-29 07:24:06 UTC
Created attachment 164846 [details]
Screenshot of the minimized document in Word and Writer
Comment 11 Commit Notification 2020-08-31 14:05:12 UTC
Regényi Balázs committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0d773f0b07798a59f7cf31207813aaf6bc9bb922

tdf#97618 DOCX import: VML shape: fix missing square wrap

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 NISZ LibreOffice Team 2020-09-02 10:43:51 UTC
*** Bug 123112 has been marked as a duplicate of this bug. ***
Comment 13 NISZ LibreOffice Team 2020-09-14 07:40:03 UTC
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 34a09c9c61bff30e8c4d16132bb47b2b1b16e422
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded