Bug 97698 - Calc very slows when spreadsheet has many notes (comments) and LO crash
Summary: Calc very slows when spreadsheet has many notes (comments) and LO crash
Status: RESOLVED DUPLICATE of bug 76324
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks: Calc-Comments
  Show dependency treegraph
 
Reported: 2016-02-09 22:27 UTC by ThierryT
Modified: 2020-02-18 00:05 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
LO Notes slows and crash (25.95 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-02-09 22:27 UTC, ThierryT
Details
osx 10.11.3 crashlog (919.29 KB, text/plain)
2016-02-09 22:53 UTC, steve -_-
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ThierryT 2016-02-09 22:27:26 UTC
Created attachment 122489 [details]
LO Notes slows and crash

If you have a large spreadsheet with a great number of comments ("notes"), when you request the saving of the file will dramatically slow down the program. The greater the number of comments, the longer LO takes to perform this operation.

Another example on the same file, but even more heavy :
1 - select the entire sheet content then cut and paste in place. It takes a very long time to apply.
2 - select the entire sheet content then cut and paste in place two or three times. It takes a very long time to apply and suddenly we have a crash of LO. When restarting the program it produces the 'Recovery' box to restore the files loaded but sometimes, we lost all the data.
Comment 1 steve -_- 2016-02-09 22:43:29 UTC
Can't reproduce. Win only?

Version: 5.2.0.0.alpha0+
Build ID: e07ffae5046e9c91ef96026435cab84c3bcb4534
CPU Threads: 4; OS Version: Mac OS X 10.11.3; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-02-08_23:39:45
Locale: de-DE (de.UTF-8)
Comment 2 steve -_- 2016-02-09 22:44:44 UTC
Oh actually, copy pasting brings LO to a halt. Force quit is necessary. Setting to NEW and platform to ALL.
Comment 3 steve -_- 2016-02-09 22:52:21 UTC
crashlog attached
Comment 4 steve -_- 2016-02-09 22:53:21 UTC
Created attachment 122490 [details]
osx 10.11.3 crashlog
Comment 5 m.a.riosv 2016-02-10 09:10:35 UTC
Save slowness is inherited from OOo, all versions have the issue.
Comment 6 Aron Budea 2017-01-21 21:50:24 UTC
Duplicate of bug 76324?
Comment 7 Xisco Faulí 2017-03-07 12:53:30 UTC
I think this can be closed as duplicated of bug 76324.
On the other hand, it crashes in LibreOffice 5.4 on win and it's reported in bug 105888

*** This bug has been marked as a duplicate of bug 76324 ***