Bug 97720 - Content of OLE object for ChemDraw not visible
Summary: Content of OLE object for ChemDraw not visible
Status: RESOLVED DUPLICATE of bug 39327
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-10 17:16 UTC by Basilius Sauter
Modified: 2017-08-24 17:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A Writer document with a ChemDraw OLE object inside. (26.27 KB, application/vnd.oasis.opendocument.text)
2016-02-10 17:16 UTC, Basilius Sauter
Details
Screenshot from LibreOffice 5.4. The image is displayed correctly (39.57 KB, image/png)
2017-05-18 12:53 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Basilius Sauter 2016-02-10 17:16:50 UTC
Created attachment 122505 [details]
A Writer document with a ChemDraw OLE object inside.

The attached documents has a ChemDraw OLE object inside. Double-Clicking it normally opens ChemDraw, where the content is displayed correctly. The content is, however, not displayed at all in LibreOffice (it should contain a benzene ring as well as a green protein). Other OLE objects are working as expected.

Apache OpenOffice Writer in the newest Version (4.1) displays the content correctly.
Comment 1 Buovjaga 2016-02-12 15:57:22 UTC
Do I have to have ChemDraw installed to confirm this?
Comment 2 Basilius Sauter 2016-02-12 17:55:12 UTC
(In reply to Beluga from comment #1)
> Do I have to have ChemDraw installed to confirm this?

No, viewing the document without ChemDraw installed should still work. On my second computer using, opening the file in LibreOffice displays an empty box. Opening it with Apache Openoffice, the content gets displayed correctly.
Comment 3 Buovjaga 2016-02-12 17:59:03 UTC
Ok, then I confirm.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: a6f876d45bd4e41a7143594a6cb11b6893a0f620
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-11_00:07:38
Locale: fi-FI (fi_FI)
Comment 4 QA Administrators 2017-03-06 16:16:42 UTC Comment hidden (obsolete)
Comment 5 Basilius Sauter 2017-03-21 14:14:51 UTC
Bug still present with:

- version 5.2.2.2 (x64)
- version 5.2.6.2 (x64)
- version 3.3.0 also seems to not display the result.

I repeat my statement that Apache OpenOffice seems to not have this bug.
Comment 6 Bartosz 2017-05-18 12:49:59 UTC
This issue was already resolved with LibreOffice 5.4

*** This bug has been marked as a duplicate of bug 31814 ***
Comment 7 Bartosz 2017-05-18 12:53:54 UTC
Created attachment 133387 [details]
Screenshot from LibreOffice 5.4. The image is displayed correctly
Comment 8 Timur 2017-08-24 17:51:20 UTC
I guess this is not a dupe of bug 31814 that's not really fixed but rather of bug 39327 that is.

*** This bug has been marked as a duplicate of bug 39327 ***