Bug Hunting Session
Bug 97763 - divide by zero bug ...
Summary: divide by zero bug ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.1.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0 target:5.1.2
Keywords:
: 97764 (view as bug list)
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2016-02-11 17:35 UTC by Michael Meeks
Modified: 2016-10-25 19:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2016-02-11 17:35:42 UTC
Ho hum - if I now zoom -waay- out of the previous scale/rotate GL test - I get a divide by zero error =)

Trivial fix - we shouldn't render anything in these cases.
Comment 1 Michael Meeks 2016-02-11 17:36:01 UTC
*** Bug 97764 has been marked as a duplicate of this bug. ***
Comment 2 Michael Meeks 2016-02-11 17:38:30 UTC
Patch in gerrit waiting review: https://gerrit.libreoffice.org/22297
Comment 3 Commit Notification 2016-02-11 18:03:07 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4d379cd842a9d27a0aec54af5b2ce94c01dfa0bd

tdf#97763 - avoid divide by zero for scaling images to tiny dimensions.

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2016-02-11 19:19:44 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cbaeb19fa39f0d310b1cadc9a753154ee3b59268&h=libreoffice-5-1

tdf#97763 - avoid divide by zero for scaling images to tiny dimensions.

It will be available in 5.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Michael Meeks 2016-02-11 19:34:54 UTC
Fixed & queued for -5-1-1 too as part of: https://gerrit.libreoffice.org/22292