Bug 97791 - Calc:: Copying formulas DIVIDES prior combined Cells
Summary: Calc:: Copying formulas DIVIDES prior combined Cells
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Formula Cell-Management
  Show dependency treegraph
 
Reported: 2016-02-12 10:24 UTC by Karl
Modified: 2019-12-06 02:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Prepared testfile (9.38 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-02-12 10:24 UTC, Karl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karl 2016-02-12 10:24:58 UTC
Created attachment 122568 [details]
Prepared testfile

If Formulas are copied from one cell to another

and theses target cells were combined prior of two (may be more) Cells

the Cells are divided into the number of cells, they were before

Win 7 , LO 5.1.0.3 x86  - 32bit
Testfile in attachement
Comment 1 m.a.riosv 2016-02-12 23:41:47 UTC
Confirmed Win10x64

But this is inherited from OOo and I'm not sure it is a bug, perhaps could be a request for enhancement.
Comment 2 QA Administrators 2017-03-06 14:56:49 UTC Comment hidden (obsolete)
Comment 3 QA Administrators 2019-12-03 14:57:02 UTC Comment hidden (obsolete)
Comment 4 m.a.riosv 2019-12-06 02:01:06 UTC
I'm remain thinking not a bug, if we paste, we also past the cell format, so looks fine breaking the merged.

Reinforcing this idea, using context menu to past the formula doesn't modify merged for destination cells.