Bug Hunting Session
Bug 97797 - Crash when removing 'minus'-symbol in a table (see attachment)
Summary: Crash when removing 'minus'-symbol in a table (see attachment)
Status: RESOLVED DUPLICATE of bug 97139
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-12 12:35 UTC by ich01
Modified: 2016-05-24 15:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Document which causes the crash. (9.99 KB, application/vnd.oasis.opendocument.text)
2016-02-12 12:35 UTC, ich01
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ich01 2016-02-12 12:35:05 UTC
Created attachment 122573 [details]
Document which causes the crash.

Application crashes when removing the '-' char after "Web" in the first column (attached document).

The original document (where this did happen the first time) was created with Open Office, i've copied and pasted the table in a new document in Libre Office. The bug only occurs after saving the document at least one time, not in an unsaved document.

The language of the paragraph is German.
Comment 1 ich01 2016-02-12 12:37:11 UTC
Step by Step:
1. Open the document
2. Place cursor behind "Web-" in the first column
3. Press backspace
Comment 2 Terrence Enger 2016-02-13 16:27:21 UTC
I am setting status NEW.

I see that the arrow keys will not move the caret so that it shows at
the end of the line after the hyphen.  If, however, you click after
the hyphen, the caret moves after the hyphen, and then <backspace>
sends LiberOffice into a loop:  the hyphen remains, CPU usage is high,
and LibreOffice does not respond to mous clicks or keystrokes.

In a local build of commit ebd6884, the bus loop is in 
SwTextFrame::_Format, sw/source/core/text/frmform.cxx lines 1425
to 1524.
Comment 3 Terrence Enger 2016-02-13 16:28:00 UTC
Setting O/S = All
Comment 4 Caolán McNamara 2016-05-24 15:03:32 UTC
This started working between 003d0ccf902d2449320dd24119564565a384f365..f84b8c03462238b821724b7f504ad141c83fcf8f

commit b29f268387f30d1d13ca167029d0d276214afaa0
Author: Oliver Specht <oliver.specht@cib.de>
Date:   Tue Feb 23 12:13:21 2016 +0100

    tdf#97139: prevent loop while formatting small text lines

is presumably the fix

*** This bug has been marked as a duplicate of bug 97139 ***