Bug 97805 - Hyperlinks fail after file save to .xlsx format
Summary: Hyperlinks fail after file save to .xlsx format
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 114453 (view as bug list)
Depends on:
Blocks: XLSX-Hyperlink Hyperlink-Calc
  Show dependency treegraph
 
Reported: 2016-02-12 16:37 UTC by dp
Modified: 2019-03-13 12:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Demo made with LibO V6.0.0.0Beta2 (6.26 KB, application/zip)
2018-01-02 11:18 UTC, Wolfgang Jäger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dp 2016-02-12 16:37:34 UTC
The bug mentioned in the "Summary" can be replicated as follows: 

1) Paste the following hyperlink into cell A1 of a newly created spreadsheet:
=HYPERLINK("http://www.google.com?t=GOOG","GOOG")

2) Test to see that the hyperlink works by ctrl-clicking on it

3) Save the document as an ".xlsx" spreadsheet

4) Test to see that the hyperlink works by ctrl-clicking on it

5) Quit out of Calc

6) Re-launch Calc

7) Open the previously saved spreadsheet

8) Test to see that the hyperlink works by ctrl-clicking on it.  It won't work, but a dialog box with the following will be generated:

"GOOG" is not an absolute URL that can be passed to an external application to open it.
Comment 1 Buovjaga 2016-02-16 11:28:25 UTC
Repro.

dp: set the version to the earliest version you saw this bug in.

Note for testers: for me, it was =HYPERLINK("http://www.google.com?t=GOOG";"GOOG") with the semicolon.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: a6f876d45bd4e41a7143594a6cb11b6893a0f620
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-11_00:07:38
Locale: fi-FI (fi_FI)
Comment 2 QA Administrators 2017-03-06 15:06:59 UTC Comment hidden (obsolete)
Comment 3 dp 2017-03-17 15:13:45 UTC
Bug is still present in Libreoffice Calc Version: 5.2.6.2 on Ubuntu 14.04 (32 bit).
Comment 4 raal 2017-12-14 20:45:34 UTC
*** Bug 114453 has been marked as a duplicate of this bug. ***
Comment 5 Wolfgang Jäger 2018-01-02 11:18:27 UTC
Created attachment 138797 [details]
Demo made with LibO V6.0.0.0Beta2

Induced by a thread in the ask.libreoffice.org/en I created the atteched file with LibO V6.0.0.0Beta2. The bug was still alive. 

The same document originally saved to .ods did not show any issues. 

Reloading the .xlsx version, saving it to .ods now, and loading it again resulted in: 
-1- The link provided by HYPERLINK() worked again.
-2- The single link in one cell worked again but was displayed with an expanded anchor text.
-3- The two links in one cell both did not work nor were they displayed in a hyperlink format, but with light blue text color. 

If somebody is interested I will aslo attach the two versions in .ods.
Comment 6 Richard Harrowell 2018-03-15 11:36:51 UTC
The bug is still present in 6.0.1.1 and 6.0.2.1

Just some more information:

Any hyperlink stored with the optional CELLTEXT argument will not work upon loading from .xlsx or xlsm formats. .xls and .ods formats work fine.

In all cases, if you left click on the cell, the tooltip shows the CELLTEXT instead of the hyperlink and a Ctrl-Click will try and jump to the CELLTEXT contents as a hyperlink.

Edit anything in the hyperlink path - for example backspace over the "h" in "http" and retype "h". Save the cell edit. It now works.

Save as .xlsx, close Calc and reopen. Bug back again.

I was using a Calc spreadsheet with one single cell containing:

=HYPERLINK("http://google.com","Google")

Without the CELLTEXT argument, the hyperlink works fine.

As an extra note, the Help states the ';' character is the separator in the HYPERLINK arguments, but this is now automatically changed to a "," character in 6.0.1.1 and 6.0.2.1. 

Windows 8.1 Pro 64 bit
Version: 6.0.2.1 (x64)  (and 6.0.1.1 x64)
Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU threads: 6; OS: Windows 6.3; UI render: default; 
Locale: en-AU (en_AU); Calc: group
Comment 7 Roel 2019-03-13 09:41:38 UTC
This bug seems to be fixed in 6.2.1.2, installed from the website, running on Ubuntu 18.04. It's still present in the version that comes packaged with Ubuntu LTS: 6.0.7.3

So if any Ubuntu users come across this, you can just grab the latests release from here and you're good to go: https://www.libreoffice.org/download/download/
Comment 8 Buovjaga 2019-03-13 12:09:18 UTC
(In reply to Roel from comment #7)
> This bug seems to be fixed in 6.2.1.2, installed from the website, running
> on Ubuntu 18.04. It's still present in the version that comes packaged with
> Ubuntu LTS: 6.0.7.3

Thanks a lot for testing. Let's close.