Bug 97808 - FILEOPEN: arrowheads added to lines within groups
Summary: FILEOPEN: arrowheads added to lines within groups
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: odf target:5.2.0 target:5.1.2 target:...
Keywords: bibisected, bisected, dataLoss, regression
: 99216 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-02-12 17:20 UTC by thekswenson
Modified: 2016-10-25 19:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
the odp file (5.97 MB, application/vnd.oasis.opendocument.presentation)
2016-02-12 17:22 UTC, thekswenson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description thekswenson 2016-02-12 17:20:24 UTC
User-Agent:       Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build Identifier: LibreOffice 5.0.2.2

It is impossible to remove arrowhead from the lines in this file.
Once removed and the file is saved, the file reopens with the arrowheads.

I'm trying to prepare a presentation for Thursday and I'm stuck!

Reproducible: Always

Steps to Reproduce:
1.open the attached file.
2.remove arrow heads from lines.
3.save the file
4.close Impress
5.open the file
Actual Results:  
See that the arrowheads are back!

Expected Results:  
They should be as when the file was saved.

[Information automatically included from LibreOffice]
Locale: en-US
Module: PresentationDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


Reset User Profile?No.  But this happens on multiple machines.
Comment 1 thekswenson 2016-02-12 17:22:25 UTC
Created attachment 122586 [details]
the odp file
Comment 2 thekswenson 2016-02-12 17:31:49 UTC
I get the same problem with a fresh user.
Comment 3 thekswenson 2016-02-13 12:21:42 UTC
This problem exists in the OSX versions of Libreoffice that I find on the website: 5.1, 5.0, 4.7.
Comment 4 thekswenson 2016-02-13 13:10:33 UTC
I've found two workarounds:

1) install version 4.4.0.1 and then manually edit each line to remove the arrowhead. (saving lines with arrowheads removed will persist under this version only -- reopening the file with any newer version of LibreOffice will add the arrowheads back)

2) in the newest version of openoffice 5.0.2.2: create a new presentation and manually copy and paste THE CONTENTS of every slide into a new slide in the new file. (NOTE: copying the slide itself will not get rid of the problem)
Comment 5 Buovjaga 2016-02-16 11:57:11 UTC
Repro.

Also: there was a big perf issue with this file in 5.2 built on Feb 11th. I clicked a line and the selecting hung. On 5.1 selecting is instant.

Win 7 Pro 64-bit, Version: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)
Comment 6 raal 2016-02-26 07:11:48 UTC
This seems to have begun at the below commit.
Adding Cc: to Michael Stahl; Could you possibly take a look at this one? Thanks

84046a67f51a8a85eceaf2daba4c61cedc1aadd5 is the first bad commit
commit 84046a67f51a8a85eceaf2daba4c61cedc1aadd5
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sun May 31 02:25:02 2015 -0500

    source sha:db1d278dcc308c73eb5edebc20481c96e7f479d8

    source sha:db1d278dcc308c73eb5edebc20481c96e7f479d8

:040000 040000 eb111545b97c5480b9c79437b9ba79a5209adf15 0a8ddcb320eab399a75cb43c1cf56f91e750cfa9 M      instdir

author	Michael Stahl <mstahl@redhat.com>	2015-04-07 20:20:49 (GMT)
committer	Michael Stahl <mstahl@redhat.com>	2015-04-07 20:55:26 (GMT)
commit	db1d278dcc308c73eb5edebc20481c96e7f479d8 (patch)
tree	255401e09027f22bbe0ec35a592f8d50654de191
parent	8f2209b1ebcb053c9f6fa8cb2c39041bec08f9f8 (diff)
tdf#89802: xmloff: fix ODF import of frame with empty style name ref
Comment 7 Michael Stahl (CIB) 2016-02-26 23:07:20 UTC
fixed on master
Comment 8 Commit Notification 2016-02-26 23:08:53 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=af57a81d0c28944b424649f024c28f444a1ab2d9

xmloff: tdf#97808: allow empty draw:marker-start/marker-end/stroke-dash

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2016-02-27 21:28:07 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a33a394bf3b44f56641ee8fd3bc5e29f1776c777&h=libreoffice-5-1

xmloff: tdf#97808: allow empty draw:marker-start/marker-end/stroke-dash

It will be available in 5.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-02-27 21:28:18 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=13ed8b7035a3a3128e246ad2f5b3be059c411c57&h=libreoffice-5-0

xmloff: tdf#97808: allow empty draw:marker-start/marker-end/stroke-dash

It will be available in 5.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2016-02-29 16:15:08 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-1-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b423f5cd8578924623d5349e4d48a35ed60050ec&h=libreoffice-5-1-1

xmloff: tdf#97808: allow empty draw:marker-start/marker-end/stroke-dash

It will be available in 5.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 raal 2016-04-11 10:14:36 UTC
*** Bug 99216 has been marked as a duplicate of this bug. ***