Bug 97812 - Vertical antialiasing insufficient with OpenGL enabled (makes fonts look jagged)
Summary: Vertical antialiasing insufficient with OpenGL enabled (makes fonts look jagged)
Status: RESOLVED DUPLICATE of bug 98380
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-12 18:59 UTC by jorge5150
Modified: 2016-03-03 16:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Jagged fonts with cleartype enabled (142.52 KB, image/jpeg)
2016-02-12 19:00 UTC, jorge5150
Details
Smooth fonts with cleartype disabled (142.15 KB, image/jpeg)
2016-02-12 19:02 UTC, jorge5150
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jorge5150 2016-02-12 18:59:12 UTC
Document fonts are jagged and pixelated when windows cleartype is enabled. Oddly, if cleartype is disabled the fonts are smooth.

In this version the menu fonts are also jagged (it didn't occur in the previous releases).
Comment 1 jorge5150 2016-02-12 19:00:44 UTC
Created attachment 122590 [details]
Jagged fonts with cleartype enabled
Comment 2 jorge5150 2016-02-12 19:02:09 UTC
Created attachment 122591 [details]
Smooth fonts with cleartype disabled
Comment 3 Buovjaga 2016-02-16 12:04:20 UTC
Well, I have jagged fonts with cleartype enabled and no OpenGL enabled in LibreOffice..

Maybe just a duplicate of bug 46817?

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: a6f876d45bd4e41a7143594a6cb11b6893a0f620
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-11_00:07:38
Locale: fi-FI (fi_FI)
Comment 4 Buovjaga 2016-03-03 11:45:52 UTC
Can you give a screenshot with OGL disabled and cleartype enabled?
How does 5.1.1 look for you?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 5 jorge5150 2016-03-03 13:32:45 UTC
(In reply to Beluga from comment #4)
> Can you give a screenshot with OGL disabled and cleartype enabled?
> How does 5.1.1 look for you?
> 
> Set to NEEDINFO.
> Change back to UNCONFIRMED after you have provided the information.

With OpenGL disabled the fonts of the menu bar look better but doesn't affect the fonts of the document.
Comment 6 Buovjaga 2016-03-03 14:55:38 UTC
Ok let's mark this as duplicate of the older one, then.

*** This bug has been marked as a duplicate of bug 46817 ***
Comment 7 Adolfo Jayme 2016-03-03 16:48:29 UTC

*** This bug has been marked as a duplicate of bug 98380 ***