Bug Hunting Session
Bug 97815 - switching to English function names does not work with Add-In functions
Summary: switching to English function names does not work with Add-In functions
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Function
  Show dependency treegraph
 
Reported: 2016-02-12 20:04 UTC by Dennis Roczek
Modified: 2019-01-11 17:05 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Roczek 2016-02-12 20:04:15 UTC
Version: 5.0.4.2 (x64)
Build-ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78
Gebietsschema: de-DE (de_DE)

use some non-English interface. Tools --> Options --> Calc --> Formula --> Check Use English Formula names 

Restart LibO

Try to use =GCD_ADD(5;15;25) from the help https://help.libreoffice.org/Calc/Mathematical_Functions#GCD_ADD

In German environment you have to use =GGT_ADD(99;102;105)

Nasty bug.
Comment 1 Buovjaga 2016-02-16 11:49:47 UTC
Repro.

Win 7 64-bit
Versio: 5.1.0.3 (x64)
Käännöksen ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Maa-asetus: fi-FI (fi_FI)
Comment 2 Dennis Roczek 2016-02-23 12:52:06 UTC
@Winfried somehow in IRC chat with Eike we realized that this report seem to be a duplicate of Bug 50118. But you resolved the other bug?

I will check later which functions do not work.

BTW: I do use Windows 10Pro x64
Comment 3 Winfried Donkers (retired) 2016-02-23 15:22:41 UTC
(In reply to Dennis Roczek from comment #2)
> @Winfried somehow in IRC chat with Eike we realized that this report seem to
> be a duplicate of Bug 50118. But you resolved the other bug?

I remember one or two remaining problems, and saw that these are in comments 11 and up in bug 50118.
As you use Windows, and I could only reproduce the problem with Windows, not with Linux, it seems that you also came across this problem.
I do not have a clue what the cause may be, but I think it will be better to treat this as a separate bug, as bug 50118 was about the fact that Add-In functions were never set to English.
Comment 4 Dennis Roczek 2016-02-24 13:15:30 UTC
OK, I have checked the functions names a bit more. The ones marked with a star might be also called in Engl. UI so.

ABS
AUFGELZINS
AUFGELZINSF
AUSZAHLUNG
BRTEILJAHRE
EDATUM*
EFFEKTIV_ADD
GAUSSFEHLER
GAUSSFKOMPL
GCD
GGANZZAHL
GGT_EXCEL2013
IMAGINÄRTEIL
IMARGUMENT
IMKONJUNGIERT
IMPRODUKT
IMREALTEIL
IMWURZEL
IPMT*
ISPMT*
IStGERADE_ADD
ISTSCHALTJAHR
ISTUNGERADE_ADD
JAHRE
KALENDERWOCHE_EXCEL2003
KGV_EXCEL2003
KOMPLEXE
KUMKAPITAL_ADD
KUMZINSZ_ADD
KURS
KURSDISAGIO
KURSFÄLLIG
KURT
LAUFZEIT_ADD
MDETERM*
MIRR*
MONATE
MONATSENDE
NETTOARBEITSTAGE_EXCEL2003
NOTIERUNGBRU
NOTIERUNGDEZ
NPV
PERMUT
PERMUTATIONA
PMT
POTENZREIHE
PPMT
RENDITE
RENDITEDIS
RENDITEFÄLL
TAGEIMJAHR
TAGEIMMONAT
TBILLÄQUIV
TBILLKURS
TBILLRENDITE
UMRECHNEN_ADD
UNREGERKURS
UNREGERREND
UNREGLEKURS
UNREGLEREND
VRUNDEN
WOCHEN
WOCHENIMJAHR
WURZELPI
XINTZINSFUSS
XKAPITALWERT
ZINSSATZ
ZINSTERMNZ
ZINSTERMTAGE
ZINSTERMTAGNG
ZINSTERMTAGVA
ZINSTERMVZ
ZINSTERMMZAHL
ZUFALLSBEREICH
ZW2
ZWEIFAKULTÄT
(missing some!)

As you can see, many are from the Date&Time and Finance, some from Mathematic (the _Excel2003 ones) and all from the Add_ins category

I will do some more analysis. @beluga can you check which ones (ideal with English names) do not work on your machine / language?
Comment 5 Buovjaga 2016-02-25 14:46:39 UTC
Now I realized =GCD_ADD(5;15;25) does not work even in an English (US) interface.

Same result with
=LCM_ADD(5;15;25)
=WEEKNUM_ADD(24.12.2001;1)
=EFFECT_ADD(0.0525;4)
=DURATION_ADD("2001-01-01";"2006-01-01";0.08;0.09;2;3)
=YEARS(12.12.2004;12.12.2014;1)
=WEEKSINYEAR(12.12.2004)
=WEEKS(12.12.2004;12.12.2014;1)
=ROT13(text)
=MONTHS(12.12.2004;12.12.2014;1)
=ISLEAPYEAR(12.12.2004)
=DAYSINYEAR(12.12.2004)
=DAYSINMONTH(12.12.2004)

Win 7 Pro 64-bit, Version: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)
Comment 6 QA Administrators 2017-03-06 15:48:21 UTC Comment hidden (obsolete)
Comment 7 Dennis Roczek 2017-03-10 20:16:30 UTC
meh, still REPRO with
Version: 5.3.0.3 (x64)
Build-ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU-Threads: 4; BS-Version: Windows 6.19; UI-Render: Standard; Layout-Engine: neu; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 8 Tibor Kovács 2018-05-27 06:02:47 UTC
I Agree it. 
In my LO 5.4.7 Still version (updated from LO 5.4.6, and that version was not tested) some function names are German - even in localised (Hungarian) or "English function names" state of the settings. For example there are such function names:
VRUNDEN( )
WURZELPI( )
ZUFALLSBEREICH( )

The User profile is located in a folder named .../4/..., because it is inherited from the version 4.4.7. (The LO 5.4.6 version was not installed by a clean istall.)

I just renamed the user profile folder to "user_old". The software just created a new one at the next launching, and the issue is gone... (and my customized settings, and macros are gone too, of course... but I can fix them.)
Comment 9 Tibor Kovács 2018-05-27 06:14:59 UTC
Arghhh...

Yes, the issue is gone... in the Localized state. But it appeared again when I switched to English function names.
Comment 10 Winfried Donkers (retired) 2018-05-29 11:35:09 UTC
I am trying to find out what goes wrong. The Add-In code is complex, mostly made to achieve interoperability with weird (obsolete) Excel behaviour, so it may take a while before I even know if I might be able to fix it.
The fact that I cannot reproduce it on Linux platforms (yet) further complicates the matter.
Comment 11 Winfried Donkers (retired) 2018-06-13 07:53:29 UTC
I managed to set up a -temporary- Windows development environment (Windows10pro) and completed an build of current master.

Neither with locale nl_NL, nor with locale de_DE have I been able to reproduce the problem.

This is what I do:
* in Tools - Options - Language Settings I set both User interface and Locale setting to Dutch or German;
* in Tools - Options - Libreofficedev Calc - Formula I disable Use English function names;
* I restart LibreOffice;
* all function names (including Add-In) are locale function names;
* in Tools - Options - Libreofficedev Calc - Formula I enable Use English function names;
* I restart LibreOffice;
* all function names (including Add-In) are English function names.

(The same is the case with LibreOffice 6.0.5.1 and Windows10Pro.)

What steps are needed to reproduce the problem?
Comment 12 Xisco Faulí 2018-06-14 09:33:31 UTC
> What steps are needed to reproduce the problem?

@Dennis Roczek, could you please provide the info requested by Winfried?
Comment 13 Tibor Kovács 2018-06-24 05:41:11 UTC
I have permanently installed the LO 5.4.7. (It is not a portable version.) It was installed by the Hungarian language installer file.
I often use the English user interface (for the English OpenOffice/LibreOffice forum), but in these cases the locale settings still Hungarian im my office suite...
The attached picture shows: When I switch the office suite to English user interface, and the Calc function names to English, then some German function names appeared.

https://drive.google.com/file/d/1JD8AUJ5tSonHN6VxcGuwsDs2Hlcws7Rn/view?usp=sharing
Comment 14 Winfried Donkers (retired) 2018-06-25 07:56:03 UTC
(In reply to Tibor Kovács from comment #13)
> I have permanently installed the LO 5.4.7. (It is not a portable version.)
> It was installed by the Hungarian language installer file.
> I often use the English user interface (for the English
> OpenOffice/LibreOffice forum), but in these cases the locale settings still
> Hungarian im my office suite...
> The attached picture shows: When I switch the office suite to English user
> interface, and the Calc function names to English, then some German function
> names appeared.
> 
> https://drive.google.com/file/d/1JD8AUJ5tSonHN6VxcGuwsDs2Hlcws7Rn/
> view?usp=sharing

I do not doubt the problem exists, I need to know how to reproduce the problem. Can you tell me what your settings are in the Languages tab and give me a step by step account of how you set the formula names to Hungarian and to English, with the results of each step? That way I can try to reproduce the problem and start debugging.
Comment 15 Tibor Kovács 2018-06-25 21:14:35 UTC
"Can you tell me what your settings are in the Languages tab and give me a step by step account of how you set the formula names to Hungarian and to English, with the results of each step?"

I just repeated the test. Here is a short desctription with some illustrations in an .odt file:
https://drive.google.com/file/d/1LSsAfShM0Bq2uCKaVKmLR7jAKO2EPQ0k/view?usp=sharing

-
Comment 16 Winfried Donkers (retired) 2018-06-26 06:44:37 UTC
(In reply to Tibor Kovács from comment #15)
> I just repeated the test. Here is a short desctription with some
> illustrations in an .odt file:
> https://drive.google.com/file/d/1LSsAfShM0Bq2uCKaVKmLR7jAKO2EPQ0k/
> view?usp=sharing

Thank you for your extensive description. 
The first I learned from it was that to reproduce the problem you not only set 'Use English function names' but also change the user interface language.

I added Hungarian to my LO 6.0.5 installation, removed my user profile and set up my user interface to Hungarian, as in your step 2. With me, there is no „Alapértelmezett” in front of "Magyar" as I did not set my Windows user interface to Hungarian.
I followed your steps, except that after step 7 I accepted the message from LO to restart the application with the new user interface. You did not mention this in your description, but I assume you did the same as I did.
But your step 8 does not reflect my situation; I still have 100% English function names.

Although you may think your efforts were wasted (still no reproduction of the problem), you have introduced an aspect that I hadn't studied before, i.e. the changing of the user interface, with a different locale than the user interface (step 7 has English UI, and Hungarian locale).

I will try to reproduce the problem with different settings for user interface and locale.
(I added you to the CC-list of this bug report to make communication easier.)
Comment 17 QA Administrators 2019-01-11 15:22:09 UTC Comment hidden (obsolete)
Comment 18 Tibor Kovács 2019-01-11 16:22:43 UTC
The problem is not raised in my 32 bit LibreOffice 6.1.4 on Windows7 prof. x64 op. sys.
It was a clear installation: I deleted the User profile, and the rest parts of LO installation from the Program Files (x86) after uninstalling of the previous version.
Comment 19 Buovjaga 2019-01-11 17:05:33 UTC
Great, let's close.