Bug 97849 - After opening the LibreOffice, menu is not displayed.
Summary: After opening the LibreOffice, menu is not displayed.
Status: RESOLVED DUPLICATE of bug 96546
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-14 11:32 UTC by userName
Modified: 2016-02-15 15:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description userName 2016-02-14 11:32:51 UTC
After opening the LibreOffice, menu is not displayed.

http://wstaw.org/m/2016/02/12/Beztytu%C5%82u_3.png
http://wstaw.org/m/2016/02/12/Beztytu%C5%82u2.png

I installed LibreOffice several times. I try reset the user profile but it didn't help.
Comment 1 wroot 2016-02-14 15:38:45 UTC
Confirm that on my Windows 7 x64. Not just menus though, it doesn't show the document content also. Tried clean install, deleting user profile. Looks like a video driver or VC++ issue to me (program is not redrawing content properly). You can click on a blank space and the menus will appear (although the fonts look fuzzy). You can open say Options and try to go through various sections, but it will always show the first open section on the right.
Comment 2 V Stuart Foote 2016-02-14 20:46:18 UTC
Any change if you navigate to Tools -> Options -> View and uncheck the "Use
OpenGL for all rendering" button, then restart?

If so, the GPU is unsupported for OpenGL and should be block listed.

And also, please post the "opengl_device.log" from your use cache and copy
paste the build details from the Help -> About LibreOffice dialog.
Comment 3 userName 2016-02-15 08:28:58 UTC
ok, I updated graphic drivers and LibreOffice is working.
Thanks.
Comment 4 V Stuart Foote 2016-02-15 12:18:06 UTC
@userName,

Glad you got it soreted, again helpful for project if you were to post the driver details from the opengl_device.log from the problematic instance, and now from the functional instance.

@wroot, the NEEDINFO is to you now.  Brand of GPU, installed driver version, and supported OpenGL standard. Any change/improvement with a driver update? If so to which driver for the GPU?
Comment 5 wroot 2016-02-15 14:49:16 UTC
I thought i should be automatically getting emails on replies here, but i didn't, so sorry for a late response. This is related to OpenGL as after i have disabled it, it now works fine. I'm using older Nvidia drivers (2 years old, becase my PC was crashing with newer ones).

Renderer: GeForce GTX 550 Ti/PCIe/SSE2
Vendor: NVIDIA Corporation
Memory: 1023 MB
Version: 4.3.0
Shading language version: 4.30 NVIDIA via Cg compiler

NVIDIA Forceware 314.22 WHQL
Comment 6 Wolfgang Jäger 2016-02-15 15:28:16 UTC
See also bug#97644 and forum topic http://en.libreofficeforum.org/node/12674.
Comment 7 V Stuart Foote 2016-02-15 15:55:33 UTC
Thank you both. This is a failure in our OpenGL blacklisting mechanism. You should not have been able to enable OpenGL with your GPU/driver combinations.

Resolving Duplicate of bug 95646 -- please post your opengl_driver.log details there

*** This bug has been marked as a duplicate of bug 95646 ***
Comment 8 V Stuart Foote 2016-02-15 15:56:50 UTC
lets make that the correct dupe bug 96546

*** This bug has been marked as a duplicate of bug 96546 ***