Download it now!
Bug 97851 - Scrolling with touchpad shows undesirable behavior.
Summary: Scrolling with touchpad shows undesirable behavior.
Status: RESOLVED DUPLICATE of bug 97288
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2016-02-14 12:05 UTC by diabolix
Modified: 2019-04-23 15:48 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description diabolix 2016-02-14 12:05:55 UTC
In any scrolling area in the libreoffice suite, every time I try to scroll down or right with the touchpad on my laptop, libreoffice scrolls back up or left respectively in an erratic and unpredictable way.

This is most noticeable in a Calc spreadsheet or Writer document, but I've noticed the same behavior in every scrollable area I was able to find.

Scrolling with a regular mouse wheel works fine.
Comment 1 keitalbame 2016-02-16 14:07:01 UTC
Have the same issue on my laptop, using touchpad with edge scrolling.

Same happens with an external touchpad, using 2 finger scroll.

I'm on Archlinux and there is already same behaviour reported.
Using Cinnamon DE.

https://bbs.archlinux.org/viewtopic.php?id=208966

libreoffice-fresh 5.1.0-1
Comment 2 Mihuleac Sergiu 2016-02-16 17:35:51 UTC
I have the same issue, using Arch Linux - Xfce enviorment - same version 5.1.0-1 - the older one is ok
Comment 3 philbradley 2016-02-16 19:32:48 UTC
Same issue.  Two finger scrolling downwards on my laptop touchpad is erratic; the direction and amount of movement (up or down) seems pretty much random.  Scrolling upwards, however, is fine.

Ubuntu 15.10 64bit.
Libreoffice Writer version: 5.1.0.3
Build ID: 1:5.1.0~rc3-0ubuntu1~wily0
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: en-GB (en_GB.UTF-8)
Comment 4 b149753 2016-02-17 04:18:48 UTC
Having the same issue, most notably scrolling down will scroll up. In some cases where I swipe down hard to produce a long-standing scroll, it will scroll down for the first half and scroll back up for the second half of the duration of the scroll. Scrolling works fine in every other application, and worked fine in previous versions of LibreOffice.

4.4.1-2-Arch GNOME3.
Build ID: 5.1.0.3 Arch Linux build-1
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8)
Comment 5 Christian Seemann 2016-02-17 09:01:33 UTC
Same issue here.

4.4.1-2-ARCH Amwesome WM
Build ID: 5.1.0.3 Arch Linux build-1
Locale: de-DE (en_US.UTF-8)

It's also mentioned in the archlinux bugtracker:

Archlinux: https://bugs.archlinux.org/task/48161
The submitter linked futher locations and even a commit:

https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-5-1&id=b083afac2f0531bacd790cb3ac25353f9a02db5d

https://bugzilla.redhat.com/show_bug.cgi?id=1294208

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=809363
Comment 6 japhir 2016-02-17 11:20:37 UTC
Same issue on Arch Linux x86_64 4.4.1-2 with i3 wm using the touchpad of my thinkpad laptop.
Comment 7 Buovjaga 2016-02-17 13:30:13 UTC
Well, I would say that is about enough confirmations :) -> NEW
Comment 8 Buovjaga 2016-02-18 08:38:23 UTC
Dupe and apparently fixed already.

*** This bug has been marked as a duplicate of bug 97288 ***