Bug 97864 - Cell content showing on screen does not update when OpenGL enabled (Need scrolling)
Summary: Cell content showing on screen does not update when OpenGL enabled (Need scro...
Status: RESOLVED DUPLICATE of bug 96546
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.0.2 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2016-02-15 05:22 UTC by Kevin Suo
Modified: 2016-02-17 11:00 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot: there is "abc" in cell B2, but does not show up on screen. (39.34 KB, image/png)
2016-02-15 05:22 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2016-02-15 05:22:21 UTC
Created attachment 122647 [details]
Screenshot: there is "abc" in cell B2, but does not show up on screen.

Start from 5.1.0.2 rc, when I type in a cell in Calc the cell content does not update for screen display. A work around is to scroll up and down the scroll bar.

Bug disappears when disabling (uncheck) OpenGL via Tools - Options - LibreOffice - View - Enable OpenGL for all rendering.

Steps to reproduce:
1. Make sure OpenGL is enabled.
2. Type in "abc" in any cell.
--> "abc" is in the cell, but you do not see it on screen.
3. Scroll the scroll bar.
--> "abc" shows up.
4. Disable OpenGL, then do step 2.
--> "abc" shows on screen after you type it in the cell.

Broken in:
Version: 5.1.0.2 (x64)
Build ID: ecd3574d51754b043f865cf5bafee286d24db7cc 
(source commit ecd3574d51754b043f865cf5bafee286d24db7cc)
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; 
Locale: zh-CN (zh_CN)
Windows 10 x64

Works in:
Version: 5.1.0.1 (x64)
Build ID: bcace328aabc4c8c10b56daa87da0a2ee6579b5a
(source commit 97e9efdd589ff5b949fb610c83e6b3746f792d9a)

Still Broken in:
Version: 5.1.1.1 (x64) 
Build ID: c43cb650e9c145b181321ea547d38296db70f36e

Works in:
All 5.0 branch versions, including Version: 5.0.5.2 Build ID: 55b006a02d247b5f7215fc6ea0fde844b30035b3

opengl_device.log:
DriverVersion: 9.17.10.4229
DriverDate: 5-27-2015
DeviceID: PCI\VEN_8086&DEV_0116&SUBSYS_21FA17AA&REV_09
AdapterVendorID: 0x8086
AdapterDeviceID: 0x0116
AdapterSubsysID: 0x21fa17aa
DeviceKey: System\CurrentControlSet\Control\Video\{3D9DB5D3-20A3-46C3-92CC-E63F5370C130}\0000
DeviceString: Intel(R) HD Graphics 3000
Comment 1 Kevin Suo 2016-02-15 05:25:23 UTC
Adding keyword "regression, bibisected".
I assume this is bibisected as I have identified the following range: 97e9efdd589ff5b949fb610c83e6b3746f792d9a..ecd3574d51754b043f865cf5bafee286d24db7cc
Comment 2 Michael Meeks 2016-02-17 11:00:05 UTC
Thanks Kevin; the HD 3000 is a known-bad card / driver combination for us I think; so - I think this is a dup of the black-listing not working ;-) (now fixed).

Sorry for the issue & thanks for reporting !

*** This bug has been marked as a duplicate of bug 96546 ***