Bug 97903 - Waiting cursor persists after cancelling "Enter password" dialog in main UI
Summary: Waiting cursor persists after cancelling "Enter password" dialog in main UI
Status: RESOLVED DUPLICATE of bug 82160
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-02-16 15:07 UTC by Tobias Markus (:Tobbi)
Modified: 2016-02-17 13:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Markus (:Tobbi) 2016-02-16 15:07:39 UTC
Steps to reproduce:
1. Open a password-protected file from the LibreOffice main UI (in recent files).
2. Cancel the upcoming "Enter password" dialog by pressing Cancel.
3. Note that the "waiting" cursor persists even though there're no pending processes.

Video of the STR here:
http://screencast.com/t/6dKMdZ7umf

Expected results:
Normal cursor

Current results:
Waiting cursor.
Comment 1 Tobias Markus (:Tobbi) 2016-02-16 15:08:43 UTC
Interesting, for some reason, it didn't record the "waiting cursor". Please try it out for yourself to observe the "issue".
Comment 2 Buovjaga 2016-02-17 12:43:56 UTC
Repro in 5.2, but not 5.1.0.

Win 7 Pro 64-bit, Version: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: a6f876d45bd4e41a7143594a6cb11b6893a0f620
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-11_00:07:38
Locale: fi-FI (fi_FI)
Comment 3 raal 2016-02-17 13:12:12 UTC
Reproducible with Version: 4.5.0.0.alpha0+
Comment 4 Buovjaga 2016-02-17 13:35:04 UTC
It seems to be intermittent. Sometimes I cannot repro with either 5.1 or 5.2.
Comment 5 Maxim Monastirsky 2016-02-17 13:40:35 UTC
I believe it's a variation of Bug 82160.

*** This bug has been marked as a duplicate of bug 82160 ***