Bug Hunting Session
Bug 97921 - Fatal Error / crash on slideshow with 3D transition
Summary: Fatal Error / crash on slideshow with 3D transition
Status: RESOLVED DUPLICATE of bug 108069
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2016-02-17 04:56 UTC by HD
Modified: 2017-05-29 08:43 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
added 3D slide transition (9.62 KB, application/vnd.oasis.opendocument.presentation)
2016-02-17 04:56 UTC, HD
Details
backtrace (16.97 KB, text/plain)
2016-02-18 02:39 UTC, HD
Details

Note You need to log in before you can comment on or make changes to this bug.
Description HD 2016-02-17 04:56:33 UTC
Created attachment 122711 [details]
added 3D slide transition

Version: 5.1.0.3 
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737 
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default;  
Locale: ja_JP (ja_JP)

Open the attachment.
Slide transition "3D Venetian" is set to all slides.
Start slideshow with F5 key then following error message pops up and Impress crashes.
Is there any workaround?

--------------------------------
LibreOffice 5.1 - Fatal Error
SEH Exception: ACCESS VIOLATION
--------------------------------

Works fine with LibreOffice 5.0.4.2 (Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78)

In addition, my settings in 'Options - LibreOffice - View' are:
Enabled - Use hardware acceleration
Enabled - Use anti-aliasing
Disabled - Use OpenGL for all rendering (on restart)
Disabled - Force OpenGL even if blacklisted (on restart)

Best regards.
Comment 1 Buovjaga 2016-02-17 13:14:59 UTC
No crash.

Maybe try getting a backtrace https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg

Win 7 Pro 64-bit, Version: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: a6f876d45bd4e41a7143594a6cb11b6893a0f620
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-11_00:07:38
Locale: fi-FI (fi_FI)
Comment 2 HD 2016-02-18 02:38:43 UTC
(In reply to Beluga from comment #1)
Thank you for your reply.
I got a backtrace. Hope it will help.
Comment 3 HD 2016-02-18 02:39:49 UTC
Created attachment 122748 [details]
backtrace
Comment 4 Julien Nabet 2016-02-18 22:12:38 UTC
On pc Debian x86-64 with master sources updated some days ago, I don't reproduce the crash but had no transition effects.
I noticed these logs on console:
warn:legacy.tools:3338:1:sfx2/source/control/bindings.cxx:2130: No cache for OfficeDispatch!
warn:vcl.gdi:3338:1:vcl/headless/svpgdi.cxx:114: non default depth bitmap, slow convert, upscale the input
warn:legacy.tools:3338:1:svtools/source/control/valueset.cxx:1642: ValueSet::InsertItem(): ItemId == 0
warn:sd.transitions:3338:1:sd/source/core/TransitionPreset.cxx:176: transition node clock-wipe-twelve not found
warn:sd.transitions:3338:1:sd/source/core/TransitionPreset.cxx:176: transition node reverse-clock-wipe-twelve not found
warn:sd.transitions:3338:1:sd/source/core/TransitionPreset.cxx:176: transition node spiral-wipe-top-left-clockwise not found
warn:sd.transitions:3338:1:sd/source/core/TransitionPreset.cxx:176: transition node spiral-wipe-top-right-counter-clockwise not found
warn:sd.transitions:3338:1:sd/source/core/TransitionPreset.cxx:176: transition node spiral-wipe-out-to-bottom-right-clockwise not found
warn:sd.transitions:3338:1:sd/source/core/TransitionPreset.cxx:176: transition node spiral-wipe-out-to-bottom-left-counter-clockwise not found
warn:sd.transitions:3338:1:sd/source/core/TransitionPreset.cxx:176: transition node snake-wipe-top-left-vertical not found
warn:sd.transitions:3338:1:sd/source/core/TransitionPreset.cxx:176: transition node snake-wipe-top-left-horizontal not found
warn:sd.transitions:3338:1:sd/source/core/TransitionPreset.cxx:176: transition node snake-wipe-bottom-right-vertical not found
warn:sd.transitions:3338:1:sd/source/core/TransitionPreset.cxx:176: transition node snake-wipe-bottom-right-horizontal not found

but above all this one:
warn:legacy.osl:3338:1:slideshow/source/engine/transitions/slidetransitionfactory.cxx:1135: TransitionFactory::createSlideTransition(): Unknown type/subtype combination encountered
Comment 5 raal 2016-02-20 19:29:59 UTC
I can reproduce the crash on last slide (click to exit the presentation). Win7.
Version: 5.2.0.0.alpha0+
Build ID: ef02de2698d90fd874bddf3146165cbe85487bc5
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-19_23:40:50
Comment 6 ivana.bosnic 2016-02-29 16:07:04 UTC
I was repeatedly getting the same fatal error, every time the slideshow started in 5.1.0.3 (different presentations, NO transitions!), several times in the row. 
Finally, LO crashed with another, bigger error window (couldn't see the text, as LO was not responding) with a reset/reconnect of my monitor display. 
After that, I can't force it to crash, neither with my presentations, or with your attached test.
Comment 7 Armin Le Grand 2016-03-18 15:03:06 UTC
Could not reproduce on win7 32bit office using

Version: 5.2.0.0.alpha0+
Build ID: 4331b137fdbe6992ca63ceb70a6f48ed6f9a86ea
CPU Threads: 8; OS Version: Windows 6.1; UI Render: GL; 
Locale: de-DE (de_DE)
Comment 8 Aron Budea 2017-01-25 14:22:04 UTC
Might be the same as bug 103236, hard to verify. Maybe if it crashes with the exact same slide transitions as mentioned here, that's a strong confirmation: https://bugs.documentfoundation.org/show_bug.cgi?id=103236#c2

Note that the mentioned bug only affects GPUs that lack capability for newer OpenGL versions.
Comment 9 Xisco Faulí 2017-02-28 16:57:12 UTC
I can't reproduce it in

Versión: 5.3.0.3
Id. de compilación: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
Subpr. de CPU: 1; Versión de SO: Windows 6.1; Repr. de IU: predet.; Motor de trazado: HarfBuzz; 
Configuración regional: es-ES (es_ES); Calc: group
Comment 10 Buovjaga 2017-03-04 15:50:42 UTC
HD, raal: can you still make it crash with 5.3?
Comment 11 raal 2017-03-04 16:12:38 UTC
No crash with Version: 5.4.0.0.alpha0+
Build ID: e25bf8505cfaa3599c2e78a7c56729280f27373e
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-20_23:33:04

@HD, please retest.
Comment 12 Julien Nabet 2017-05-29 08:43:27 UTC
Don't hesitate to reopen this tracker if you still reproduce with next version 5.3.4.
You can also give a try with a master daily build (see http://dev-builds.libreoffice.org/daily/master/)

*** This bug has been marked as a duplicate of bug 108069 ***