Download it now!
Bug 97939 - Can't paste inside Writer from other documents or pages
Summary: Can't paste inside Writer from other documents or pages
Status: RESOLVED DUPLICATE of bug 62196
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Paste
  Show dependency treegraph
 
Reported: 2016-02-17 15:28 UTC by Alberto
Modified: 2020-03-08 18:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alberto 2016-02-17 15:28:07 UTC
I've recently noticed that the "paste" function in LibreOffice Writer is sometimes broken: I can't copy-paste text from other documents or internet pages and I can only do that INSIDE the same text document I've opened in LibreOffice. 

While I'm writing this report, I'm having this problem again: I've tried copying-pasting some text from an internet page (opened in Edge) inside my document in LibreOffice Writer but it's not working. 
I've tried pasting it inside the Windows text editor and it's been pasted correctly. I've tried copying that text again from the text editor and pasting inside LibreOffice Writer also, but it didn't work.

I don't know why and when this happens, but I'm experiencing it right now.

I'm using the latest (x64 bit) version of the software and I'm on Windows 10.
Comment 1 Alberto 2016-02-17 15:30:47 UTC
I've tried with some drag 'n drop from the web page inside the text document. It worked, luckily, but of course it's not the best solution!
Comment 2 Buovjaga 2016-02-18 18:50:46 UTC
Please give an example web page.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 3 Tony 2016-02-22 16:09:11 UTC
I am also having similar issues.  I noticed last week, February 17th.  I work via Citrix for work, copying text from MS Word and Excel sheets, and pasting into Libre Writer, as Libre Writer is more responsive than MS via Citrix.  

I am able to copy and paste text initially after opening writer, however after the first successful pasting, the paste functionality goes away.  I will close the application, re open it, and then will run into the same situation.  I am able to copy and paste within the document, and I can take copied text from the MS documents and paste them in Chrome and they show up.  z

I have unistalled and reinstalled Libre and am still having this issue.  

I am running Windows 8.1
Comment 4 Buovjaga 2016-02-22 16:25:16 UTC
Which LibreOffice version are you guys using btw.?
Comment 5 Tony 2016-02-23 17:51:26 UTC
I was using 4.4.7.  I uninstalled and re installed version 4.4.6, but I am running into the same issues.  However, prior to 4.4.7 I never had this issue.
Comment 6 Buovjaga 2016-02-23 19:30:17 UTC
What if you do: paste special - unformatted text?
Comment 7 Alberto 2016-02-24 09:46:54 UTC
I'm sorry if I didn't answer before, but I'm very busy these days! 

1-With "Web page" I mean anyone, it happened to me in different web pages when I've tried copying-pasting the text. It doesn't happen immediately when I open LibreOffice, and it happens from other text files opened with other programs too. It's not easy to understand "WHEN" this happens, indeed.
If you want an example of web page, I can give it to you anyway:
http://digilander.libero.it/moses/adorno3.html


2-I'm using the 5.1.0.3 x64 bit version on Windows 10 x64

3-I tried using "paste special - unformatted text" but seems that it didn't work too!
Comment 8 Tony 2016-02-24 13:59:28 UTC
Paste special doesn't work for me either.
Comment 9 Buovjaga 2016-02-24 14:45:14 UTC
(In reply to Alberto from comment #7)
> http://digilander.libero.it/moses/adorno3.html

I tried by first copying and pasting some text inside writer. Then I copied and pasted from the Adorno page. No problem pasting in any format.

Win 7 Pro 64-bit, Version: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)
Comment 10 Alberto 2016-02-24 16:06:07 UTC
(In reply to Beluga from comment #9)
> (In reply to Alberto from comment #7)
> > http://digilander.libero.it/moses/adorno3.html
> 
> I tried by first copying and pasting some text inside writer. Then I copied
> and pasted from the Adorno page. No problem pasting in any format.
> 
> Win 7 Pro 64-bit, Version: 5.1.0.3 (x64)
> Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
> CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
> Locale: fi-FI (fi_FI)

I know: it usually works, indeed. The problem in the copy-paste process from ANY web page (or other text documents) shows up when the bug appears, not before.

That's why it was almost useless linking you that page: if the bug shows up, you can open ANY web page - or text document - and try copy-pasting anything. :)
Comment 11 Tony 2016-02-24 20:05:15 UTC
It seems like the clipboard is resetting when copying from outside of Writer.  I just noticed when copying text from a different application (Chrome), that the clipboard icon in Writer went from colored, to grey.  If I highlight text within the Writer document, the clipboard icon will become colored again, and then if I copy text from a separate application, the icon will remain colored, and I will be able to paste the copied text.  However, if I then attempt to copy additional text from outside of the Writer document, the clipboard icon will turn grey again.  

I also just tried the following. 

1.  Copied text within Writer document. 
2.  Copied text within Chrome (Ctrl C)
3.  Copied the same text again (Ctrl C) and the clipboard icon turns grey.
Comment 12 Tony 2016-03-08 18:57:06 UTC
Do we have any idea how to resolve this issue?
Comment 13 Ludovic CHEVALIER 2016-03-28 11:12:54 UTC
I'm using LibreOffice 5.1.2~rc1-1 on Debian Testing and I can't paste text from master document to writer. But I can paste text from Writer document to master.
Comment 14 lupajor 2017-01-06 12:53:31 UTC
I am experiencing the same problem pasting formatted text from the app OneNote. Today I have V 5.1 but the problem 


Versión: 5.1.6.2 (x64)
Id. de compilación: 07ac168c60a517dba0f0d7bc7540f5afa45f0909
Subprocesos de CPU: 4; Versión de SO: Windows 6.19; Renderizado de IU: predeterminado; 
Configuración regional: es-AR (es_AR); Calc: CL

How to reproduce it: 
1. Create a note in OneNote
2. Paste some text copied from a web page (Just paste it formatted, it is the default behavior in OneNote)
3. Copy the text of the note just copied.
4. Open Writer. It starts with a new blank document.
4. Paste.
5. You will see a blink but the text is not pasted.

Note1: If I open another app, for example Wordpad, and try to paste the same text, it is pasted, so the clipboard content is OK.
Note2: If I select "Paste Special" --> "Unformatted text", then the text is pasted in Writer.
Note3: If I open Notepad and paste the text and then I copy it (the unformatted text now in Notepad) and try to paste on Writer, the text is pasted. 
Note4: The step I described below are exactly what I did, but I find that the problem is the same as copying from a web page and pasting it on Writer, as it happened to another in this thread (Alberto).
Comment 15 lupajor 2017-01-06 12:57:55 UTC
(In reply to lupajor from comment #14)
> I am experiencing the same problem pasting formatted text from the app
> OneNote. Today I have V 5.1 but the problem 

I forgot some text: Today I have LibreOffice V 5.1 but I have experienced the same problem in previous versions.
Comment 16 C 2017-01-29 06:13:05 UTC
Version: 5.2.4.2
Build ID: 3d5603e1122f0f102b62521720ab13a38a4e0eb0
CPU Threads: 2; OS Version: Windows 6.2; UI Render: default; 
Locale: en-US (en_US); Calc: group

This happens to me as well, and i don't see what triggers it. Everything works fine, until it suddenly doesn´t.

when i try to paste, even from notepad (plain text, ie not only from browser) it doesn´t recognize the new text. LO chooses to paste the last "internal" content in clipboard. obviously confirmed via the source field in "paste-special".
Comment 17 conrad_heimbold 2017-04-27 01:03:30 UTC
Version: 5.2.2.2
Build-ID: 1:5.2.2-0ubuntu2
CPU-Threads: 4; BS-Version: Linux 4.8; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

I had the same problem. Linux is also affected. 
Drag'n'Drop did not help. 
Restarting LibreOffice did help however. 
Unfortunately, I did not collect a debug log; sorry.
Comment 18 conrad_heimbold 2017-04-27 01:07:00 UTC
I also had this problem in LibreOffice Draw, where I could not paste a picture. 
LibreOffice Draw always pasted the object that was last copied inside of LibreOffice Draw. Objects copied from the outside of LibreOffice could not get through (could not be pasted)!
Comment 19 Buovjaga 2017-04-27 11:05:06 UTC

*** This bug has been marked as a duplicate of bug 62196 ***
Comment 20 Jens Löhnhardt 2018-09-20 07:46:58 UTC
Same issue here!   

Once a single character whitin LibreOffice has been copied, it's not possible to do an "external" copy&paste.

The solution here was conflicting software.  A CTI-Software worked in background, waiting for a key-combination to start a new telephone-call.
(UNIFY - CommunicationClient, desktopintegration.exe)

Once this app has been terminated, the copy&paste bug has vanished.

Hope this will help others.
Comment 21 Timur 2020-03-08 18:45:02 UTC
Last comment wrongly changed the status. 
Duplicate of this one or some other paste bug.

*** This bug has been marked as a duplicate of bug 62196 ***