Bug 97943 - Presentation-mode: Slides aren't correctly displayed anymore (with openGL and hardware accel)
Summary: Presentation-mode: Slides aren't correctly displayed anymore (with openGL and...
Status: RESOLVED DUPLICATE of bug 40534
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
Reported: 2016-02-17 18:37 UTC by bordfeldt
Modified: 2017-10-10 10:58 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:

screenshot of presentation-mode (26.65 KB, image/png)
2016-02-17 18:37 UTC, bordfeldt
presentation bug 97943 (12.77 KB, application/vnd.oasis.opendocument.presentation)
2016-02-17 19:11 UTC, bordfeldt
LO-view-options for bug 97943 (69.83 KB, image/png)
2016-02-18 06:45 UTC, bordfeldt

Note You need to log in before you can comment on or make changes to this bug.
Description bordfeldt 2016-02-17 18:37:34 UTC
Created attachment 122739 [details]
screenshot of presentation-mode

LO on Windows 10 Pro

Steps to reproduce:
Open impress with a new empty presentation -> on the first slide add the following title (only for testing): "This is a test for what happens in impress" -> click on "Start from first slide"-button to enter presentation-mode -> look what happens (see attached screenshot)?
Comment 1 Joel Madero 2016-02-17 18:42:07 UTC
Please attach the sample document that you are asking us to create ;) Always better (our time is horribly stretched).

Marking as NEEDINFO - once you attach please mark as UNCONFIRMED. Thanks
Comment 2 bordfeldt 2016-02-17 19:10:46 UTC
Hi Joel,

here it is!

Comment 3 bordfeldt 2016-02-17 19:11:23 UTC
Created attachment 122742 [details]
presentation bug 97943
Comment 4 Cor Nouws 2016-02-17 19:26:15 UTC
Hi Bordfeldt,

thanks for the file!

Can you please report what your settings are for
Tools > Options > LibreOffice > View ..Hardware Acceleration and Use OpenGL ..?

I do not see a problem on Ubuntu.
Comment 5 bordfeldt 2016-02-18 06:44:32 UTC

you can see the settings in the attached screenshot.

Comment 6 bordfeldt 2016-02-18 06:45:12 UTC
Created attachment 122754 [details]
LO-view-options for bug 97943
Comment 7 bordfeldt 2016-02-20 09:44:24 UTC
Today I installed LO on Xubuntu 14.04 64bit. There the problem doesn't exist.
Comment 8 bordfeldt 2016-02-20 13:18:18 UTC
Installed LO on the same machine on Windows7 Pro 64bit (It's a dual-boot-machine: Xubuntu/Win7).
Start LO the first time->open a new and empty presentation->start presentation mode: LO crashes with a fatal error "SEH Exception: ACCESS VIOLATION".
Comment 9 bordfeldt 2016-02-20 13:27:08 UTC
Now it works on Windows 7 too! I had to deactivate the option->view->use OpenGL... and then it works. Perhaps it would be useful to deactivate this option by default.
Comment 10 Buovjaga 2016-02-20 15:31:38 UTC
Works ok here.

For Windows 10, maybe try with 5.1.1 RC1? For parallel install: https://wiki.documentfoundation.org/SI-GUI

Win 7 Pro 64-bit, Version: (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)
Comment 11 Joel Madero 2016-02-20 16:24:34 UTC
Seems like it's WFM now. Closing it up. Thanks all!
Comment 12 Buovjaga 2016-02-20 16:51:39 UTC
Let's wait for confirmation about Windows 10, the original report was about it.
Comment 13 bordfeldt 2016-02-20 17:35:51 UTC
You are right Beluga,

the problem still exists on my Windows 10 system. So the bug shoulb be still UNCONFIRMED. Perhaps somebody else could test it on a Windows 10 system.
Comment 14 Joel Madero 2016-02-20 18:07:21 UTC
LibreOffice Version:
Build ID: 8896851ddb02d043f3ebcc5b27b907369f0d6730
CPU Threads: 2; OS Version: Windows 6.2; UI Render: GL; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-1, Time: 2016-02-11_23:47:09
Locale: en-US (en_US)

No problem at all

Have you tried resetting your user profile?
Comment 15 Buovjaga 2016-02-20 18:34:29 UTC
Well, he didn't test with 5.1.1 yet.
Comment 16 bordfeldt 2016-05-15 18:01:17 UTC
Problem still exists in
Comment 17 bordfeldt 2016-08-03 16:02:01 UTC
problem still exists for me on

I tried to reset my user profile, but this doesn't help. Because LO creates a new user profile with activated OepnGL by default and this doesn't work on my machine: LO hangs, windows, menus ... aren't displayed correctly, windows gives me the error-message, that the graphics driver had to be resetted ...

The only way to get slides displayed correctly in presentation mode is to activate the option->view->use OpenGL... but only for a short time. Then LO is useless because of the problems with activated OpenGL as described above.

I think there are problems with the graphics interface in my machine, an intel HD Graphics 520.
Comment 18 Buovjaga 2016-08-03 16:30:19 UTC
Could you paste to a comment the contents of the file C:\Users\User\AppData\Roaming\LibreOffice\4\cache\opengl_device.log ?
Comment 19 bordfeldt 2016-08-04 08:29:09 UTC
Here it is:

DriverDate: 7-6-2016
DeviceID: PCI\VEN_8086&DEV_1916&SUBSYS_00151414&REV_07
AdapterVendorID: 0x8086
AdapterDeviceID: 0x1916
AdapterSubsysID: 0x00151414
DeviceKey: System\CurrentControlSet\Control\Video\{5730D0D1-E741-4493-B31E-71316B62D0B3}\0000
DeviceString: Intel(R) HD Graphics 520
Comment 20 Michael Meeks 2016-08-04 09:19:39 UTC
We should have GL disabled on all Windows 7 and Intel in and 5.2.0.final onwards - precisely because of crashing issues. Things should work on Windows 10 - clearly if you force GL on anyway, you can experience the joys of ignoring the black-list ;-) but ...

I'd love to know if the problem recurs with a clean user-profile of the above versions; thanks ! =)
Comment 21 bordfeldt 2016-08-04 11:35:31 UTC
Hi Michael,

I tried to use a clean user-profile and moved my old one. But I can't use LO with a new clean user profile, because of crashing and massive displaying problems, because of the by default activated OpenGL-option. With a new user-profile I'm even not able to go to the option-menu, because I can't see it, and so I'm not able to deactivate the OpenGL-setting to get a working profile again. So I have to use my old user-profile.
Comment 22 Buovjaga 2016-08-04 11:51:25 UTC
Could try with a fresh profile, which you edit according to these instructions to disable OpenGL: https://wiki.documentfoundation.org/OpenGL#Crash_on_program_start
Comment 23 bordfeldt 2016-08-04 12:08:08 UTC
I succeeded with starting with a new fresh user-profile. I even didn't need to use the registry patch, because LO gave me enough time to change the Open-GL-setting.

But the problem with presentation mode in impress still exists.
Comment 24 KB Lee 2016-08-06 06:03:10 UTC
Windows 10 v1607 64-bit
LO 64-bit
MS Surface Pro 4

Presentation mode works only when the following two options are in Disable state.

Hardware Acceleration: Disable
Use OpenGL: Disable

When any one or both of the parameters are Enabled, various display defects start appearing on screen.
Comment 25 bordfeldt 2016-08-06 08:35:59 UTC
Thank you KB_Lee,

this is the solution for me:

in options -> view:

Hardware Acceleration: Disable
Use OpenGL: Disable

Now slides are displayed correctly in presentation mode.
Comment 26 Buovjaga 2016-08-06 10:16:32 UTC Comment hidden (obsolete)
Comment 27 KB Lee 2016-08-07 04:51:56 UTC Comment hidden (obsolete)
Comment 28 KB Lee 2016-08-07 04:57:20 UTC Comment hidden (obsolete)
Comment 29 KB Lee 2016-08-07 05:01:21 UTC
(In reply to Buovjaga from comment #26)
> Interesting to hear that HW acceleration had to be disabled as well.
> KB Lee: can you paste to a comment the contents of your
> C:\Users\User\AppData\Roaming\LibreOffice\4\cache\opengl_device.log

This is the copy from MS Surface Pro 4, which requires both Hardware Acceleration and OpenGL to be DISABLED in order to function properly in Presentation Mode.

DriverDate: 7-6-2016
DeviceID: PCI\VEN_8086&DEV_1926&SUBSYS_00151414&REV_0A
AdapterVendorID: 0x8086
AdapterDeviceID: 0x1926
AdapterSubsysID: 0x00151414
DeviceKey: System\CurrentControlSet\Control\Video\{700B5DB9-776A-4660-9BBD-5E032D4369AE}\0000
DeviceString: Intel(R) Iris(TM) Graphics 540
Comment 30 Buovjaga 2016-12-21 15:19:48 UTC
*** Bug 104773 has been marked as a duplicate of this bug. ***
Comment 31 bordfeldt 2017-02-13 18:09:36 UTC
problem still exists in, if I activate the 
"use hardware accelaration" option.
Comment 32 Xisco Faulí 2017-10-10 10:58:24 UTC
It looks like a duplicate of bug 40534

*** This bug has been marked as a duplicate of bug 40534 ***