Bug 98040 - Hovering over hidden comment does not display properly with compositing window managers (Gtk2)
Summary: Hovering over hidden comment does not display properly with compositing windo...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 100408 104025 (view as bug list)
Depends on:
Blocks: Calc-Comments GTK2 Desktop-Environment
  Show dependency treegraph
 
Reported: 2016-02-20 23:42 UTC by rebelxt
Modified: 2018-12-08 12:44 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Comments in Linux Mint 17.3 (18.48 KB, image/jpeg)
2016-02-20 23:42 UTC, rebelxt
Details
Comments is Linux Mint 16 (30.92 KB, image/jpeg)
2016-02-20 23:43 UTC, rebelxt
Details
Comment in Linux Mint 18 and LO 5.4.3.2 (15.19 KB, image/png)
2017-12-06 06:19 UTC, gmolleda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rebelxt 2016-02-20 23:42:47 UTC
Created attachment 122831 [details]
Comments in Linux Mint 17.3

Comments in LO Calc should be displayed in a box with a solid background. In Linux Mint 17.3, there is no box, and the background is only under the text. See the Mint17.jpg attachment. I see the bug in the following versions of LO: 

Linux Mint 17.3 (installed):
LibreOffice 3.3.4 OOO330m19 (Build:401)
Version 3.6.7.2 (Build ID: e183d5b)
Version: 5.0.3.2 Build ID: 1:5.0.3~rc2-0ubuntu1~trusty2
Version: 5.2.0.0.alpha0+ Build ID: bc20c6d0f397c0c1aef6ef7d6f750c2f81af8db6

Linux Mint 17.3 (Live CD on two different computers):
Version: 5.0.3.2 Build ID: 1:5.0.3~rc2-0ubuntu1~trusty2

I see a slightly different appearance in Linux Mint 16. The background is there, but the box is  not. See the Mint16.jpg attachment.

Linux Mint 16 (installed):
Version: 4.1.3.2 Build ID: 410m0(Build:2)

The bug is not seen in the following versions of LO:

Linux Mint 13 (installed):
LibreOffice 3.5.7.2 Build ID: 350m1(Build:2)
Version: 4.5.0.0.alpha0+ Build ID: 7201fa0dddd7dd0352f69fd2b2b64efcb361ccad

Linux Mint 15 (installed):
Version 4.0.2.2 (Build ID: 400m0(Build:2))

Linux Mint 17.3 installed in VirtualBox (Linux Mint 17.3 host):
Version: 5.0.3.2 Build ID: 1:5.0.3~rc2-0ubuntu1~trusty2

Windows 8.1 (installed):
Version: 5.1.0.3 Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f73

Occasionally, the first time you mouse-over a comment, the box is displayed, but the second time it is not. FWIW, if the wallch wallpaper changer is installed, the box and background will be displayed when the wallpaper is changed.
Comment 1 rebelxt 2016-02-20 23:43:49 UTC
Created attachment 122832 [details]
Comments is Linux Mint 16
Comment 2 Joel Madero 2016-02-21 00:09:06 UTC
@Jay - you might checking this out since you run Mint?
Comment 3 Yousuf Philips (jay) (retired) 2016-02-21 01:09:31 UTC
Cant reproduce this on Linux Mint 17.3 Mate, but the issue with attachment 122831 [details] shows up on Linux Mint 17.2 XFCE and Ubuntu XFCE 14.04 and something similar to attachment 122832 [details] shows up in Linuxt Mint 17.3 Cinnamon.

The problem only occurs when hovering over, but not when you unhide the comment.
Comment 4 Yousuf Philips (jay) (retired) 2016-02-21 16:56:53 UTC
@rebelxt: What desktop environment are you using?
Comment 5 rebelxt 2016-02-21 20:45:14 UTC
@Jay: I assume you mean hardware. The Linux all run on a homebuilt desktop with an Intel CPU, using the built-in graphics; all OS's use their default graphics driver. Windows 8.1 runs on an ASUS laptop, also with an Intel CPU and the built-in graphics.
Comment 6 Yousuf Philips (jay) (retired) 2016-02-22 05:15:20 UTC
@rebelxt: No i meant which desktop environment version of Linux Mint are you running. Are you running Cinnamon, Mate, XFCE or KDE?
Comment 7 rebelxt 2016-02-22 07:38:35 UTC
All of them are Mate.
Comment 8 Yousuf Philips (jay) (retired) 2016-02-22 09:22:28 UTC
So i did some more testing and the bug showed up on

- no background box -
Ubuntu Mate 15.10 live usb
Ubuntu Mate 16.04 live usb
Xubuntu 16.04 live usb
Mint Mate 17.3 live usb
- partial background box -
Mint Cinnamon 17.3 live usb

But it didnt show up here

Kubuntu 16.04 live usb
Ubuntu Gnome 16.04 live usb
Mint Mate 17.1 installed

All these were tested from the same laptop with Intel 945GM internal graphics. I'm assuming it may have to do with the liberoffice-gtk package.

@Bjoern, @Maxim: Any thoughts?
Comment 9 Yousuf Philips (jay) (retired) 2016-02-22 10:22:48 UTC
Tested Ubuntu 16.04 and it was the same partial background box found in Mint Cinammon.
Comment 10 rebelxt 2016-02-22 15:00:28 UTC
Tested on Arch Mate (LO 5.0.5.2). The background box displayed properly.
Comment 11 rebelxt 2016-03-09 19:05:46 UTC
Alt+Tab will cause the comment background to be displayed, as long as the cursor is not moved from the cell.
Comment 12 Buovjaga 2016-06-17 18:40:27 UTC
*** Bug 100408 has been marked as a duplicate of this bug. ***
Comment 13 Buovjaga 2016-11-29 13:06:59 UTC
*** Bug 104025 has been marked as a duplicate of this bug. ***
Comment 14 QA Administrators 2017-11-30 06:27:20 UTC Comment hidden (obsolete)
Comment 15 gmolleda 2017-12-06 05:10:52 UTC
Confirmed in actual version 5.4.3.2
About of LibreOffice (Acerca de LibreOffice in my spanish version):

Versión: 5.4.3.2
Id. de compilación: 92a7159f7e4af62137622921e809f8546db437e5
Subprocs. CPU: 4; SO: Linux 4.4; Repres. IU: predet.; VCL: gtk2; 
Configuración regional: es-ES (eo.UTF-8); Calc: group

Esperanto is the best international language: more fair and neutral.
Konfirmita en la nuna versio 5.4.3.2
Pri LibreOffice (Acerca de LibreOffice en mia hispana versio)
Comment 16 Jean-Baptiste Faure 2017-12-06 05:53:32 UTC
Not reproducible with LO 5.4 under Ubuntu 16.04 x86-64 with GTK3 backend.

Best regards. JBF
Comment 17 gmolleda 2017-12-06 06:19:48 UTC
Created attachment 138232 [details]
Comment in Linux Mint 18 and LO 5.4.3.2
Comment 18 gmolleda 2017-12-06 06:25:13 UTC
My system is:

Release Linux Mint 18 Sarah 64-bit

Kernel Linux: 4.4.0-101-generic #124-Ubuntu SMP Fri Nov 10 18:29:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

MATE 1.14.1

LibreOffice 5.4.3.2
It looks good while I write the comment.
I exit the comment editing mode.
I put the mouse over and it goes wrong (without box) (view attached image)
Comment 19 Yousuf Philips (jay) (retired) 2017-12-06 14:22:09 UTC
So on Linux Mint 18 (MATE 1.14.1), the issue only happens with the gtk2 backend and only when using the 'Marco + Compositing' or 'Compiz' window managers, but not when using 'Marco' or 'Marco + Compton' window managers.

Version: 6.1.0.0.alpha0+
Build ID: 2618e4a13d719122e6358d9d96864d1691e56a02
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group threaded
Comment 20 QA Administrators 2018-12-07 03:47:04 UTC Comment hidden (obsolete)
Comment 21 gmolleda 2018-12-07 09:20:59 UTC
Versión: 6.0.6.2
Id. de compilación: 1:6.0.6-0ubuntu0.18.04.1
Subprocs. CPU: 4; SO: Linux 4.15; Repres. IU: predet.; VCL: gtk3; 
Configuración regional: es-ES (eo.UTF-8); Calc: group
Output command ~$ inxi -F
System:    Host: XXXXX-X555LA Kernel: 4.15.0-42-generic x86_64 bits: 64
           Desktop: Xfce 4.12.3 Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: ASUSTeK product: X555LA v: 1.0 serial: N/A
           Mobo: ASUSTeK model: X555LA v: 1.0 serial: N/A
           BIOS: American Megatrends v: X555LA.308 date: 08/14/2014
Battery    BAT0: charge: 13.6 Wh 83.8% condition: 16.2/37.3 Wh (43%)
CPU:       Dual core Intel Core i7-4510U (-MT-MCP-) cache: 4096 KB
           clock speeds: max: 3100 MHz 1: 2308 MHz 2: 1520 MHz 3: 1476 MHz
           4: 1477 MHz
Graphics:  Card: Intel Haswell-ULT Integrated Graphics Controller
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.01hz
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile
           version: 4.5 Mesa 18.0.5

Other computer:
System:    Host: ZZZZZZZ Kernel: 4.15.0-42-generic x86_64 bits: 64
           Desktop: Cinnamon 3.8.9  Distro: Linux Mint 19 Tara
Machine:   Device: desktop Mobo: ASUSTeK model: P8H61-M LE R2.0 v: Rev x.0x serial: N/A
           BIOS: American Megatrends v: 0610 date: 08/10/2012
CPU:       Quad core Intel Core i7-3770 (-MCP-) cache: 8192 KB
           clock speeds: max: 3400 MHz 1: 1600 MHz 2: 1600 MHz 3: 1600 MHz
           4: 1600 MHz
Graphics:  Card: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1280x1024@60.02hz
           OpenGL: renderer: Mesa DRI Intel Ivybridge Desktop
           version: 4.2 Mesa 18.0.5


It works!
All perfect.

Ĝi funkcias!
Ĉio estas perfekta.
Comment 22 Jean-Baptiste Faure 2018-12-08 12:44:38 UTC
Thank you very much for your tests and feedback. So closing as WorksForMe.
Please feel free to reopen if you disagree.

Best regards. JBF