Bug 98044 - Ruler messed up on HiDPI screens
Summary: Ruler messed up on HiDPI screens
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HiDPI Rulers
  Show dependency treegraph
 
Reported: 2016-02-21 01:29 UTC by gunwald
Modified: 2018-11-02 21:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Messed up rulers and ugly icons (81.41 KB, image/png)
2016-02-21 01:29 UTC, gunwald
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gunwald 2016-02-21 01:29:35 UTC
Created attachment 122834 [details]
Messed up rulers and ugly icons

LibreOffice 5.0 and 5.1 aren’t usable on heigh resolution screen. Currently I am using a QHD+ screen (3.200 × 1.800) on Windows 10. The rulers look crazy and the icons remind me on Win 3.1. 

Is this a bug? Is there a work around or do I simply have to use 640x480 to work with LibreOffice?
Comment 1 Buovjaga 2016-02-21 17:18:57 UTC
Your icon issue is a dupe of bug 75485
Comment 2 gunwald 2016-02-21 17:25:37 UTC
I think only the icons a mentioned there, but as you can see at the picture above, the rulers are messed up too.
Comment 3 Adolfo Jayme 2016-02-22 08:46:22 UTC
@gunwald: Yes, but the icons and the rulers are two different things. Please use each bug report to file an *individual* issue.

Anyway, I can confirm that the ruler numbers are not displayed correctly in high-DPI.
Comment 4 QA Administrators 2017-03-06 16:03:06 UTC Comment hidden (obsolete)
Comment 5 Alexander E. Patrakov 2018-11-02 21:00:55 UTC
Cannot reproduce (with 240 dpi set in MATE preferences dialog) on version 6.1.2.1. I could reproduce it earlier.