Bug 98066 - Some drop-downs in dialogs render wrongly in high-contrast-mode/theming
Summary: Some drop-downs in dialogs render wrongly in high-contrast-mode/theming
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: High-Contrast
  Show dependency treegraph
 
Reported: 2016-02-21 21:32 UTC by Martin Lemburg
Modified: 2017-11-02 11:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing a wrongly rendered drop-down (17.66 KB, image/png)
2016-02-21 21:32 UTC, Martin Lemburg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Lemburg 2016-02-21 21:32:50 UTC
Created attachment 122854 [details]
Screenshot showing a wrongly rendered drop-down

In some dialogs drop-down lists with graphical elements, like e.g. line style render wrongly with hardcoded color black in high-contrast-mode/theming with a black high-contrast-theme like e.g. high-contrast-#1.
With this theme the default window background color is black.
Comment 1 Adolfo Jayme 2016-02-22 15:43:45 UTC
This, as it looks, is for Windows versions up to 7, as the high-contrast themes have been rewritten since Windows 8 and should behave differently.
Comment 2 Buovjaga 2016-04-06 05:28:34 UTC
Reproduced.

Win 7 Pro 64-bit, Version: 5.1.1.3 (x64)
Build ID: 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)
Comment 3 QA Administrators 2017-10-28 17:46:52 UTC Comment hidden (obsolete)
Comment 4 Martin Lemburg 2017-11-02 11:33:00 UTC
I tested with LibreOffice version 5.4.2.2 and found no occurrence of wrongly rendered drop-down controls anymore.

BTW testing in high-contrast on Windows is not that difficult. The hotkey LeftAlt+LeftShift+PrintScr is normally enabled and toggles the high-contrast-mode with its default or last used high-contrast theme/design.
Comment 5 Buovjaga 2017-11-02 11:46:30 UTC
Great, let's close.