Bug 98071 - Right aligned tabs before page numbers (in updated) table of contents not saved, docx (WPS)
Summary: Right aligned tabs before page numbers (in updated) table of contents not sav...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-TableofContents
  Show dependency treegraph
 
Reported: 2016-02-22 03:21 UTC by Konstantin Kharlamov
Modified: 2018-07-27 13:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test to reproduce (14.61 KB, application/wps-office.docx)
2016-02-22 03:21 UTC, Konstantin Kharlamov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Kharlamov 2016-02-22 03:21:19 UTC
Created attachment 122859 [details]
test to reproduce

The document have a screwed «table of contents», e.g. every item is surrounded with a random and different number of spaces. To fix that a simple update of the table is enough, but the problem is that the table of contents isn't saved. Steps to reproduce:

Ⅰ) Open the attached document with a screwed table of contents
Ⅱ) Right-click the table, and select «Update Index or Table», thus getting the table fixed.
Ⅲ) Save the document in docx format.
Ⅳ) Close, and open the document again — the table of contents is screwed again, like if it didn't saved.

That happens in «docx», but didn't happen in «odt» format, i.e. if you save it in «odt» instead, then upon reopening everything would be okay. A test document is attached (I removed the seemingly unnecessary parts, like the text, and the first page where I did use tab-stops, but feel free to ask more if it's needed).
Comment 1 Buovjaga 2016-03-02 18:42:26 UTC
Repro.

Version: 5.1.0.3 64-bit
Build ID: 5.1.0.3 Arch Linux build-1
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)

Version: 5.2.0.0.alpha0+
Build ID: 8fab3bf91331a4ac9e3b8f44a46f579dbf7aeafb
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 2 Cor Nouws 2016-05-03 14:41:56 UTC
I see the same problem in 4.3.7.2
In version 4.0.0.1 the TOC looks a bit bad in a different way, but the right aligned numbers (tab with dots) looks fine...
Comment 3 QA Administrators 2018-01-18 03:34:00 UTC Comment hidden (obsolete)
Comment 4 Konstantin Kharlamov 2018-01-18 05:45:29 UTC Comment hidden (obsolete)
Comment 5 Timur 2018-07-27 13:07:22 UTC
WFM in master 6.2+.