Bug 98100 - tooltips unavailable in valuesets when "General\Extended tips" is checked
Summary: tooltips unavailable in valuesets when "General\Extended tips" is checked
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:5.3.0 target:5.2.2
Keywords:
Depends on:
Blocks: Color-Picker-Widget
  Show dependency treegraph
 
Reported: 2016-02-23 06:25 UTC by tommy27
Modified: 2017-01-24 13:31 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Expert config stanzas for the tooltip timeouts (13.05 KB, image/png)
2016-03-03 03:22 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tommy27 2016-02-23 06:25:20 UTC
while testing Bug 98097 on 5.2.x I realized that all mouse-over-tags disappeared from master.

while in 5.0.4.2 and 5.1.0.3 the mouse-over-tags are missing just from the "Recent" area and are visible in the color grid above, in 5.2.x there's no mouse-over-tag in that area too.

this is a 5.2.x regression
Comment 1 Yousuf Philips (jay) (retired) 2016-02-23 12:14:21 UTC
I have tooltips in master on Linux and Windows.

Version: 5.2.0.0.alpha0+
Build ID: 943af6cd6f07c2e0ccd067f661d8dc664eea1e4b
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86@71-TDF, Branch:master, Time: 2016-02-21_01:49:02
Locale: en-US (en_US.UTF-8)
Comment 2 Buovjaga 2016-02-28 16:22:49 UTC
I see tooltips in color grid.

OpenGL?

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 85fcf15ff41ceb95f46dee586ff7187551be4955
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-27_09:23:38
Locale: fi-FI (fi_FI)
Comment 3 tommy27 2016-03-02 05:52:03 UTC
still no tooltips at all in the color picker grid using LibO 5.2.0.0.alpha0+
Build ID: f64a190f52f9e9c76c2a0d18f072938b5df93aae
CPU Threads: 4; OS Version: Windows 6.29; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-02-28_14:15:03
Locale: it-IT (it_IT)

my system is Win8.1 x64
turning OpenGL on/off makes no difference.
Comment 4 Yousuf Philips (jay) (retired) 2016-03-02 07:39:15 UTC
@Tommy: Does clearing your profile make any difference?
Comment 5 raal 2016-03-02 08:23:15 UTC
I can confirm with Version: 5.2.0.0.alpha0+
Build ID: aaca25d67eb5ea252730cdcf555ecc04ce04a5e6
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-24_23:58:47

no repro win10 , Version: 5.2.0.0.alpha0+
Build ID: 817f6bd75e98a321c238b5906bfcb031908914b2
CPU Threads: 1; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-03-01_01:14:57
Comment 6 V Stuart Foote 2016-03-02 14:52:42 UTC
Do you have Tools -> Options -> Extended tips: checked-on?  Please un-check and retest.

The visible tool-tips including the color labels are altered by that setting.

Otherwise no repro Windows 10 Pro en-US

Version: 5.2.0.0.alpha0+
Build ID: a6f876d45bd4e41a7143594a6cb11b6893a0f620
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-11_00:07:38
Locale: en-US (en_US)

Version: 5.2.0.0.alpha0+
Build ID: 393f11f88648e1c7cace6224aa7afcbf9d68ddd6
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-26_00:41:15
Locale: en-US (en_US)
Comment 7 tommy27 2016-03-02 21:35:23 UTC
retested using march 1st 5.2.0.0 daily build

If "Tools/Options/LibreOfficeDev/General/Extended tips" is checked no tooltips are shown... this affect the color picker and even all the other toolbar buttons... so the bug is not limited to color picker 

if the ".../Extended tips" is unchecked tooltips are again visible.

this seems illogical to me and in 5.0.4.2 it works exactly the opposite way.
so this looks like a regression.
Comment 8 tommy27 2016-03-02 21:38:46 UTC
(In reply to Yousuf (Jay) Philips from comment #4)
> @Tommy: Does clearing your profile make any difference?

no difference.
Comment 9 V Stuart Foote 2016-03-02 22:18:20 UTC
(In reply to tommy27 from comment #7)
> retested using march 1st 5.2.0.0 daily build
> 
> If "Tools/Options/LibreOfficeDev/General/Extended tips" is checked no
> tooltips are shown... this affect the color picker and even all the other
> toolbar buttons... so the bug is not limited to color picker 
> 
> if the ".../Extended tips" is unchecked tooltips are again visible.
> 
> this seems illogical to me and in 5.0.4.2 it works exactly the opposite way.
> so this looks like a regression.

Actually, this is correct. At 5.1 the Tool-tips check box was removed as it is always enabled unless the extended-tips are selected which override them.

Otherwise the "Extended tips" only become available when the offline help is installed.  And when offline help is installed and toggled active the "default" tool-tips--e.g. color names are replaced by the more descriptive tool-tip for the block of content.  When not installed--the extended tool-tips are either blank, or are generic.

For example the color picker the extended tip, when en-US offline help is installed, becomes "Click a color. Click No Fill to remove a background or highlighting color. Click automatic to reset a font color" for the color picker.

What might be useful UI would be to provide a UNO action for a GUI button & keyboard short-cut to toggle between basic and extended tool-tips.

Also, the Extended tips when help is installed is always available for a11y AT support.
Comment 10 Yousuf Philips (jay) (retired) 2016-03-03 01:50:03 UTC
(In reply to tommy27 from comment #8)
> (In reply to Yousuf (Jay) Philips from comment #4)
> > @Tommy: Does clearing your profile make any difference?
> 
> no difference.

With a cleared profile, Extended Tips would be unchecked, so it should work.

@raal: Can you do a bibisect and see when the Tooltips checkbox was removed.
Comment 11 V Stuart Foote 2016-03-03 03:22:12 UTC
Created attachment 123175 [details]
Expert config stanzas for the tooltip timeouts

(In reply to Yousuf (Jay) Philips from comment #10)

> @raal: Can you do a bibisect and see when the Tooltips checkbox was removed.

No need. This was done as brokered by Adolfo:

https://gerrit.libreoffice.org/17481

https://cgit.freedesktop.org/libreoffice/core/commit/?id=0b0fb87fbac36ef9fbf3dfeac0f1372617f4b3e4

@Samuel, Adolfo -- any thoughts on situation?

Also, looking at it I remain a little uncomfortable about removal of the a11y HelpTip timer options. Defaults are reasonable, but it becomes unreasonable to expect AT dependent users to navigate Expert Configuration to make UI changes to what worked well from GUI panel--just saying.
Comment 12 Samuel Mehrbrodt (CIB) 2016-04-14 14:10:11 UTC
Well the proper solution would be to implement a fallback to use the default tips when no extended tips are installed.
Comment 13 Björn Michaelsen 2016-08-24 22:00:30 UTC
Assuming bisected to imply bibisected, thus adding the latter. This is to make queries for "bibisected" not miss out bisected bugs.
Comment 14 Caolán McNamara 2016-08-31 10:02:17 UTC
I see this problem in valuesets, e.g. color grid, with extended tips enabled and no help installed. However "this affect the color picker and even all the other toolbar buttons... so the bug is not limited to color picker" is not what I experience. The tool items in e.g. the standard toolbar report the "quick" tooltips when the "extended" tips are unavailable.

Looking at the valueset ValueSet::RequestHelp it seems that the intent is ambiguous for the BALLOON (extended) case and I feel the intent was always to report the same tooltip for normal and extended case so I'll fix that under this bug id.

Missing tooltips for valuesets with no offline help installed seems to have been "always", so clearing the various regression/bisect stuff.

If there is still an outstanding problem where there's no helptip shown when Extended Tips is enabled, and a helptip shown when Extended Tips is disabled can you file a new bug for that and put me on CC
Comment 15 Commit Notification 2016-08-31 10:03:51 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=281027ea88d4d683449d4ce2cdb0563223741465

Resolves: tdf#98100 no valueset tooltips with extended tips...

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2016-09-02 16:34:02 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=934c79c22ee63c25538e25b18d780377cc09f3af&h=libreoffice-5-2

Resolves: tdf#98100 no valueset tooltips with extended tips...

It will be available in 5.2.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.