Bug 98106 - FILESAVE: Hidden and empty rows became visible when export to .XLSX or .XLS file
Summary: FILESAVE: Hidden and empty rows became visible when export to .XLSX or .XLS file
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium major
Assignee: Bartosz
QA Contact:
URL:
Whiteboard: target:5.3.0 target:5.2.5 target:5.4....
Keywords: preBibisect
: 91153 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-02-23 10:04 UTC by Merlinux
Modified: 2017-02-10 08:37 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
File with cells hidden (55.58 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2016-02-23 10:04 UTC, Merlinux
Details
OriginalFIle after save with patched version of LibreOffice (7.18 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2016-06-17 14:19 UTC, Bartosz
Details
OriginalFile after save to .xls with patched version of LibreOffice (10.50 KB, application/vnd.ms-excel)
2016-06-19 15:25 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Merlinux 2016-02-23 10:04:42 UTC
Created attachment 122902 [details]
File with cells hidden

Cells that were previously hidden became visible.

Steps:

Download OriginalFile.xlsx

Open It > make no changes > select "Save As" > Select any location on computer > keep xlsx file extension > Save

Open the saved file once again. Now Instead of having lines from 1 to 12 hidden, only Line 1 remains hidden. Lines 2 - 12 became visible.

(This is related to Bug 74932)
Comment 1 m.a.riosv 2016-02-24 03:27:30 UTC
Hi @Merlinux,

I can't reproduce.
Win10x64
Version: 5.1.1.1 (x64)
Build ID: c43cb650e9c145b181321ea547d38296db70f36e
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL;
Comment 2 Merlinux 2016-02-24 12:59:05 UTC
@m.a.riosv

Hi.
I just upgraded to 5.1.1.1 (x64) and run it under Win10x64 machine but i still get the same bug.

Everytime i make a "Save As" to the downloaded file it gets messed up!
Comment 3 m.a.riosv 2016-02-24 13:14:42 UTC
Please try resetting the user profile, sometimes solves strange issues.
https://wiki.documentfoundation.org/UserProfile
Usually it's enough renaming/deleting the file "user/registrymodifications.xcu",  it affects all the options in Menu/Tools/Options, and the files "user/basic/dialog.xlc" and "scrip.xlc" are overwritten, additionally custom colors in "user/config/standard.soc" are lost.
Comment 4 Merlinux 2016-02-24 14:58:26 UTC
I've renamed the user folder, forcing it to create a new one whit all inside it - It did not solve the problem! :(

Can anything else be tried?
Comment 5 m.a.riosv 2016-02-24 22:53:06 UTC
Hi Merlinux, sorry my mistake doing the test.

Reproducible
Win10x64
Version: 5.0.5.2 (x64)
Build ID: 55b006a02d247b5f7215fc6ea0fde844b30035b3
Version: 5.1.1.1 (x64)
Build ID: c43cb650e9c145b181321ea547d38296db70f36e
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL;
Comment 6 Bartosz 2016-06-16 02:03:52 UTC
I think I found possible fix in xetable.cxx
Comment 7 Bartosz 2016-06-17 14:19:12 UTC
Created attachment 125705 [details]
OriginalFIle after save with patched version of LibreOffice

I managed to fix that issue with hidden rows.
COuld you please check if attached xlsx file is correct now?
Comment 8 m.a.riosv 2016-06-17 14:25:51 UTC
The file looks fine, but as expected after save with
Win10x64
Version: 5.1.4.2 (x64)
Build ID: f99d75f39f1c57ebdd7ffc5f42867c12031db97a
CPU Threads: 1; OS Version: Windows 6.19; UI Render: GL; 

rows are visible again.
Comment 9 Bartosz 2016-06-17 14:30:59 UTC
Review for the fix:
https://gerrit.libreoffice.org/#/c/26421/
Comment 10 Bartosz 2016-06-17 22:01:06 UTC
@m.a.riosv Could you please check also if this file is working correctly with MS Excel?

I tested it with Office 365, but I would confirm if it also working correctly with standard MS Excel.
Comment 11 m.a.riosv 2016-06-17 22:07:56 UTC
Sorry, but I have not MS Excel.
Comment 12 Bartosz 2016-06-19 15:25:09 UTC
Created attachment 125733 [details]
OriginalFile after save to .xls with patched version of LibreOffice

The fix is also resolving issue with hidden rows, also after save to .xls file.
Comment 13 Bartosz 2016-06-20 08:26:14 UTC
I have tested .xlsx and .xls files generated by Libreoffice (with empty rows hidden), and everything is working perfectly fine on MS Excel 2010.
Comment 14 Katarina Behrens (CIB) 2016-06-20 13:35:08 UTC
*** Bug 91153 has been marked as a duplicate of this bug. ***
Comment 15 Merlinux 2016-06-20 17:30:15 UTC
Great! Any ETA?
Comment 16 Commit Notification 2016-06-22 23:05:13 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=228c25fd17727660a3372307e3f73dbcff5e71d2

tdf#98106 Preserving hidden and empty rows after xlsx export

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2016-12-05 17:41:19 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7dd19273530730478b5ed24b79f42ac480c7ae43&h=libreoffice-5-2

tdf#98106 Preserving hidden and empty rows after xlsx export

It will be available in 5.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2016-12-07 23:36:15 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f5bca308c910c4486b2e5c8f67f628ae8e9c2457

sc-perf: call RowHidden() only once, tdf#98106 follow-up

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 m.a.riosv 2016-12-11 12:49:02 UTC
Tested
Version: 5.3.0.0.beta1+ (x64)
Build ID: 7f47d68c4310b8bae09286a81036a6fa669a1705
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; Layout Engine: new; 
TinderBox: Win-x86_64@62-TDF, Branch:libreoffice-5-3, Time: 2016-12-08_16:10:30
Locale: es-ES (es_ES); Calc: CL

Version: 5.4.0.0 alpha0+, TB Win-x86@39, Time 2016-12-10_23:50:52
Comment 20 Merlinux 2017-01-16 20:06:48 UTC
I can confirm as well this bug is now fixed.

Thank you!
Comment 21 Justin L 2017-02-09 12:39:00 UTC
The fix has caused several bug reports.  If these are not properly fixed before 5.2.6 is released, I suggest that this patch be reverted from the 5.2 series.
Comment 22 Justin L 2017-02-09 12:45:34 UTC
changed earliest version affected to 3.5 - the earliest I could test with bibisect43all.
Comment 23 Commit Notification 2017-02-10 08:37:01 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3e67dc9dbbd802dd82b92304098aaa44e70c014c&h=libreoffice-5-2

revert tdf#98106 Preserving hidden and empty rows after xlsx export

It will be available in 5.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.