Bug 98114 - Printing does not honor the orientation in page properties in Linux/Mac
Summary: Printing does not honor the orientation in page properties in Linux/Mac
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
: 98115 113150 (view as bug list)
Depends on:
Blocks: Print
  Show dependency treegraph
 
Reported: 2016-02-23 15:34 UTC by Kevin
Modified: 2020-06-30 07:35 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
Spreadsheet which refuses to print in portrait orientation in spite of settings (53.99 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-02-23 15:34 UTC, Kevin
Details
Portrait prints landscape (160.53 KB, image/jpeg)
2017-10-28 23:30 UTC, Ken Adkison
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin 2016-02-23 15:34:14 UTC
Created attachment 122911 [details]
Spreadsheet which refuses to print in portrait orientation in spite of settings

The attached file has the "portrait" property set by Format->page->page but prints in landscape orientation (as it was when first created and printed).
Comment 1 m.a.riosv 2016-02-24 03:32:51 UTC
Hi @Kevin,

I can't reproduce.
Win10x64
Version: 5.1.1.1 (x64)
Build ID: c43cb650e9c145b181321ea547d38296db70f36e
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL;

Do you see it right on preview?
Comment 2 raal 2016-02-24 20:27:54 UTC
no repro, print to pdf printer
 Version: 5.2.0.0.alpha0+
Build ID: 91a7580e03d5b47c6e2513afce85ddee45e730b6
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-04_00:17:43
Comment 3 Kevin 2016-02-24 23:24:58 UTC
I tried on my own Win 10 x64, and agree it works properly there.

On Xubuntu 14.04, x64, it fails.  Both when printing to my network printer and printing to file, it greys out the button that could change the orientation, and prints landscape.
Comment 4 Kevin 2016-02-24 23:27:16 UTC
I forgot to mention: LibreOffice is Version: 5.1.0.3
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 8; OS Version: Linux 3.16; UI Render: default; 
Locale: en-US (en_US.UTF-8)
Comment 5 m.a.riosv 2016-02-24 23:36:17 UTC
Please take a look to see if this thread can help:

https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1040037
Comment 6 Kevin 2016-02-25 02:52:10 UTC
That thread seems to be about a different case.  There, as I understand it, a page formatted for landscape was printed portrait and this some of the content bled off the side of the paper.  That's not the problem in this bug.
Comment 7 Buovjaga 2016-03-14 14:25:50 UTC
Which printer are you using?
Same printer for Win & Linux?
You did not reply to: Do you see it right in preview?

Works here.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: b89feb8018bf3610faf01e73995d576f6566e20b
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-03-07_03:36:17
Locale: fi-FI (fi_FI)
Comment 8 Timur 2016-03-14 16:10:13 UTC
Do you have "Use only paper size from printer preferences" checked on the "Print-Options" tab?
Comment 9 Kevin 2016-03-19 03:34:44 UTC
The print preview shows landscape.

Print -> Options 3 checkbox unchecked for "Use only paper size from printer preferences" as are the other two checkboxes.

Running on Xubuntu 14.04, LibreOffice Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 8; OS Version: Linux 3.16; UI Render: default; 
Locale: en-US (en_US.UTF-8)
Comment 10 Lloyd 2016-05-15 14:50:40 UTC
I have run into same problem. Can't set format for landscape printing and envelope printing has become impossible.

Regardless of orientation set tp print envelopes, it will print them in portrait mode.
Using Linux Mint with 2 different Epson printers. (NX415 and Artisan 837)
Comment 11 Buovjaga 2016-05-15 15:41:38 UTC Comment hidden (obsolete)
Comment 12 Kevin 2016-05-16 20:29:15 UTC
I do not have an Epson printer.  I usually use my HP Color Laserjet CP 2025, but can use a Canon inkjet in an emergency.  I noticed this problem on the HP.
Comment 13 Buovjaga 2016-05-17 09:38:20 UTC
Lloyd and Kevin have the opposite problems, though (landscape vs. portrait).
This is a bug that sounds like Kevin's problem: bug 92190. It has been identified as OS X -only, but there was no test on Linux.
Comment 14 Evan Carroll 2016-07-26 19:16:17 UTC
I can confirm this problem is still present in Ubuntu 16.04 with a Zebra Technologies ZTC GK420d ZBR6533416, installed under CUPS. I set the size to 4.04x6.06 (4inx6in with 0.02 margin). Then in Format Page set the Orientation to Landscape. This displays the page as 4.04x6.06. I would expect it to print though on a normal 4x6 label. It doesn't. It still prints portrait, it just crops off 2 inches.
Comment 15 lancegrnwd 2016-10-18 02:59:48 UTC
I can confirm this problem with version 5.2.1.2 Running on Linux Mint 18, printing to an Epson WF-7520.  It does it in all the apps, the only work around is to export it as pdf and use another program.
Comment 16 Timur 2016-10-18 06:58:30 UTC Comment hidden (obsolete)
Comment 17 Timur 2016-10-18 07:06:31 UTC
*** Bug 98115 has been marked as a duplicate of this bug. ***
Comment 18 Buovjaga 2016-10-24 18:32:27 UTC
Let's set to NEW and see, if this will get any traction.
Comment 19 Timur 2016-10-25 10:23:20 UTC
So far, we have the following:

Kevin: on Xubuntu 14.04, x64, LO 5.1.0.3 fails, spreadsheet refuses to print in portrait orientation. Both when printing to his network printer and printing to file, HP Color Laserjet CP 2025
Lloyd: similar problem, can't set format for landscape printing and envelope printing has become impossible, Linux Mint with 2 different Epson printers. (NX415 and Artisan 837)
Raal: no repro with LO master, print to pdf printer, Linux (which?)
Evan: confirm in Ubuntu 16.04 with a Zebra Technologies ZTC GK420d ZBR6533416, installed under CUPS. set the Orientation to Landscape, still prints portrait, it just crops off 2 inches
lance: confirm with LO 5.2.1.2 on Linux Mint 18, printing to an Epson WF-7520. 
Timur: no repro in VM Ubuntu 16.04 with print to file nor with Lexmark printer connected as shared USB device from Windows host
No repro on Windows, so far Linux-only where reporduced.

I wouldn't really agree with setting to New until it's clear where the problem is.

BTW Kevin, when reporting bugs, please give immediately in the first post as mush details as you can, after you tested different options.
Comment 20 Timur 2017-10-16 16:27:38 UTC
*** Bug 113150 has been marked as a duplicate of this bug. ***
Comment 21 Timur 2017-10-16 16:28:48 UTC
Sam from Bug 113150: 

Using MacOS and L.O.  5.4.2.2.  Used other 5+ on website; does the same thing too (was hoping the bleeding edge version would have this fixed).  I checked Format > Page  and orientation is set to print Portrait.  But printer wants to do Landscape.  Brother HL-L2340D Series.  Do not have any other issues with other programs (including LibreOffice 4+).
Comment 22 Sam 2017-10-16 16:51:05 UTC
For further clarification, when I indicated the problem was having with other 5+ I was NOT clear; my apologies.  I was referring to 5.3.6.  The problem happens here as well.  I downloaded 5.4.2 (which what I was referring to when I said bleeding edge version).  

I just downloaded version 5.3.1.1, and this works fine with the printing in Portrait.
Comment 23 Ken Adkison 2017-10-28 23:30:44 UTC
Created attachment 137348 [details]
Portrait prints landscape

OSX v. 10.12.6 (16G29) iMAC 27" I7 fully updated
Epson WF-4630 printer
Portrait prints landscape
Checked all settings, very carefully in Format->Page, File->Printer Settings, Sidebar->Page->Format, OSX printer settings and Epson print settings/presets.

File->Print Preview is okay
Printing to .pdf followed by printing pdf is okay

Portate setting seems to be overridden to landscape.  Please see attached jpeg.
Thank You
Comment 24 Ken Adkison 2017-10-29 15:24:12 UTC
Uninstalled LibreOffice ver. 5.3.6.1 and installed Version: 5.4.2.2
Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4

Problem persists
We had no problems with this computer and printer using LibreOffice in the past.  Other programs continue to print fine.  I suspect an incomplete or incorrect print handoff is occurring to OSX and/or the print driver.  I have been using these style Epson printers for a number of years because of how simple and stable the MAC and driver work together.  
Ran the printer firmware updater and found the firmware unto date (epson 9.60).  OSX does not need a driver installed from epson you simply plug it in or put it on the lan and it configures itself.

If you can tell me what to test, I will do detailed testing and make and forward log files to you to help pin this down.
Ken
Comment 25 Ken Adkison 2017-10-30 14:14:46 UTC
My i7 iMAC reliably shows this bug on LibreOffice version 5.4.2.2.
I loaded two older versions side by side with 5.4.2.2:
v5.3.4.2 prints fine 
v5.3.3.2 prints fine
v5.4.2.2 retested and still corrupts orientation. Attempts to force it it back by electing opposite orientation does not work.
I don't have other older copies to find out which version went wrong.
I have done all the usual rebooting and reinstalling tricks to no avail.

My MacBook Air, with the same updated OSX v.10.12.6, works fine with the same printer using an older version of LibreOffice v. 5.2.6.2.

Thank You for helping to improve LibreOffice - Ken
Comment 26 Timur 2017-11-01 15:25:10 UTC Comment hidden (obsolete)
Comment 27 Buovjaga 2017-11-01 15:44:41 UTC Comment hidden (obsolete)
Comment 28 Bernie 2017-11-07 16:14:27 UTC
I love libra office, but your latest release prints portrait oriented documents as landscape only.  Attempts to change it in the program has not worked.  hope you can fix that little problem.  In the meantime I have to use another word process program.
Comment 29 TT 2017-12-04 05:07:35 UTC
I'm experiencing the same problem on a Mac ever since upgrading to 5.4.  The latest update doesn't fix this.  The Importance of this bug should be changed to Major.
Comment 30 Timur 2017-12-08 07:35:22 UTC
Since Bug 92190 is fixed in 5.4.4 please test this one again with that version.
Comment 31 Kevin 2017-12-10 03:50:33 UTC Comment hidden (no-value)
Comment 32 Jon K. 2017-12-10 06:35:08 UTC
See https://ask.libreoffice.org/en/question/121393/libreoffice-540-writer-portrait-document-prints-as-landscape/ which gives a workaround of resizing the document (say 8.51 x 11.00). 

I see this problem with Writer, Epson Artisan 530, Mac OS 10.13.2 High Sierra, LibreOffice 5.4.3.2 and 5.4.4.1 (pre-release).
Comment 33 Buovjaga 2017-12-10 13:13:25 UTC
(In reply to Jon K. from comment #32)
> I see this problem with Writer, Epson Artisan 530, Mac OS 10.13.2 High
> Sierra, LibreOffice 5.4.3.2 and 5.4.4.1 (pre-release).

Then this is different from Bug 92190.

Kevin: you can use this without messing up your system: http://libreoffice.soluzioniopen.com/
Comment 34 Kevin 2017-12-10 15:29:03 UTC
That site (http://libreoffice.soluzioniopen.com) confuses me a little.  What are "fresh" and "still" versions.
In any event, I do not see a 5.4.4+ version.  The numbered versions seem to stop at 5.4.3

I tried the 6.0.0.0 preview, and the bug remains, with a few changes....

The orientation in the printer preferences can be set to portrait, which as I recall was not possible before.
However the preview and actual printing are landscape.
Comment 35 QA Administrators 2019-05-07 02:42:16 UTC Comment hidden (obsolete)
Comment 36 TT 2019-05-07 13:27:25 UTC
I can't seem to reproduce this problem on Mac OS X any more, but it's been so long since I've used Libre Office that I'm not sure I'm testing it correctly.
Comment 37 Kevin 2019-05-07 21:10:12 UTC
Responding to the request to re-test.  I have changed printers from a HP to a Brother, if it matters.  What probably matters more is that the upgrade to the OS also upgraded LibreOffice, and I no longer see the problem.

Now on Xubuntu Bionic (18.04.1), and LibreOffice 6.0.7.3, Build  1:6.0.7-0ubuntu0.18.04.5.

In this configuration, portrait printing works just fine.
Comment 38 Buovjaga 2019-05-07 21:16:44 UTC
Thanks for testing, let's close.
Comment 39 canon ij setup 2019-05-13 06:35:20 UTC Comment hidden (spam)
Comment 40 Ken Adkison 2019-05-13 12:58:09 UTC
We had this "portrait printing in landscape" problem using OSX but it was resolved with an update some time ago.  Sorry, I should have updated the post at that time.
Comment 41 123.hp.com 2020-01-24 09:53:08 UTC Comment hidden (spam)
Comment 43 Ken Adkison 2020-01-31 13:57:47 UTC
(In reply to Ken Adkison from comment #25)
> My i7 iMAC reliably shows this bug on LibreOffice version 5.4.2.2.
> I loaded two older versions side by side with 5.4.2.2:
> v5.3.4.2 prints fine 
> v5.3.3.2 prints fine
> v5.4.2.2 retested and still corrupts orientation. Attempts to force it it
> back by electing opposite orientation does not work.
> I don't have other older copies to find out which version went wrong.
> I have done all the usual rebooting and reinstalling tricks to no avail.
> 
> My MacBook Air, with the same updated OSX v.10.12.6, works fine with the
> same printer using an older version of LibreOffice v. 5.2.6.2.
> 
> Thank You for helping to improve LibreOffice - Ken

Current versions don't have this problem - RESOLVED WORKSFORME
Comment 49 123.hp.com 2020-02-03 06:14:22 UTC Comment hidden (spam)
Comment 50 123.hp.com 2020-02-03 06:24:48 UTC Comment hidden (spam)
Comment 51 Michael Weghorn 2020-02-03 07:30:08 UTC
Previous comments are not directly related to this bug report, so closing again as WORKSFORME.
Comment 52 elisa martin 2020-06-30 06:43:58 UTC Comment hidden (spam)