Bug 98115 - Request abililty to choose orientation when printing
Summary: Request abililty to choose orientation when printing
Status: RESOLVED DUPLICATE of bug 98114
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-23 15:40 UTC by Kevin
Modified: 2017-12-08 07:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Document that cannot be printed in portrait orientation. (53.99 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-02-23 15:40 UTC, Kevin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin 2016-02-23 15:40:29 UTC
Created attachment 122912 [details]
Document that cannot be printed in portrait orientation.

I cannot find a way to print the attached document in portrait orientation.  The page property is set portrait (Format->page->page), but it prints in landscape anyway.

There is a separate bug filed to solve that problem.  This enhancement request would be to unlock the orientation in the File->Print->Probperties dialog and make it control the printing orientation.  Or else in the File->Printer Settings->properties dialog, or both.  As things stand, those properties are greyed out and immutable.
Comment 1 raal 2016-03-06 10:59:39 UTC
I can not confirm with Version: 5.2.0.0.alpha0+
Build ID: aaca25d67eb5ea252730cdcf555ecc04ce04a5e6
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-24_23:58:47

Printing portrait works in pdf export and physical printer.What do you see in print preview?
Comment 2 Robinson Tryon (qubit) 2016-03-11 22:32:11 UTC
(In reply to raal from comment #1)
> Printing portrait works in pdf export and physical printer.What do you see
> in print preview?

awaiting info from OP, so
Status -> NEEDINFO
Comment 3 Kevin 2016-03-19 03:37:41 UTC
Print preview is landscape.
Comment 4 Buovjaga 2016-03-27 15:40:02 UTC
Print preview is portrait for me.

What printer model do you have?

64-bit, KDE Plasma 5
Build ID: 5.1.1.3 Arch Linux build-2
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 5 Kevin 2016-03-27 16:52:27 UTC
Intrigued by non-confirmation by y'all, I removed the LibreOffice from the Xubuntu 14.04 repos, and now have
Version: 5.1.0.3
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 8; OS Version: Linux 3.16; UI Render: default; 
Locale: en-US (en_US.UTF-8)

This version has the document in portrait in print preview, but seems stuck in landsace in the thumbnail that shows when click File->print, and there's no way to change that (including Properties).  It prints landscape.

The actual printer is an HP Color Laserjet 2025 with duplexer.  In software that allows changing the orientation, it prints as directed.
Comment 6 Timur 2016-10-18 07:06:31 UTC
This looks like a problem with the document from Bug 98114 and not general enhancement request. 
I'm aware of https://bugs.documentfoundation.org/show_bug.cgi?id=45971#c11 but I think it' wrong.

*** This bug has been marked as a duplicate of bug 98114 ***