Bug Hunting Session
Bug 98132 - Format cell dialog very slow to pop up
Summary: Format cell dialog very slow to pop up
Status: RESOLVED DUPLICATE of bug 63551
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace, perf
Depends on:
Blocks:
 
Reported: 2016-02-24 10:47 UTC by Raf
Modified: 2017-11-09 13:37 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
callgrind trace (8.42 MB, application/x-bzip)
2016-05-17 20:10 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Raf 2016-02-24 10:47:35 UTC
Problem description: 
Format cell dialogue wait for a long while (8 seconds) to pop up.. 

Steps to reproduce:
1. either choose cell formatting from  right-click pop-up or Format menu entry or Ctrl+1.
2. Wait 8 seconds for the dialogue to pop up and the calc windows may be dimmed. It might be caused for waiting too long.
3. Popuped window operations are then normal.
4. Disabling Java in libreoffice does not help. 
5. running Calc as administrator does not help
6. Removing %AppData%/Roaming/Libreoffice folder does not help

Current behaviour: Unreasonably slow cell format window popup.

Expected behaviour: Dialogue should pop up almost immediately.

Operating System: Windows 7 Pro x64 - 12GB RAM - i7-5600U processor
Version: 5.1.0.3 release

May be related to ticket #63551
Comment 1 Buovjaga 2016-02-24 11:16:32 UTC
Does disabling this help Tools - Options - LibO - View - Use OpenGL for all rendering?

Please always include the full version info from Help - About.
Comment 2 Raf 2016-02-24 11:19:48 UTC
- Disabling OpenGL does not help.

Full info details:
Versione: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Versione locale: it-IT (it_IT)
Comment 3 Buovjaga 2016-03-04 11:53:57 UTC
I have to admit it is slower in 5.2 for me than in 5.1. Not 8 seconds, but still..

64-bit, KDE Plasma 5
Build ID: 5.1.0.3 Arch Linux build-1
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)

Version: 5.2.0.0.alpha0+
Build ID: 8fab3bf91331a4ac9e3b8f44a46f579dbf7aeafb
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 4 Julien Nabet 2016-05-17 20:10:12 UTC
Created attachment 125127 [details]
callgrind trace

On pc Debian x86-64 with master sources updated today + enable-symbols, I retrieved a callgrind trace.
Comment 5 Buovjaga 2016-09-12 19:48:01 UTC
*** Bug 101990 has been marked as a duplicate of this bug. ***
Comment 6 Buovjaga 2016-09-12 19:52:22 UTC
Sam: thanks for the bt in your duplicate report. You probably have your hands full with all kinds of stuff, but the QA team is always in need of savvy guys like you. Do drop by and say hello, if you can: https://wiki.documentfoundation.org/QA/IRC
Comment 7 tomaskeb 2017-05-10 10:45:16 UTC

*** This bug has been marked as a duplicate of bug 104312 ***
Comment 8 Kevin Suo 2017-11-09 13:37:40 UTC

*** This bug has been marked as a duplicate of bug 63551 ***