Bug Hunting Session
Bug 98133 - Empty cells moved up on import
Summary: Empty cells moved up on import
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pptx
Depends on:
Blocks: Chart PPTX
  Show dependency treegraph
 
Reported: 2016-02-24 10:51 UTC by Robert de Rooy
Modified: 2017-11-08 15:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
MS Office original file (47.22 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2016-02-24 10:51 UTC, Robert de Rooy
Details
MS Office 2016 screenshot of how the graph should look (80.09 KB, image/png)
2016-02-24 10:52 UTC, Robert de Rooy
Details
LibreOffice 5.0.5.2 screenshot showing Line C in the wrong place (113.93 KB, image/png)
2016-02-24 10:53 UTC, Robert de Rooy
Details
MS Office 2016 PPT screenshot with chart data table (96.32 KB, image/png)
2016-03-07 11:27 UTC, Robert de Rooy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert de Rooy 2016-02-24 10:51:48 UTC
Created attachment 122940 [details]
MS Office original file

When opening a MS Office presentation with embedded Graphs into LibreOffice we ran into problems, in that the graphs where different then when viewed in MS Office. OpenOffice has exactly the same problem, and this has already resulted in people being told not to use Open/LibreOffice because of this.

I figured out the issue is that any empty cells are removed when opened in LibreOffice. In my attached PPTX file, the data for "Line C" does not have any datapoints in the first three cells, and when you open this file in LibreOffice it just removes those empty cells, causing "Line C" to peak much earlier then it should.
Comment 1 Robert de Rooy 2016-02-24 10:52:43 UTC
Created attachment 122941 [details]
MS Office 2016 screenshot of how the graph should look
Comment 2 Robert de Rooy 2016-02-24 10:53:50 UTC
Created attachment 122942 [details]
LibreOffice 5.0.5.2 screenshot showing Line C in the wrong place
Comment 3 raal 2016-03-06 10:31:36 UTC
I can confirm with LibreOffice 3.5.0  and Version: 5.2.0.0.alpha0+
Build ID: aaca25d67eb5ea252730cdcf555ecc04ce04a5e6
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-24_23:58:47

Please attach printscreen how data table looks in powerpoint. Thanks
Comment 4 Robert de Rooy 2016-03-07 11:27:36 UTC
Created attachment 123370 [details]
MS Office 2016 PPT screenshot with chart data table
Comment 5 QA Administrators 2017-05-22 13:19:23 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2017-11-08 15:50:02 UTC
Bug no longer reproducible in

Version: 6.0.0.0.alpha1+
Build ID: 38a8157d9447134913d88c6c373d99a7aa472857
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Closing as RESOLVED WORKSFORME

[Improvement found by office-interoperability-tools]