Bug Hunting Session
Bug 98212 - RTL: 'Text Direction' drop down menu doesnt update preview in alignment tab of paragraph dialog
Summary: RTL: 'Text Direction' drop down menu doesnt update preview in alignment tab o...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks: RTL-CTL Paragraph-Dialog
  Show dependency treegraph
 
Reported: 2016-02-26 20:37 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-11-11 21:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot showing wrong alignment (51.77 KB, image/png)
2016-03-17 08:53 UTC, Usama
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-02-26 20:37:44 UTC
Steps:
1) Open Writer with CTL enabled in the options dialog
2) Open Paragraph dialog and switch to Alignment tab
3) Change the entry of the 'Text Direction' from 'Use superordinate object settings' to 'Right-to-left'
4) Notice the preview does not update, though the alignment was switched from Left to Right due to the change

Version: 5.2.0.0.alpha0+
Build ID: 003d0ccf902d2449320dd24119564565a384f365
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-23_02:42:33
Locale: en-US (en_US.UTF-8)
Comment 1 Usama 2016-03-17 08:53:45 UTC
Created attachment 123654 [details]
screenshot showing wrong alignment

I confirm it. If you chose Right from options the priview show text aligned to right. But if you change the entry of the 'Text Direction' from 'Use superordinate object settings' to 'Right-to-left' it will set options to right without changing the preview.

Confirmed on: Ubuntu 15.10 and Windows 7

Version: 5.0.2.2
Build ID: 00m0(Build:2)
Locale: en-GB (en_US.UTF-8)

Version: 5.2.0.0.alpha0+
Build ID: aaca25d67eb5ea252730cdcf555ecc04ce04a5e6
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-24_23:58:47
Locale: en-US (en_US.UTF-8)

Version: 5.2.0.0.alpha0+
Build ID: 6eb7cd38e348e8a9d6498bfc2d41e91725eb34aa
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-03-16_12:53:35
Locale: en-US (en_US)
Comment 2 Jim Raykowski 2017-10-19 20:28:29 UTC
Here is a link to modified tdf#98211 patch which specifically addresses the preview update bug.

https://gerrit.libreoffice.org/#/c/43577/
Comment 3 Commit Notification 2017-10-20 08:37:32 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9466ea1af09c275f423b0d5c1ad929984ed998b3

tdf#98212 make paragraph dialog alignment tab preview update

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Yousuf Philips (jay) (retired) 2017-10-20 15:14:57 UTC
(In reply to Jim Raykowski from comment #2)
> Here is a link to modified tdf#98211 patch which specifically addresses the
> preview update bug.

Look forward to testing it. Tried to cherry-pick it to 5.4 in gerrit but it wouldnt work, so can you create a 5.4 patch.
Comment 5 Omer Zak 2017-11-11 20:24:31 UTC
Works for me in:

Version: 6.0.0.0.alpha1+
Build ID: 5d12237d79f289a1dcf8e07aa03df329e136f078
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.utf8); Calc: group

OS: Debian 64bit Stretch (Debian 9.2, with some backported packages)