Bug 98230 - [HELP] Rename "Insert - File" and "Insert - Document" to "Insert - Text from File"
Summary: [HELP] Rename "Insert - File" and "Insert - Document" to "Insert - Text from ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: sdc.blanco
URL:
Whiteboard: target:6.5.0
Keywords:
Depends on:
Blocks: Help-Changes-Features
  Show dependency treegraph
 
Reported: 2016-02-27 14:53 UTC by pmb
Modified: 2020-01-24 10:37 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
graphic of Insert menu (144.14 KB, image/jpeg)
2016-02-27 14:53 UTC, pmb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pmb 2016-02-27 14:53:22 UTC
Created attachment 123040 [details]
graphic of Insert menu

I tried inserting a text file but could not find Insert > File.

Went to help - instructions Insert > File.

No File item in the Insert Menu.
Comment 1 MM 2016-02-27 18:46:43 UTC
I think they've renamed 'file' to 'document'.
Comment 2 Stanislav Horacek 2016-02-29 14:22:15 UTC
Confirmed - thanks for the report!

The dependency added because of different names for this command in Writer and Impress/Draw which should be solved at first.
Comment 3 Ming Hua 2019-11-30 11:07:30 UTC
Impress/Draw no longer has an "Insert -> File..." menu entry, and the title of bug 98274 has been changed.  I don't think it's relevant to this bug anymore.

So now the issue for Writer's help page seems to be just that the description of the menu entry doesn't match the UI.  For LO 6.2 and higher this entry is "Insert -> Text from file...".  This should be easily fixed, shouldn't it?

For the record, the relevant help page is
https://help.libreoffice.org/6.4/en-US/text/swriter/guide/textdoc_inframe.html
Comment 4 Dieter 2019-12-03 12:54:08 UTC
Similar with HELP about Insert Menu:

https://help.libreoffice.org/6.4/en-GB/text/swriter/main0104.html?&DbPAR=WRITER&System=WIN

"Document" has to be changed to "Text from File"
Comment 5 Commit Notification 2020-01-10 13:51:54 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/a0872eddb8cdcf166793ddc950d05d2634a76810

tdf#98230 update help for insert file
Comment 6 sdc.blanco 2020-01-11 12:00:02 UTC
@Ming and @Dieter Have I understood correctly that the OP is "out of date" but there were still corrections needed that you identified?  I have also found a third case.

It takes a few days after the commit before the change is visible.  But you can check here:

https://help.libreoffice.org/6.5/en-US/text/swriter/guide/textdoc_inframe.html
https://help.libreoffice.org/6.5/en-US/text/swriter/main0104.html
https://help.libreoffice.org/6.5/en-US/text/swriter/01/04190000.html

Maybe this issue is resolved now?
Comment 7 Ming Hua 2020-01-11 15:31:31 UTC
(In reply to sdc.blanco from comment #6)
> @Ming and @Dieter Have I understood correctly that the OP is "out of date"
> but there were still corrections needed that you identified?  I have also
> found a third case.
> 
> [...]
> 
> Maybe this issue is resolved now?
I agree this issue is fixed with your commit.  Thanks Seth!
Comment 8 Dieter 2020-01-12 16:25:31 UTC
(In reply to sdc.blanco from comment #6)
> But you
> can check here:
> 
> https://help.libreoffice.org/6.5/en-US/text/swriter/guide/textdoc_inframe.
> html
> https://help.libreoffice.org/6.5/en-US/text/swriter/main0104.html
> https://help.libreoffice.org/6.5/en-US/text/swriter/01/04190000.html
> 
> Maybe this issue is resolved now?

In all three help-pages I can read Insert > Document, but it should be Insert > Text from File.

I would expect:

> https://help.libreoffice.org/6.5/en-US/text/swriter/guide/textdoc_inframe.html

To insert text from a file (as heading)
2. Choose Insert > Text from File

> https://help.libreoffice.org/6.5/en-US/text/swriter/main0104.html

"Text from File" instead of "Document"

> https://help.libreoffice.org/6.5/en-US/text/swriter/01/04190000.html

"Insert (Text from File)" as heading
"Choose Insert - Text from File"
Comment 9 sdc.blanco 2020-01-12 16:31:20 UTC
(In reply to Dieter Praas from comment #8)
>
> In all three help-pages I can read Insert > Document, but it should be
> Insert > Text from File.
See comment #6

> It takes a few days after the commit before the change is visible.  
Perhaps by the end of this coming week.
Comment 10 sdc.blanco 2020-01-13 12:31:30 UTC
(In reply to sdc.blanco from comment #9)
> Perhaps by the end of this coming week.
The changes are to be "online" (for 6.5) now.  But you may have to reload in your browser (to overcome the "cache").
Comment 11 Ming Hua 2020-01-14 02:46:14 UTC
(In reply to sdc.blanco from comment #10)
> The changes are to be "online" (for 6.5) now.
Yes they are.

(In reply to Dieter Praas from comment #8)
> 
> > https://help.libreoffice.org/6.5/en-US/text/swriter/01/04190000.html
> 
> "Insert (Text from File)" as heading
Seth, you seem to have missed this part.  The updated version still has a "Insert (Document)" heading.

Also, the "title" (I don't know exactly what it's called, the thing that's shown on my Firefox tab) of the page still reads "Insert (File)", I believe that needs a change as well.
Comment 12 Ming Hua 2020-01-14 02:57:20 UTC
I think a fourth file needs patching, source/text/swriter/01/04190000.xhp

https://opengrok.libreoffice.org/xref/help/source/text/swriter/01/04190000.xhp
Comment 13 Commit Notification 2020-01-17 18:50:28 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/fb0dc909685c512937906fa1c1b2ffab912907d1

tdf#98230 update of Insert (Text to File) help page
Comment 14 sdc.blanco 2020-01-20 22:38:38 UTC
(In reply to Ming Hua from comment #12)
> I think a fourth file needs patching, source/text/swriter/01/04190000.xhp
Thanks Ming -- this is the source file for: 
 https://help.libreoffice.org/6.5/en-US/text/swriter/01/04190000.html

I can see online pages have been updated now (but depending on your browser's cache, you may have to reload the page). Maybe everything is all right now?
Comment 15 Ming Hua 2020-01-22 01:22:45 UTC
(In reply to sdc.blanco from comment #14)
> (In reply to Ming Hua from comment #12)
> > I think a fourth file needs patching, source/text/swriter/01/04190000.xhp
> Thanks Ming -- this is the source file for: 
>  https://help.libreoffice.org/6.5/en-US/text/swriter/01/04190000.html
Looks good.  This bug can be closed as far as I'm concerned.

... although Dieter's this particular point hasn't been addressed:

(In reply to Dieter Praas from comment #8)
> 
> I would expect:
> 
> > https://help.libreoffice.org/6.5/en-US/text/swriter/guide/textdoc_inframe.html
> 
> To insert text from a file (as heading)
But I think the inaccuracy is not limited to the heading, and the whole paragraph needs an update, which is probably better discussed in a separate bug.
Comment 16 sdc.blanco 2020-01-22 01:41:32 UTC
(In reply to Ming Hua from comment #15)
> ... although Dieter's this particular point (from comment #8) hasn't been 
> addressed:
> https://help.libreoffice.org/6.5/en-US/text/swriter/guide/textdoc_inframe.html
> 
> To insert text from a file (as heading)
Did not attempt, because only incorrect information can be changed (to avoid retranslations).

> But I think the inaccuracy is not limited to the heading, and the whole
> paragraph needs an update, which is probably better discussed in a separate
> bug.
Sounds right. Then headings can also be discussed.
Comment 17 sdc.blanco 2020-01-24 10:37:00 UTC
Will close as Fixed and assume Reopen as needed.
Or that a new bug will be filed, as suggested in comment 15.