Bug 98272 - print check boxes fail on Calc since 5.0.4.2
Summary: print check boxes fail on Calc since 5.0.4.2
Status: RESOLVED DUPLICATE of bug 97244
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 98570 98763 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-02-29 13:42 UTC by GUTH Christophe
Modified: 2016-03-20 17:37 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Calc doc printed (sheet LF-ref0) (924.88 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-02-29 13:42 UTC, GUTH Christophe
Details
badly printed Sheet LF-ref0 with LOO 5.0.4.2 and 5.1.0.3 (8.04 KB, application/pdf)
2016-02-29 13:42 UTC, GUTH Christophe
Details
correctly printed sheet LF-Ref0 (LOO 5.0.2.2 Linux) (323.44 KB, image/jpeg)
2016-02-29 13:43 UTC, GUTH Christophe
Details
screen capture of the dialog (see on left of the mouse's cursor) (50.43 KB, image/jpeg)
2016-02-29 13:48 UTC, GUTH Christophe
Details
Large fonts in print preview instead of checkboxes (71.01 KB, image/jpeg)
2016-03-01 09:39 UTC, janvdberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description GUTH Christophe 2016-02-29 13:42:08 UTC
Created attachment 123075 [details]
Calc doc printed (sheet LF-ref0)

Hello,

My coworker told me that a document is faultly printed after reinstallation of his computer (I've installed LOO 5.0.4.2 which was released just before reinstallation).

When my coworker wanted to print a sheet, a little part causes garbage print.

On the file attached, the sheet "LF-ref0" is to be printed. But the lines 9 and 10 gives differents results when printed with LOO 5.0.2.2 (correctly printed) and LOO 5.0.4.2 (badly printed).

The bug is visible in LOO 5.1.0.3.

I'll send two printings of this sheet as attachments to show the differences.

Is it possible to correct this bug ?

Thanks you in advance
Comment 1 GUTH Christophe 2016-02-29 13:42:50 UTC
Created attachment 123076 [details]
badly printed Sheet LF-ref0 with LOO 5.0.4.2 and 5.1.0.3
Comment 2 GUTH Christophe 2016-02-29 13:43:46 UTC
Created attachment 123077 [details]
correctly printed sheet LF-Ref0 (LOO 5.0.2.2 Linux)
Comment 3 GUTH Christophe 2016-02-29 13:47:43 UTC
Just an addition :

- I've attached a correctly printed sheet obtained from Linux but the sheet is correctly printed with LOO 5.0.2.2 on Windows too. The bug occured after this release.

- When you have the print dialog in LOO, the preview on the left side of the dialog shows the lines badly rendered in LOO 5.0.4.2
Comment 4 GUTH Christophe 2016-02-29 13:48:33 UTC
Created attachment 123078 [details]
screen capture of the dialog (see on left of the mouse's cursor)
Comment 5 raal 2016-02-29 20:09:54 UTC
I can confirm with Version: 5.2.0.0.alpha0+
Build ID: 98a8eafa915b8d57b8bdccab9981e537d77f6f4a
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-25_00:49:33

works in LO 4.0, regression
Comment 6 janvdberg 2016-03-01 09:39:05 UTC
Created attachment 123103 [details]
Large fonts in print preview instead of checkboxes

I can confirm the same issue.

Versie: 5.1.0.3 
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: nl-NL (nl_NL)

It seems that where the checkboxes should be that in print preview there are now large/huge fonts/letters. They become visible when zooming in on the print preview (in my case). See attached file.
Comment 7 janvdberg 2016-03-01 09:43:08 UTC
Actually I mean radio buttons (not check boxes).
Comment 8 raal 2016-03-03 13:00:34 UTC
This seems to have begun at the below commit.
Adding Cc: to Tomaž Vajngerl; Could you possibly take a look at this one? Thanks
 946e3a3d952ed45ff0926b767839a5d2fa7b7979 is the first bad commit
commit 946e3a3d952ed45ff0926b767839a5d2fa7b7979
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Oct 23 16:14:34 2015 -0700

    source sha:825b3df7f1d987021ec4a08ff8e7ed78e5772c97

    source sha:825b3df7f1d987021ec4a08ff8e7ed78e5772c97

author	Tomaž Vajngerl <tomaz.vajngerl@collabora.com>	2015-10-22 17:03:01 (GMT)
committer	Tomaž Vajngerl <tomaz.vajngerl@collabora.com>	2015-10-22 17:16:14 (GMT)
commit 825b3df7f1d987021ec4a08ff8e7ed78e5772c97 (patch)
tree ea377df8cb251150d9606bf1c09a2dfbb7377b62
parent 8e49a523c932936c1e38e0d26e5946619c2ed321 (diff)
tdf#94138 fix printing of edit form fields
Comment 9 m.a.riosv 2016-03-10 00:37:25 UTC
*** Bug 98570 has been marked as a duplicate of this bug. ***
Comment 10 yuyu122 2016-03-10 17:39:31 UTC
Same issue

Version: 5.0.5.2
Build ID: 55b006a02d247b5f7215fc6ea0fde844b30035b3
Locale: es-MX (es_MX)
Comment 11 JoNi 2016-03-20 16:29:51 UTC
duplicate of older report

*** This bug has been marked as a duplicate of bug 97244 ***
Comment 12 raal 2016-03-20 17:37:38 UTC
*** Bug 98763 has been marked as a duplicate of this bug. ***