Bug 98312 - (PRINTING) Forms in Calc print (printer, preview) very ugly
Summary: (PRINTING) Forms in Calc print (printer, preview) very ugly
Status: RESOLVED DUPLICATE of bug 97244
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2016-03-01 17:35 UTC by Marco Gaiarin
Modified: 2016-03-20 16:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The document that behave incorrectly (10.72 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-03-01 17:35 UTC, Marco Gaiarin
Details
Printed page (Using PDFCReator to mimick a real printer) (13.11 KB, application/force-download)
2016-03-01 17:36 UTC, Marco Gaiarin
Details
Print Preview screenshot (87.29 KB, image/png)
2016-03-01 17:36 UTC, Marco Gaiarin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Gaiarin 2016-03-01 17:35:15 UTC
Created attachment 123113 [details]
The document that behave incorrectly

In Windows 7 64bit, after switching from LO 4.4.7 x86 to LO 5.0.5 x64, a simple form built with Calc start to do strange things in printing/preview.

Fonts get UGLY and BIGGIE, wraps around cells and so it is totally unreadable.

The document works like a charm in LO 4.4, and the trouble is full reproducible: attached a sample LO doc that behave like explained above, the PDF print (using PDFCreator printer, to mimick a real one) and a screenshot of a print preview.

The same document (that was created by zero on LO 5.0) behave correctly on LO 4.4.


Thanks.
Comment 1 Marco Gaiarin 2016-03-01 17:36:05 UTC
Created attachment 123114 [details]
Printed page (Using PDFCReator to mimick a real printer)
Comment 2 Marco Gaiarin 2016-03-01 17:36:37 UTC
Created attachment 123115 [details]
Print Preview screenshot
Comment 3 Joel Madero 2016-03-02 20:26:10 UTC
Interestingly enough, I don't see any text at all in 5.2 in Bodhi Linux, seems like a separate issue though :) Need a Windows QA member to verify.
Comment 4 Buovjaga 2016-03-10 13:28:46 UTC
Repro. Confirmed it works ok in 4.3.

Win 7 Pro 64-bit, Version: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: b89feb8018bf3610faf01e73995d576f6566e20b
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-03-07_03:36:17
Locale: fi-FI (fi_FI)
Comment 5 Joel Madero 2016-03-10 16:05:37 UTC
All regressions post 3.5 should have bibisectRequest in keywords. Adding.
Comment 6 raal 2016-03-11 12:40:29 UTC
This seems to have begun at the below commit.
Adding Cc: to Tomaž Vajngerl; Could you possibly take a look at this one? Thanks

946e3a3d952ed45ff0926b767839a5d2fa7b7979 is the first bad commit
commit 946e3a3d952ed45ff0926b767839a5d2fa7b7979
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Oct 23 16:14:34 2015 -0700

    source sha:825b3df7f1d987021ec4a08ff8e7ed78e5772c97

    source sha:825b3df7f1d987021ec4a08ff8e7ed78e5772c97

author	Tomaž Vajngerl <tomaz.vajngerl@collabora.com>	2015-10-22 17:03:01 (GMT)
committer	Tomaž Vajngerl <tomaz.vajngerl@collabora.com>	2015-10-22 17:16:14 (GMT)
commit	825b3df7f1d987021ec4a08ff8e7ed78e5772c97 (patch)
tree	ea377df8cb251150d9606bf1c09a2dfbb7377b62
parent	8e49a523c932936c1e38e0d26e5946619c2ed321 (diff)
tdf#94138 fix printing of edit form fields
Comment 7 JoNi 2016-03-20 16:29:26 UTC
duplicate of older report

*** This bug has been marked as a duplicate of bug 97244 ***