Bug 98346 - When reedit chart data labels "number format" cleared
Summary: When reedit chart data labels "number format" cleared
Status: RESOLVED DUPLICATE of bug 95425
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-02 12:37 UTC by Alex
Modified: 2016-03-09 19:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Problem file ods Xubuntu 14.04 LibreOffice 5.1.0 (13.13 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-03-03 09:15 UTC, Alex
Details
Problem file ods Windows 7 LibreOffice 5.1.0 (13.09 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-03-03 09:15 UTC, Alex
Details
the window where changes should happen (185.36 KB, image/png)
2016-03-03 17:19 UTC, Usama
Details
Step by step bug reproduce (859.49 KB, application/vnd.oasis.opendocument.text)
2016-03-04 05:36 UTC, Alex
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2016-03-02 12:37:08 UTC
When editing in Data Labels diagram I change "number format" from the default one to a different one. After saving and entering diagram properties once again the "number format" is changed into default. 
Test in clear installation Xubuntu 14.04 + Libreoffice 5.1.0 and Windows 7 + Libreoffice 5.1.0
Comment 1 Joel Madero 2016-03-02 21:35:00 UTC
Hi Alex,

Please attach a simple test document for us. Marking as NEEDINFO, once attached set back to UNCONFIRMED. Thanks!
Comment 2 Alex 2016-03-03 09:15:04 UTC
Created attachment 123183 [details]
Problem file ods Xubuntu 14.04 LibreOffice 5.1.0
Comment 3 Alex 2016-03-03 09:15:53 UTC
Created attachment 123184 [details]
Problem file ods Windows 7 LibreOffice 5.1.0
Comment 4 Alex 2016-03-03 09:17:19 UTC
Video where reproduced this bug - https://www.youtube.com/watch?v=fVwjmjDYjNU
Comment 5 Joel Madero 2016-03-03 15:56:08 UTC
In the future please set bugs to UNCONFIRMED after you add the additional info. Thanks
Comment 6 Usama 2016-03-03 17:13:48 UTC
Hello Alex, Thank you for reporting the bug. Unfortunately without clear steps to reproduce it, we cannot track down the origin of the problem. Please provide a clearer set of step-by-step instructions on how to reproduce the problem.

For example I double clicked on the chart column and I got the "Data labels for Data Series 'Column A'" Window.

Then in Data labels tab I chose "Number Format" and set it to currency. I saved the file and reopened it without a problem.

However your original file has the numbers on columns showing in this format 3.00E+00

When I click and reopen it return to 3.

So could you please clear the steps you did?


Tested on Libreoffice Version: 5.2.0.0.alpha0+
Comment 7 Usama 2016-03-03 17:19:36 UTC
Created attachment 123207 [details]
the window where changes should happen
Comment 8 Alex 2016-03-04 05:36:30 UTC
Created attachment 123219 [details]
Step by step bug reproduce
Comment 9 Alex 2016-03-04 05:36:58 UTC
Step by Step:
1)Create new spreadsheet document
2)Input data and create chart
3) Select “Edit” Chart.
4) Insert Data Labels
5) In Data Labels parameters check “Show values as number” and change “Number format” to Scientific
6) Save document and close it
7) Open saved document. Data labels show in scientific format
8) Select “Edit” Chart.
9) Select properties any elements, such as “Data Series”
10) If click  “Ok”, “Cancel” or press Esc “Number Format” set as default
Comment 10 Andreas 2016-03-09 18:00:17 UTC
This seems to be the same as Bug 95425.

I can confirm this bug for Version: 5.0.4.2, Build ID: 00m0(Build:2) on Linux / OpenSuse 42.1.

I reset the status to unconfirmed, the information by Alex should be sufficient.
Comment 11 Buovjaga 2016-03-09 19:03:01 UTC
Indeed, let's set to dupe.
Thanks for investigating.

*** This bug has been marked as a duplicate of bug 95425 ***