Bug 98354 - EDITING: inverted comma automatically added to numbers
Summary: EDITING: inverted comma automatically added to numbers
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-02 16:55 UTC by Theo.Jakobus
Modified: 2016-05-02 16:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
LibreOffice Calc file standard setup (8.00 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-03-03 17:12 UTC, Theo.Jakobus
Details
LibreOffice Calc file no standard setup for column A (8.17 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-03-03 17:36 UTC, Theo.Jakobus
Details
File created with CALC version 5.0.5.2 (8.10 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-03-14 17:25 UTC, Theo.Jakobus
Details
Screenshot of correct behavior (161.94 KB, image/jpeg)
2016-03-14 18:08 UTC, Buovjaga
Details
Created as standard user on Windows 7 (11.48 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-03-16 19:57 UTC, Theo.Jakobus
Details
Created as administrator on Windows 7 (11.46 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-03-16 19:58 UTC, Theo.Jakobus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Theo.Jakobus 2016-03-02 16:55:46 UTC
After entering numbers direct in cells like:
C2: 1,1
C3: 2,2
C4: 3,3
C5: 4,4
and in the next cell
C6: =SUMME(C2:C5)
the sum is 0 !!!
The edit line shows for all cells the same characters as in the cell.

Opening the file with LibreOffice Version: 4.4.7.2 the content of the cells are identical but in the edit line all numbers have an inverted comma as first character:
C2: '1,1
C3: '2,2
C4: '3,3
C5: '4,4
That's the explanation for the sum.
Comment 1 Theo.Jakobus 2016-03-02 17:28:16 UTC
In LibreOffice 5.0.5.2 the language for the cells is set to:
Standard - Deutsch (Deutschland)
After changing the language to:
Deutsch (Deutschland)
in the edit line the inverted comma in front of the number is shown!

If I first change the language of cells to:
Deutsch (Deutschland)
entered numbers are numbers now.

That's a workaround !!!
Comment 2 Joel Madero 2016-03-02 19:47:02 UTC
Please attach a sample document. Marking as NEEDINFO. Once you attach a sample set to UNCONFIRMED. Thanks
Comment 3 Theo.Jakobus 2016-03-03 17:12:17 UTC
Created attachment 123206 [details]
LibreOffice Calc file standard setup

I just entered numbers in cell A1 to A3 and in cell A4 =SUMME(A1:A3)
Comment 4 Theo.Jakobus 2016-03-03 17:36:39 UTC
Created attachment 123208 [details]
LibreOffice Calc file no standard setup for column A

Select column A, [Strg]+[1], Then I changed for column A the language from "Standard - Deutsch (Deutschland)" to "Deutsch (Deutschland)"
Next I entered numbers in cell A1 to A3 and in cell A4 =SUMME(A1:A3)
The result is ok.
Comment 5 Buovjaga 2016-03-10 12:53:08 UTC
(In reply to Theo.Jakobus from comment #4)
> Created attachment 123208 [details]
> LibreOffice Calc file no standard setup for column A
> 
> Select column A, [Strg]+[1], Then I changed for column A the language from
> "Standard - Deutsch (Deutschland)" to "Deutsch (Deutschland)"
> Next I entered numbers in cell A1 to A3 and in cell A4 =SUMME(A1:A3)
> The result is ok.

So can this be closed?

Was the file originally a CSV?
Comment 6 Theo.Jakobus 2016-03-10 19:02:36 UTC
Both spreadsheets in attachment 123206 [details] and in attachment 123208 [details] are created in CALC. Both spreadsheets were originally not a CSV.
The comment to attachment 123208 [details] gives a workaround.

The bug still exists.
Comment 7 Buovjaga 2016-03-13 13:05:40 UTC
Comment from a developer on IRC:
"These are string cells and not numbers.
Most likely the comma separator for the original input is . so 3,3 is a string and not a number."

I don't see any language choice "Standard - German (Germany)". I only see Standard in the Format column of the Format cells dialog.

Closing as NOTABUG.
Comment 8 Theo.Jakobus 2016-03-14 17:25:52 UTC
Created attachment 123567 [details]
File created with CALC version 5.0.5.2

Using "CALC 5.0.5.2" I created a new spreadsheet
- select column A
- change the format for column A to number
   (the window shows language: Standard - Deutsch (Deutschland)
- entering numbers into cells A1 to A3
   (decimal point in German is comma)
- entering =SUMME(A1:A3) in cell A4
the shown result is 0

Using "CALC 4.4.7.2" I created a new spreadsheet and did the steps in the exact same manner as for "CALC 5.0.5.2" the sum is 9,22 which is ok.
Comment 9 Joel Madero 2016-03-14 17:48:07 UTC
Wrong status.
Comment 10 Buovjaga 2016-03-14 18:08:44 UTC
Created attachment 123570 [details]
Screenshot of correct behavior

No problem here.

Version: 5.1.1.3
Build ID: 5.1.1.3 Arch Linux build-2
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 11 steve 2016-03-14 18:31:31 UTC
Hey Theo,

can you please try to reproduce this problem from scratch using LO 5.1.1 or master?

Setting to NEEDINFO until more detail is provided.

After providing the requested info, please reset this bug to UNCONFIRMED (should it be persisting) or WORKSFORME (should it be solved with a newer LO version).
Comment 12 Theo.Jakobus 2016-03-16 19:55:37 UTC
As admin I uninstalled LibreOffice 5.0.5.2
As admin I installed LibreOffice 5.1.1.3 locally.

Normally I'm using Windows 7 as standard user without admin rights.

As standard user I created file "CALC 5.1.1.3 user.ods"
Column A formatted for numbers, language set to Standard - Deutsch (Deutschland)
I entered some numbers and in cell A7 the command =SUMME(A1:A6)
The sum is 0!
Column B formatted for numbers, language set to Deutsch (Deutschland)
I entered some numbers and in cell B7 the command =SUMME(B1:B6)
The sum is ok.

I logged in as admin and I did the steps again as admin
I created file "CALC 5.1.1.3 admin.ods"
I entered the same commands.
Now for column A the sum is ok too.

The bug shows up for standard user only.
Comment 13 Theo.Jakobus 2016-03-16 19:57:34 UTC
Created attachment 123634 [details]
Created as standard user on Windows 7
Comment 14 Theo.Jakobus 2016-03-16 19:58:21 UTC
Created attachment 123635 [details]
Created as administrator on Windows 7
Comment 15 Joel Madero 2016-03-24 14:54:38 UTC
Please don't update the version field...."earliest affected"...
Comment 16 raal 2016-03-25 07:45:12 UTC
I can not reproduce with LO 5.1.1.3 (x64); win7 logged as guest.

Theo, field Assigned To - The person in charge of resolving the bug. Are you developer?
Comment 17 Theo.Jakobus 2016-03-30 19:35:54 UTC
I'm not a developer.

On my notebook Windows 7 x64 is used.
I uninstalled LibreOffice_5.1.1.3_Win_x86.msi
I installed LibreOffice_5.1.1.3_Win_x64.msi
standard user: no admin rights
As standard user starting CALC with user interface: German
The error as described in comment 12 is still present.

As standard user starting CALC with user interface: English
Set format of a column to: English (USA)
No error.
Set format of a column to: Default - German (Germany)
The error occurs.
Comment 18 Theo.Jakobus 2016-05-02 16:19:18 UTC
I deleted the directory C:\Users\Theo\AppData\Roaming\LibreOffice\4
Starting CALC creates a new directory.
Now CALC works as expected.
Comment 19 steve 2016-05-02 16:30:49 UTC
Since there is no specific commit fixing this issue, setting to WORKSFORME. FIXED is used only when a commit exists.

Feel free to reopen this issue if you still can reproduce this particular problem or if I did miss something peculiar.