Bug 98356 - Comment Formatting Lost After Save, Close, Reopen
Summary: Comment Formatting Lost After Save, Close, Reopen
Status: RESOLVED DUPLICATE of bug 91596
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-02 18:01 UTC by Andy
Modified: 2016-08-06 19:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A witer file with comments of different sizes even though I formatted them all to 8 with the specific command (25.28 KB, application/vnd.oasis.opendocument.text)
2016-03-02 18:02 UTC, Andy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andy 2016-03-02 18:01:11 UTC
The writer comments have now the "format all comments option, which is apparently quite useful. For example you can set a smaller font size on a document where you need to have a LOT of comments cramped in some pages
While the formatting appears to work properly until you are keep working on the file, after saving  closing and reopening, the font size you have set is not present, and it appears to be quite unpredictable: in the attached document, after setting all comments to size 9, upon reopening the file you can see that some comments are size 10 and others (a minority) are size 9.
After reapplying the size formatting this time to size 8, and saving, you get a mix of the 3 sizes 10, 9 and 8!
Comment 1 Andy 2016-03-02 18:02:03 UTC
Created attachment 123148 [details]
A witer file with comments of different sizes even though I formatted them all to 8 with the specific command
Comment 2 Joel Madero 2016-03-02 21:16:47 UTC
Confirmed

Bodhi Moksha
LibreOffice 5.2

FWIW I don't think this has anything to do with Format All Comments - I did a test where I formatted them independently, and when I did the format all comments, both had same result.

What I did:

New writer document;
Two comments;
Format first comment to size 40 font (format -> comment)
Format second comment to size 40 
Saved;
Closed;
Opened


Observed: Second comment was back to size 10, first retained formatting.
Comment 3 Buovjaga 2016-08-06 19:43:18 UTC

*** This bug has been marked as a duplicate of bug 91596 ***