Bug Hunting Session
Bug 98397 - Fira sans “semibold” works but isn’t saved.
Summary: Fira sans “semibold” works but isn’t saved.
Status: RESOLVED DUPLICATE of bug 69254
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.1.1 rc
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-03 22:07 UTC by synthview
Modified: 2018-01-24 16:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description synthview 2016-03-03 22:07:36 UTC
When setting a paragraph style: font > typeface
If I set “SemiBold” for the font family “Fira sans”, after saving, closing and reopening my file, the style passed to “Regular”.
Comment 1 synthview 2016-03-04 11:11:06 UTC
I’ve tested editing the same Word file in WinXP Word 2003.

I notice on Word the font Fira sans Semibold appears as a different font in the list, below fira sans. Your way of grouping them seems more logic and proper to me, but it doesn’t seem to be compatible :(
Comment 2 Timur 2016-03-14 09:56:21 UTC
I use Windows and Fira family is neither in Windows nor in LO fonts.
Comment 3 synthview 2016-03-14 11:04:28 UTC
And so what? 
A writing software must run with any font what that follow opentype format standards.
The time of only 4 styles for a font is finished. You must provide appropriate support for more extended font families.
Comment 4 Buovjaga 2016-03-22 18:26:55 UTC
I installed Fira Sans SemiBold from here: https://github.com/mozilla/Fira/blob/master/otf/FiraSans-SemiBold.otf

I modified the default paragraph style like mentioned in description.

After save and reload the style stays as SemiBold.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.0.alpha0+
Build ID: 011e65c93053c88eb752e50ef47c69872608cbcd
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on March 22nd 2016
Comment 5 synthview 2016-03-22 18:38:31 UTC
You have to install more than one style to see the bug.
for example at least the basic regular, italic, bold, bold italic.
Comment 6 Buovjaga 2016-03-22 18:45:10 UTC
(In reply to synthview from comment #5)
> You have to install more than one style to see the bug.
> for example at least the basic regular, italic, bold, bold italic.

Sorry, I forgot to mention I already had Regular, Light, Bold, Italic, Light Italic, Medium Italic and Bold Italic installed.
Comment 7 synthview 2016-03-22 18:54:47 UTC
and if you install the whole family?
On my side I’ve tried many times and DemiBold was lost at each save in .doc format.
Comment 8 Buovjaga 2016-03-22 19:05:37 UTC
(In reply to synthview from comment #7)
> and if you install the whole family?
> On my side I’ve tried many times and DemiBold was lost at each save in .doc
> format.

You really have all the 64 styles installed?
Comment 9 synthview 2016-03-22 19:15:14 UTC
I am a designer :p it doesn’t mean I use them all at a time of course
Comment 10 Buovjaga 2016-03-24 13:42:44 UTC
Now I tried with OS X, but SemiBold is not available in LibreOffice. I can see it in Font Book.
Comment 11 synthview 2016-03-24 13:49:29 UTC
Right,
if you disable “medium” and “medium italic” and restart LibreOffice, you’ll see SemiBold again.
Comment 12 Alex Thurgood 2016-06-14 11:17:06 UTC
(In reply to Buovjaga from comment #10)
> Now I tried with OS X, but SemiBold is not available in LibreOffice. I can
> see it in Font Book.

Confirming, I can't see SemiBold either in LibreOffice
Comment 13 Alex Thurgood 2016-06-14 11:24:10 UTC
No repro, after de-activating the Fira fontweights in comment 11

Version: 5.3.0.0.alpha0+
Build ID: 4d49c9601c9b3e26a336e08e057d299895683480
Threads CPU : 2; Version de l'OS :Mac OS X 10.11.5; UI Render : par défaut; 
Locale : fr-FR (fr.UTF-8)


1) Create a new Writer document
2) Type some text
3) Right mouse button click on paragraph, choose Edit Style
4) Select Fira Sans SemiBold as font. Click on OK, and Apply. Quit dialog.
5) Save document.
6) Close LO, restart LO, re-open test document. Fira Sans SemiBold still default style font.
Comment 14 Alex Thurgood 2016-06-15 07:29:44 UTC
synthview: am I correct in my understanding of your comment in comment 7 that your actual problem is that the font weight isn't exported to DOC format ?

Please give precise instructions on how to reproduce, because I only tested against a Writer document.

Setting needinfo
Comment 15 QA Administrators 2017-01-31 00:29:15 UTC Comment hidden (obsolete)
Comment 16 QA Administrators 2017-03-01 10:36:42 UTC Comment hidden (obsolete)
Comment 17 Thomas Linard 2018-01-24 16:49:29 UTC

*** This bug has been marked as a duplicate of bug 69254 ***