Bug 98416 - REMOTE FILE: "The specified device is invalid." error dialog when attempting to add a service
Summary: REMOTE FILE: "The specified device is invalid." error dialog when attempting ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Giuseppe Castagno (aka beppec56)
QA Contact:
URL:
Whiteboard: target:5.2.0 target:5.1.2 target:5.0....
Keywords:
: 72646 107542 (view as bug list)
Depends on:
Blocks: CMIS
  Show dependency treegraph
 
Reported: 2016-03-04 14:35 UTC by Yousuf Philips (jay)
Modified: 2017-05-21 15:39 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
Wireshark log of failing Linux Google Drive connection (376 bytes, application/octet-stream)
2016-03-07 14:45 UTC, Giuseppe Castagno (aka beppec56)
Details
Wireshark log of a working Linux Google Drive connection (367.88 KB, application/octet-stream)
2016-03-07 14:50 UTC, Giuseppe Castagno (aka beppec56)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2016-03-04 14:35:43 UTC
Steps:
1) Open a release version of LO, which has google drive access
2) File > Open Remote File
3) Click 'Add Service' button
4) Fill in Google Drive details
5) When pressing OK you get a 'The specified device is invalid.' error dialog.

This didnt occur on Windows.

Version: 5.1.1.3
Build ID: 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
Locale: en-US (en_US.UTF-8)
Comment 1 Szymon Kłos 2016-03-05 20:48:46 UTC
(In reply to Yousuf (Jay) Philips from comment #0)
> 
> This didnt occur on Windows.
> 

'The specified device is invalid.' error dialog appears only when I enter wrong password. You are sure that on other OS you entered correct login and password?

By the way, I think we should change this mysterious message to something more clear in case of providing incorrect combination :)

Version: 5.1.2.0.0+
Build ID: bba00901f55bfd4fa476667baaf2b2e7e1f58762
CPU Threads: 4; OS Version: Linux 4.1; UI Render: default; 
Locale: pl-PL (pl_PL.UTF-8)
Comment 2 Yousuf Philips (jay) 2016-03-05 22:00:31 UTC
(In reply to Szymon Kłos from comment #1)
> 'The specified device is invalid.' error dialog appears only when I enter
> wrong password. You are sure that on other OS you entered correct login and
> password?

As stated in the other bug, it was the right password as i got an email from google saying a successful login, but still was getting this error.

> By the way, I think we should change this mysterious message to something
> more clear in case of providing incorrect combination :)

Yes if that is the error for an incorrect password, we definitely need to change it. I see that its found below, but i would assume that error maybe used elsewhere for something different.

http://opengrok.libreoffice.org/xref/core/svx/source/src/errtxt.src#195
Comment 3 Giuseppe Castagno (aka beppec56) 2016-03-07 14:45:25 UTC
Created attachment 123384 [details]
Wireshark log of failing Linux Google Drive connection

Wireshark log of failing Linux Google Drive connection, obtained with:

Version: 5.1.1.3
Build ID: 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d
CPU Threads: 8; OS Version: Linux 3.13; UI Render: default; 
Locale: en-US (en_US.UTF-8)

It seems the TLS 1.2 protocol never started.
Comment 4 Giuseppe Castagno (aka beppec56) 2016-03-07 14:50:02 UTC
Created attachment 123385 [details]
Wireshark log of a working Linux Google Drive connection

The log was obtained using a LO 5.1.1.3 version, compiled from public source code, using my own Google application ids.

As can be seen in the log, after the first three standard sync messages, the TLS protocol started.
Comment 5 Giuseppe Castagno (aka beppec56) 2016-03-07 14:51:12 UTC
Set as NEW, this bug affects LO 5.x Linux TDF builds.
Comment 6 Yousuf Philips (jay) 2016-03-08 21:20:57 UTC
Just tried this on a new installation of Ubuntu Mate 16.04 which comes with 5.1.0.3 and got the same error and got an email from google confirming the sign-in.
Comment 7 Yousuf Philips (jay) 2016-03-08 23:07:50 UTC
So did some testing of old builds and they have failed to connect to Google Drive on linux since 4.2, when this feature was introduced, and only with the new remote file dialog is an error message appearing.
Comment 8 Szymon Kłos 2016-03-09 16:25:12 UTC
This bug could be related with:
https://bugs.documentfoundation.org/show_bug.cgi?id=72277

It is marked as resolved, but it was mentioned that not in all cases.
Comment 9 Samuel Wolf 2016-03-09 18:49:39 UTC
(In reply to Szymon Kłos from comment #8)
> This bug could be related with:
> https://bugs.documentfoundation.org/show_bug.cgi?id=72277
> 
> It is marked as resolved, but it was mentioned that not in all cases.

It was never fixed, see:
https://bugs.documentfoundation.org/show_bug.cgi?id=90038
Comment 10 Commit Notification 2016-03-11 10:58:59 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=30b9c6a457de61f3c94431ecc75716f866c3379e

tdf#98416: Explicitly disable curl hardcoded CA certificate store

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Yousuf Philips (jay) 2016-03-11 12:51:26 UTC
@Szymon: So how can we correct the incorrect login error message?
Comment 12 Commit Notification 2016-03-13 14:40:39 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=98d48dad9e807a4a40f4c3d1b5280d9e5156cb18

tdf#98416 fix curl's configure check for nss (missing -lnssutil3)

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Giuseppe Castagno (aka beppec56) 2016-03-13 20:17:11 UTC
Usually daily masters are not Google Drive enabled, this:

<http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@70-TDF/gdrivetest2/LibreOfficeDev_5.2.0.0.alpha0_Linux_x86-64_deb.tar.gz>

It's a special version of master build specifically created to check this bug.

A comfirmation will be appreciated.

Thanks.
Comment 14 Christian Lohmaier 2016-03-13 20:56:01 UTC
(rpms also provided at the gdrivetest2 url http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@70-TDF/gdrivetest2/ )

Note that there's still bug#87938 (two-factor auth for gdrive not working) - so if you want to test, you have to disable two-factor authentication temporarily.
Comment 15 Commit Notification 2016-03-14 11:18:17 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=347577cb687ee7c30b52fdca3dee831d78ec55cd&h=libreoffice-5-1

tdf#98416: Explicitly disable curl hardcoded CA certificate store

It will be available in 5.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Yousuf Philips (jay) 2016-03-14 12:25:10 UTC
Thanks Giuseppe. It works correctly now in cloph's special daily build. Would be good to backport this also to 5.0.

I've created a separate bug report to deal with the incorrectly phrased error message for a wrong password (bug 98644).

Version: 5.2.0.0.alpha0+
Build ID: 98d48dad9e807a4a40f4c3d1b5280d9e5156cb18
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
Locale: en-US (en_US.UTF-8)
Comment 17 Yousuf Philips (jay) 2016-03-14 12:26:24 UTC
*** Bug 72646 has been marked as a duplicate of this bug. ***
Comment 18 Commit Notification 2016-03-14 14:56:27 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6af19381894c45c2375824b1bf2c96c8198ea455&h=libreoffice-5-1

tdf#98416 fix curl's configure check for nss (missing -lnssutil3)

It will be available in 5.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2016-03-16 14:37:32 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bfe6eaae2c4e45e830db1e9f1710d251f86fb2a3&h=libreoffice-5-0

tdf#98416 fix curl's configure check for nss (missing -lnssutil3)

It will be available in 5.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Pedro 2016-03-21 13:50:55 UTC
Tested with

Version: 5.1.2.0.0+
Build ID: 750fcdef6551f069badb802649a665e147e69083
CPU Threads: 2; OS Version: Windows 5.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-1, Time: 2016-03-15_16:35:55
Locale: pt-PT (pt_PT)

under Windows XP Pro x86 SP3 (there isn't any newer 5.1 build for x86 and the latest 5.0 build is from March 7th)

It isn't fixed and in fact it locks before any fields can be filled.
Comment 21 Yousuf Philips (jay) 2016-03-21 19:01:10 UTC
(In reply to Pedro from comment #20)
> under Windows XP Pro x86 SP3 (there isn't any newer 5.1 build for x86 and
> the latest 5.0 build is from March 7th)
> 
> It isn't fixed and in fact it locks before any fields can be filled.

This bug was specifically for linux, so i'd suggest opening a new bug specifically about it not working on XP.
Comment 22 V Stuart Foote 2016-03-22 16:00:41 UTC
(In reply to Yousuf (Jay) Philips from comment #21)
> (In reply to Pedro from comment #20)
> > under Windows XP Pro x86 SP3 (there isn't any newer 5.1 build for x86 and
> > the latest 5.0 build is from March 7th)
> > 
> > It isn't fixed and in fact it locks before any fields can be filled.
> 
> This bug was specifically for linux, so i'd suggest opening a new bug
> specifically about it not working on XP.

So, more than the XP specific bug 97226?
Comment 23 Commit Notification 2016-03-22 16:05:09 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0f567d9316941f0fcca4c260ad1e92fbe1a0df2d&h=libreoffice-5-0

tdf#98416: Explicitly disable curl hardcoded CA certificate store

It will be available in 5.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 andis.lazdins 2016-04-01 05:17:33 UTC
In 5.1.2.2 I still receive response The specified device is invalid on attempt to open remote file on Google drive. Ubuntu 14.04 32 bit
Comment 25 Yousuf Philips (jay) 2016-04-03 18:22:19 UTC
Didnt work for me either on Linux.

Version: 5.1.2.2
Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
Locale: en-US (en_US.UTF-8)
Comment 26 Yousuf Philips (jay) 2016-04-03 18:23:15 UTC
(In reply to V Stuart Foote from comment #22)
> So, more than the XP specific bug 97226?

No that is fine for it.
Comment 27 Pedro 2016-04-03 19:23:44 UTC
It still doesn't work under Windows 7 x64.

Using 5.1.2.2 x64, the message is still "The specified device is invalid."

Testing the latest x64 dev build (there aren't any for 5.1 or Master)

Version: 5.0.6.0.0+ (x64)
Build ID: 1f7af80f020a9114d7b6b4014a4ebb71cb81d8a1
TinderBox: Win-x86_64@62-TDF, Branch:libreoffice-5-0, Time: 2016-03-24_12:43:39
Locale: pt-PT (pt_PT)

There is no error because Google Drive Server Type is no longer available.
Comment 28 Christian Lohmaier 2016-04-04 13:38:18 UTC
> Version: 5.0.6.0.0+ (x64)

→ that is expected, nightly builds don't have necessary  keys. It is planned to  have dedicated keys for daily builds in future.

And 
RE not working in RCs/final builds:

If the comment doesn't explicitly state "I really don't use two-factor authentication and the problem  occurs nevertheless", I mentally immediately treat it as dupe to bug#87938 (see also comment#14)
Comment 29 Pedro 2016-04-04 14:30:09 UTC
(In reply to Christian Lohmaier from comment #28)
> If the comment doesn't explicitly state "I really don't use two-factor
> authentication and the problem  occurs nevertheless", I mentally immediately
> treat it as dupe to bug#87938 (see also comment#14)

I had already answered to you personally on IRC that I don't use two-factor authentication but here is the explicit statement: "I really don't use two-factor authentication and the problem  occurs nevertheless"
Comment 30 Yousuf Philips (jay) 2016-04-04 14:49:30 UTC
(In reply to Christian Lohmaier from comment #28)
> And 
> RE not working in RCs/final builds:
> 
> If the comment doesn't explicitly state "I really don't use two-factor
> authentication and the problem  occurs nevertheless", I mentally immediately
> treat it as dupe to bug#87938 (see also comment#14)

I dont use 2FA. :D
Comment 31 Giuseppe Castagno (aka beppec56) 2016-04-27 13:21:15 UTC
Spent some time hunting this bug in master.

I found that Google changed the OAuth 2.0 login procedure used by LO (more specifically by libcmis) to login.

If what I suspect is right, all LO versions are now unable to login to Google Drive.

Can someone check on LO older versions?
The operating system doesn't matter.
Comment 32 Pedro 2016-04-27 13:57:45 UTC
(In reply to Giuseppe Castagno (aka beppec56) from comment #31)

> If what I suspect is right, all LO versions are now unable to login to
> Google Drive.
> 
> Can someone check on LO older versions?
> The operating system doesn't matter.

Tested with LO 4.4.7, 4.3.7 and 4.2.8 under Windows 7 x64.
Result for all: General input/output error.
Comment 33 Giuseppe Castagno (aka beppec56) 2016-04-28 07:36:40 UTC
The reason for Google Drive login failing is this one:

https://productforums.google.com/forum/#!topic/gmail/oAsE-6wmaSU

Changing the login sequence from one html page to two broke libcmis.

I worked out a solution in Linux that works. Need to test in Windows , will take a few days.
Comment 34 Commit Notification 2016-05-02 11:00:15 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3db082a75210bbf0fc657831443c589a4226b997

Related tdf#98416 Libcmis: add a patch to fix Google Drive login

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 35 Commit Notification 2016-05-03 09:17:58 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1f8a8cc460b936f234a018cde48ef52ff25b537d&h=libreoffice-5-1

Related tdf#98416 Libcmis: add a patch to fix Google Drive login

It will be available in 5.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 36 Commit Notification 2016-05-03 16:56:21 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "libreoffice-5-1-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=207d8440429d03d846f94c8c25fb0ff1bc773a95&h=libreoffice-5-1-3

Related tdf#98416 Libcmis: add a patch to fix Google Drive login

It will be available in 5.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 37 Giuseppe Castagno (aka beppec56) 2016-05-09 13:43:49 UTC
5.1.3.2 is ready to be tested, download from here:
http://www.libreoffice.org/download/pre-releases/

Fixed in:

Version: 5.1.3.2
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
CPU Threads: 8; OS Version: Linux 3.13; UI Render: default; 
Locale: en-US (en_US.UTF-8)
Comment 38 Pedro 2016-05-09 14:51:36 UTC
(In reply to Giuseppe Castagno (aka beppec56) from comment #37)
> 5.1.3.2 is ready to be tested, download from here:
> http://www.libreoffice.org/download/pre-releases/
> 
> Fixed in:
> 
> Version: 5.1.3.2
> Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
> CPU Threads: 8; OS Version: Linux 3.13; UI Render: default; 
> Locale: en-US (en_US.UTF-8)

It is indeed fixed in 5.1.3.2!

Grazie mille!
Comment 39 Pierre van Male 2016-07-03 09:32:00 UTC
I am using Ubuntu 16.04 and LO Version: 5.1.4.2 (Build ID: 1:5.1.4-0ubuntu1) and the problem is not solved for me.

what info can I provide to check further?
Comment 40 Giuseppe Castagno (aka beppec56) 2016-07-03 10:01:12 UTC
(In reply to Pierre van Male from comment #39)
> I am using Ubuntu 16.04 and LO Version: 5.1.4.2 (Build ID: 1:5.1.4-0ubuntu1)
> and the problem is not solved for me.
> 
> what info can I provide to check further?

The steps you used to reproduce the bug but using a TDF release, judging from the Build ID you reported, you are using a Ubuntu version, that may work differently than the TDF's one.
Comment 41 kubi 2016-08-09 16:03:48 UTC
I can confirm that the bug is fixed in TDF version. -- Thanks!

Operating system Debian unstable 64bit

From libreoffice.org - works properly
Version: 5.2.0.4
Build ID: 066b007f5ebcc236395c7d282ba488bca6720265

From Debian unstable repository - "General input/output error." dialog
Version: 5.2.0.4
Build ID: 1:5.2.0-1
Comment 42 Yousuf Philips (jay) 2016-08-10 21:28:33 UTC
(In reply to Giuseppe Castagno (aka beppec56) from comment #40)
> The steps you used to reproduce the bug but using a TDF release, judging
> from the Build ID you reported, you are using a Ubuntu version, that may
> work differently than the TDF's one.

Giuseppe: So i tested ubuntu's LO 5.1.4.2 build and get the same 'The specified device is invalid.' error, and as kubi mentioned debian's LO build doesnt work as well, i could guess that something maybe wrong with their build script or their google drive credentials arent correct. @Bjoern: Any thoughts?

(In reply to kubi from comment #41)
> From Debian unstable repository - "General input/output error." dialog
> Version: 5.2.0.4
> Build ID: 1:5.2.0-1

Kubi: Do you have two factor authentication on your google login?
Comment 43 kubi 2016-08-10 22:08:32 UTC
No, I forgot to mention. I use single factor only.
Comment 44 Erkhyan 2016-08-11 20:07:46 UTC
I get the error message on two separate computers, with the same Google account using two-factor authentication.

Computer 1 is under Linux Mint 18 Cinnamon 64 bits.
Version: 5.2.0.4
Build ID: 1:5.2.0~rc4-0ubuntu1~xenial2

Computer 2 is under Microsoft Windows 7 Ultimate 64 bits.
Version: 5.2.0.4 (x64)
Build ID: 066b007f5ebcc236395c7d282ba488bca6720265

The error appears after I enter the authentication code. Creating and using an application-specific password from Google does not solve the issue.
Comment 45 Martin 2016-08-15 01:23:07 UTC
I have the same problem in ArchLinux with version 5.2.0.4
The maintainer of the package said it could be related to libcmis, if this gives some hint.
Comment 46 Jonathan Prior 2016-08-17 09:29:30 UTC Comment hidden (obsolete)
Comment 47 Jonathan Prior 2016-08-17 09:31:22 UTC
Can report this happening on a Google Apps account with 2 factor. Filling out the login details, entering the 2 factor code and then clicking OK shows this error. 

Ubuntu 14.04.5 LTS, with LibreOffice deb packages downloaded from TDF website.

Version: 5.2.0.4
Build ID: 066b007f5ebcc236395c7d282ba488bca6720265
CPU Threads: 4; OS Version: Linux 3.16; UI Render: default; 
Locale: en-GB (en_GB.UTF-8)
Comment 48 Giuseppe Castagno (aka beppec56) 2016-08-17 13:23:13 UTC
(In reply to Martin from comment #45)
> I have the same problem in ArchLinux with version 5.2.0.4
> The maintainer of the package said it could be related to libcmis, if this
> gives some hint.

Martin, are you having problem with ArchLinux LO version or TDF's ?
Comment 49 Martin 2016-08-19 02:30:40 UTC Comment hidden (obsolete)
Comment 50 Martin 2016-08-19 02:31:19 UTC
(In reply to Giuseppe Castagno (aka beppec56) from comment #48)
> (In reply to Martin from comment #45)
> > I have the same problem in ArchLinux with version 5.2.0.4
> > The maintainer of the package said it could be related to libcmis, if this
> > gives some hint.
> 
> Martin, are you having problem with ArchLinux LO version or TDF's ?

Both. The only difference is that ArchLinux's version doesn't promt me the 2 factor code, whereas the TDF's one first asks for it and then shows the error message.
Comment 51 david 2016-09-13 13:17:11 UTC
(In reply to Martin from comment #50)
> (In reply to Giuseppe Castagno (aka beppec56) from comment #48)
> > (In reply to Martin from comment #45)
> > > I have the same problem in ArchLinux with version 5.2.0.4
> > > The maintainer of the package said it could be related to libcmis, if this
> > > gives some hint.
> > 
> > Martin, are you having problem with ArchLinux LO version or TDF's ?
> 
> Both. The only difference is that ArchLinux's version doesn't promt me the 2
> factor code, whereas the TDF's one first asks for it and then shows the
> error message.

Just downloaded and installed: http://download.documentfoundation.org/libreoffice/stable/5.2.1/deb/x86_64/LibreOffice_5.2.1_Linux_x86-64_deb.tar.gz, which is the latest TDF version.

I got the prompt for the 2 factor code, then got shown the same error message.
Comment 52 ftr 2016-10-18 13:38:26 UTC
Right, same here on Windows 7 , LO Version: 5.2.1.2 (x64)
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620

In addition, the Help link sends yo to an empty page:
https://help.libreoffice.org/swriter/svt/ui/placeedit/ok?Language=en-GB&System=WIN&Version=5.2

Swriter/svt/ui/placeedit/ok
There is currently no text in this page.
Comment 53 jolivierld 2016-10-20 04:58:03 UTC
I'm getting the same errors..
there is an underscore in my password as well as an exclamation point...

Not sure at this point if 2-factor is enabled... probably not, Evolution is able to sync my google calendars, no problem.

This is kind of frustrating because it's a really useful feature.
I know gnome is coming up with some kind of documents syncing app for google drive as well, but it's not part of debian-stable yet (won't be until january last I checked)...

Version info running debian :
Version: 5.2.2.2.0+
Build ID: 1:5.2.2~rc2-2~bpo8+1
Threads CPU : 4; Version de l'OS :Linux 3.16; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 54 lan.gatew2 2017-03-07 21:06:32 UTC
hello everyone
 
I'm a huge fan of LibreOffice, which probably explains why I've spent the last couple of hours carrying out some tests on the remote file services out of LibreOffice writer, specifically when attempting to connect to G Drive.

In essence, it doesn't work. I've tried connecting to G Drive using accounts: 

i) with 2-step verification

and

ii) without 2-step verification

from a variety of OS (Windows 10, Ubuntu 16.04 real, Ubuntu 16.04 virtualised, Kali Linux/Debian live USB).

I keep getting the same error message everyone else does, regardless of whether I enter my PIN correctly. Interestingly, it seems LOW requests an authentication code irrespective of whether 2-step verification is enabled on any given account.

Not entirely sure who owns this, but it doesn't look like progress it's been made over the years. Anything I can do to help?

Cheers

PS I've noticed some users lamenting the fact that there's no G Drive sync'ing feature in Debian ... that's not quite correct, it can be set up and it works, although it is a bit laborious to set it up. Get in touch if you'd like to know how (and I'll pull together the relevant guidance... which is in itself a bit of a laborious exercise, so not proposing to do it unless someone needs it).
Comment 55 Karl Foley 2017-03-29 09:36:55 UTC
I have just upgraded to v5.3.1.2 on Windows 10 and I can confirm this is still not working for me - In fact, I don't believe it has ever worked for me.

I have a google apps domain, so all my accounts end in @thefoleyhouse.co.uk instead of @gmail.com - Not sure if this makes a difference.

If I turn off two-factor authentication, everything works as expected but if I turn on two-factor authentication again (using the Android app) I get the "invalid device" error message.

Very happy to capture packets or logs as required.
Comment 56 Karl Foley 2017-03-29 09:42:13 UTC
Just reproduced my testing with a standard @gmail.com account.

Worked fine without 2FA.

Did not work with either SMS or Android App 6 digit pin.
Comment 57 Commit Notification 2017-03-30 11:49:28 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8d1a56c206e5c2ed6c331049198bb8ebc6176171

tdf#98416 libcmis: Google Drive 2FA fix

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 58 Commit Notification 2017-04-03 19:53:28 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9700ba82ab9ffff07ae0c1ea1ca2a6e0d9a7347e&h=libreoffice-5-3

tdf#98416 libcmis: Google Drive 2FA fix

It will be available in 5.3.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 59 Commit Notification 2017-04-03 19:55:30 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f3049d26625e008fa11a275940998662b6d3d1d6&h=libreoffice-5-2

tdf#98416 libcmis: Google Drive 2FA fix

It will be available in 5.2.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 60 Alex Thurgood 2017-05-12 07:48:11 UTC
*** Bug 107542 has been marked as a duplicate of this bug. ***
Comment 61 Alex Thurgood 2017-05-12 07:50:34 UTC
Re-opening as the problem is still present for many, even when 2FA is not activated.

See bug 107542, marked as a duplicate of this bug, for a report concerning MacOSX, where the reporter states that he is asked for a number code despite not having activated 2FA.
Comment 62 Alex Thurgood 2017-05-12 08:14:07 UTC
(In reply to Alex Thurgood from comment #61)
> Re-opening as the problem is still present for many, even when 2FA is not
> activated.
> 
> See bug 107542, marked as a duplicate of this bug, for a report concerning
> MacOSX, where the reporter states that he is asked for a number code despite
> not having activated 2FA.

Testing on 

Version: 5.3.3.2
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 2; OS Version: Mac OS X 10.12.4; UI Render: default; Layout Engine: new; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group

allows me to log on and see the folder tree of my GDrive, but no files are displayed, so I can't select anything to load or edit !!
Comment 63 Alex Thurgood 2017-05-12 08:22:55 UTC
OK, so closing as indeed resolved fixed, it just takes forever to populate the dialog with files...
Comment 64 Erkhyan 2017-05-20 00:35:48 UTC
Still doesn’t work on my end, on three different computers.

Computer 1 is on Linux Mint 18.2, LibreOffice 5.3.3 installed from Fresh PPA.

Computer 2 is on Ubuntu Gnome 17.04, LibreOffice 5.3.3 installed from Fresh PPA.

Computer 3 is on Windows 7 64-bit, LibreOffice 5.3.3 installed from libreoffice.org.

The account I attempted to use on all three uses two-factor authentication using codes from the Android Authenticator app.

Still, always and again, 'The specified device is invalid.' after entering the six-digit code.
Comment 65 Szymon Kłos 2017-05-20 07:14:35 UTC
(In reply to Erkhyan from comment #64)
> 
> The account I attempted to use on all three uses two-factor authentication
> using codes from the Android Authenticator app.
> 

ATM only SMS authentication works
Comment 66 Buovjaga 2017-05-21 15:39:41 UTC
(In reply to Szymon Kłos from comment #65)
> (In reply to Erkhyan from comment #64)
> > 
> > The account I attempted to use on all three uses two-factor authentication
> > using codes from the Android Authenticator app.
> > 
> 
> ATM only SMS authentication works

Let's close this again, then. No need to keep punching a dead horse. Further auth methods belong to new reports.