Bug 98434 - Text Formatting ToolBar - Disappears
Summary: Text Formatting ToolBar - Disappears
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-05 00:42 UTC by E Net Arch
Modified: 2021-03-01 08:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description E Net Arch 2016-03-05 00:42:52 UTC
User-Agent:       Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build Identifier: LibreOffice 5.1.0.3

The text formatting tool bar was told to display in Impress. It appears and disappears now, causing the window to jump vertically as the tool bar appears and disappears when an object's text is editted.  This behaviour is very disturbing when editting a slide as I have to refocus my eyes on the new location of the data.

Reproducible: Always

Steps to Reproduce:
1. Select View / ToolBars / Text Formatting
2. Tool Bar appears
3. Select an object on the slide whose text you wish to edit
4. Edit the Text
5. Deselect the item for editting.
6. The toolbar disappears
7. the slide jumps
Actual Results:  
The slide jumps up and down as the tool bar appears and disappears

Expected Results:  
The tool bar should remain present 100% of the time, and should gray out when not needed.

[Information automatically included from LibreOffice]
Locale: en-US
Module: PresentationDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 V Stuart Foote 2016-03-05 02:08:14 UTC
Sorry, this is by design. The Text and Text Formatting toolbars are no longer active by default, they can be activated from the View -> Toolbars menu.

You have several options:

1. If you find it distracting, the toolbar should be disabled by unselecting it from View -> Toolbars -> Text Formatting, all formatting defaults available on it are available from the Sidebar -> Properties and Paragraph content panels.

2. If you prefer the toolbar, or need its additional customization over the Sidebar deck--when set visible you can undock the toolbar. It will float over the Impress slide canvas. And can be dragged into a multi row arrangement.

3. Finally you can dock the Text Formatting toolbar to another location: Right of Sidebar, Left of Slide sorter, bottom, or any position horizontal under the main menu.
Comment 2 Regina Henschel 2016-06-10 17:56:25 UTC
Users have problems with context sensitive toolbars and not all users like the sidebar, but prefer the position above the edit window. Nevertheless this issue can be kept resolved in favor of the more general discussion in bug 36976.
Comment 3 szotsaki 2016-06-28 11:09:43 UTC
„Sorry, this is by design.”

I'm sorry to say that, but for me this behaviour in solely 5 minutes caused to leave Impress to Google Slides. This constant screen flashing, resizing, refocusing is extremely irritating and would cause headache after hours of use (which is not unlike in production environment). Really, one of the worst design decisions ever made.

Turning the toolbar on in View -> Toolbars -> Text Formatting works only for seconds, until I click into a text box and leave that text box. Then it disappears again. I don't want these stupid workarounds like floating boxes everywhere.

See also this question/community bug report here: https://ask.libreoffice.org/en/question/64803/how-to-make-the-text-formatting-toolbar-permanent-in-impress/

I'm sorry, I seldom write so long about a single issue, but for this bug being a feature leaves me speechless.
Comment 4 E Net Arch 2016-06-28 16:23:44 UTC
My work around to this issue was to create a new ToolBar with all the controls that the existing TextBox ToolBar contains.  My ToolBar is not tied to the system, and does not disappear when a TextBox receives or looses focus.

I suspect that other users are doing the same thing to resolve this issue, vs complain about it.
Comment 5 alexlaedi 2016-09-16 11:48:54 UTC
I totally agree with szotsaki that the appearing and disappearing of the toolbar, leading to a vertically jumping environment, really provides headaches. 

„Sorry, this is by design.” is like selling a bug as a feature..
Comment 6 V Stuart Foote 2016-09-16 14:41:27 UTC
Closing again NOTABUG as bug 36976 is the general case for enable/disable context sensitive menus. However, with the new Single Toolbar fully customizeable--any desired button actions from the Text or Text Formatting toolbars can be added there and be available.

And at some point the Notebook Bar (Glade UI button assemblages, docked top) will be fully implemented providing another alternative to Sidebar, multi-toolbar and single toolbar controls. All are available in current daily tinderbox builds of master for testing and comment.
Comment 7 Jack Williamson 2019-12-16 12:13:40 UTC Comment hidden (spam)
Comment 8 meave 2020-06-03 13:23:40 UTC Comment hidden (spam)
Comment 9 cormak 2021-03-01 08:02:07 UTC Comment hidden (spam)