Bug Hunting Session
Bug 98437 - DIALOG: Find & Replace dialog reopens with larger size but collapsed options
Summary: DIALOG: Find & Replace dialog reopens with larger size but collapsed options
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 98429 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-03-05 04:39 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-03-22 08:11 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-03-05 04:39:50 UTC
Steps:
1) Open Writer, Calc or Impress
2) Click on the Find & Replace button or Ctrl+H
3) Click on the 'Other options'
4) Close the dialog
5) Open it up again and notice the dialog is as large as it should be if the 'Other options' were open, but they are closed

In 5.1 and opening the dialog again always has 'Other options' collapsed and the correct size of the dialog, so i'm assuming someone was adding this enhancement but didnt complete it.

Version: 5.2.0.0.alpha0+
Build ID: 31e037c348ef0e04393926891617fde1b0051a35
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86@71-TDF, Branch:master, Time: 2016-03-04_00:22:37
Locale: en-US (en_US.UTF-8)
Comment 1 Yousuf Philips (jay) (retired) 2016-03-05 04:40:45 UTC
Can you track down where this new behaviour was introduced. Thanks :D
Comment 2 Yousuf Philips (jay) (retired) 2016-03-08 22:40:08 UTC
I believe it must be this, as that is the only change made to svx/uiconfig/ui/findreplacedialog.ui since October.

commit 393f11f88648e1c7cace6224aa7afcbf9d68ddd6
Author: Eike Rathke <erack@redhat.com>
Date:   Fri Feb 26 00:13:07 2016 +0100

    add Wildcards to Find&Replace dialog
    
    Enabled only for Calc. Writer needs to be adapted to support wildcards.
    
    The global escape character is '\' set in SvxSearchItem ctor.
    
    Change-Id: I1af78f296deff81e023ee9f0e936f5f506f80c83

@Eike: Any thoughts?
Comment 3 Buovjaga 2016-03-09 19:41:24 UTC
No repro. My build is newer than Eike's commit.
(Btw., how can I make the build date visible in the about box?)

64-bit, KDE Plasma 5
Version: 5.2.0.0.alpha0+
Build ID: 8fab3bf91331a4ac9e3b8f44a46f579dbf7aeafb
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 4 Eike Rathke 2016-03-10 15:30:25 UTC
I temporarily reverted that change but the behavior stays the same, it must be something else.
Comment 5 Yousuf Philips (jay) (retired) 2016-03-10 18:49:24 UTC
(In reply to Eike Rathke from comment #4)
> I temporarily reverted that change but the behavior stays the same, it must
> be something else.

Thanks for checking Eike.

@Raal, @Xisco: Its up to you to do the magic. :D
Comment 6 Akshay Deep 2016-03-10 20:54:25 UTC
@jphilipz I can reproduce this bug. This bug is really distorting the dialog interface. :(

Version: 5.2.0.0.alpha0+
Build ID: eff3f82033b5862af6300876aa69d9de0486d61b
CPU Threads: 4; OS Version: Linux 3.19; UI Render: default; 
Locale: en-IN (en_IN)
Comment 7 Buovjaga 2016-03-10 20:59:48 UTC
NEW per comment 6
Comment 8 Xisco Faulí 2016-03-10 22:57:15 UTC
Regression introduced in range 57c3b726d0845a2070acccbe6a30837c3cc8a341..31e037c348ef0e04393926891617fde1b0051a35
Comment 9 raal 2016-03-11 10:31:55 UTC
This seems to have begun at the below commit.
Adding Cc: to Pierre-Eric Pelloux-Prayer; Could you possibly take a look at this one? Thanks

4a47626b82bfae847b38b2bca46565cfc7157e3d is the first bad commit
commit 4a47626b82bfae847b38b2bca46565cfc7157e3d
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Wed Mar 9 01:09:20 2016 -0800

    source sha:9fdd671fb276a419089f26e47739c4a783d15e93

    source sha:9fdd671fb276a419089f26e47739c4a783d15e93

:040000 040000 fd3edd587189dccbf40db69ec2e4627217eac7e6 be45d1e09aff9174e37922c03352291eff54a692 M      instdir

author	Pierre-Eric Pelloux-Prayer <pelloux@gmail.com>	2016-01-27 18:51:30 (GMT)
committer	jan iversen <jani@documentfoundation.org>	2016-03-03 07:37:11 (GMT)
commit	9fdd671fb276a419089f26e47739c4a783d15e93 (patch)
tree	2073020c2ee2b5d0e7759673e9dedb12cc094fec
parent	be326abdd5371e9f8715a064289bcff64af47bdb (diff)
tdf#96393: reuse layout if available
Comment 10 Eike Rathke 2016-03-14 16:14:56 UTC
9fdd671fb276a419089f26e47739c4a783d15e93 is the culprit, temporarily reverting that fixes the behavior.
Comment 12 Yousuf Philips (jay) (retired) 2016-03-22 08:11:11 UTC
*** Bug 98429 has been marked as a duplicate of this bug. ***