Bug 98452 - FILESAVE, FILEOPEN - Interaction - run program forget the file after reopen
Summary: FILESAVE, FILEOPEN - Interaction - run program forget the file after reopen
Status: RESOLVED DUPLICATE of bug 127791
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.8.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: dataLoss
Depends on:
Blocks:
 
Reported: 2016-03-05 21:08 UTC by André Lampe
Modified: 2019-11-22 17:34 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Impress file and bat file - impress forgets test.bat when saving (14.42 KB, application/zip)
2016-03-06 11:12 UTC, André Lampe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description André Lampe 2016-03-05 21:08:59 UTC
I am using the German version, I provide the German menu options in (), because I do not know the English ones.

In Impress, I have a group of objects, a form, an image and text. I wanted to assign an interaction ("Interaktion" - right click context menu, last point). I choose run programm ("Programm ausführen" from the drop-down, and selected a .BAT file (namely 1.bat). This works fine when I run the presentation, also after saving the presentation. When I close impress and open this presentation again, the group keeps run programm ("Programm ausführen") but there is no file saved to go along with it, it did forget the 1.bat.

I need this function because I want to call VLC to open specific video files with subtitles (in an extra file), play it on fullscreen once and close again.

I tried several things with it and found also, that the run programm option ("Programm ausführen") can not handle spaces or German umlaute (äüö) in folder names. I would lave to have something like a full commandline available, which could handle "C:\stuff\vlc.exe -f --play-and-exit C:\other-stuff\peng.avi"
Comment 1 raal 2016-03-06 07:43:37 UTC
I can not confirm with Version: 5.2.0.0.alpha0+
Build ID: 817f6bd75e98a321c238b5906bfcb031908914b2
CPU Threads: 1; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-03-01_01:14:57
and  5.1.0.3 (x64)

Please attach test file.
Comment 2 André Lampe 2016-03-06 11:12:23 UTC
Created attachment 123341 [details]
Impress file and bat file - impress forgets test.bat when saving

I created a test file in impress (5.1.0.3, German version) and provided a test.bat to go along with it.
With this file the same happens as described in the first bug report.

I am happy to provide additional files, when needed. Just ask.
Comment 3 raal 2016-03-06 12:45:19 UTC
(In reply to André Lampe from comment #2)
> Created attachment 123341 [details]
> Impress file and bat file - impress forgets test.bat when saving
> 
I can confirm with Version: 5.2.0.0.alpha0+
Build ID: 98a8eafa915b8d57b8bdccab9981e537d77f6f4a
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-25_00:49:33
and 4.2.8.2

after save and reopen is path empty.  Path: //VBOXSVR/tmp/test.bat
Comment 4 QA Administrators 2017-03-06 14:53:29 UTC Comment hidden (obsolete)
Comment 5 Timur 2019-11-22 16:02:28 UTC
"Forget" looks resolved in Windows LO 6.5+. I guess duplicate of bug 127791.

There's another issue "file is not an absolute URL that can be passed to an external application to open it". Seems bug 125607.

*** This bug has been marked as a duplicate of bug 127791 ***