Bug 98503 - Calc broken in 5.1.x
Summary: Calc broken in 5.1.x
Status: RESOLVED DUPLICATE of bug 94691
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-07 16:29 UTC by Eric
Modified: 2016-03-07 21:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric 2016-03-07 16:29:42 UTC
After starting up, changed some cells, changed some fonts, process stuck at 100% CPU, no menus render, and cannot select cells.

When I quit the page, a blank "Save" menu pops up. I was able to hit enter (I believe it actually did save, presumably "yes" was in focus?), and the process exited. 

Same thing happened in 5.0.x (the official ubuntu package). I then tried to install 5.1.x from .deb package available on the website.

I'm on Ubuntu 15.10.
Comment 1 Joel Madero 2016-03-07 16:56:27 UTC
Try to turn off openGL just to test that - Calc is most definitely not broken generally....most people have it working fine so it's environment related.
Comment 2 Eric 2016-03-07 17:12:08 UTC
Ah, disabling hardware acceleration seems to make it better. 

I have a pretty stock Ubuntu 15.10 instance running on a recent Asus laptop, Intel i7 processor, 4GB RAM, no fancy graphics card. Should I file a new bug about hardware acceleration? 

"Environment related" seems to gloss over the fact that 5.1 was unusable with pretty common software/hardware in the default settings.
Comment 3 Joel Madero 2016-03-07 17:13:26 UTC
No need - we're aware of openGL issues....just need to find the duplicate so we can close this one. There are a handful of these types of bugs.
Comment 4 sophie 2016-03-07 17:23:16 UTC
Hi, I got an Asus laptop too with LO 5.1.0.3 and cannot reproduce with hardware acceleration checked. Is it with a brand new document or an existing one? Sophie
Comment 5 Joel Madero 2016-03-07 17:30:16 UTC
If we're going to do that - also might as well list your graphics card (even if everyone has Asus...the graphics card is not necessarily the same)
Comment 6 Eric 2016-03-07 17:32:34 UTC
Uh oh, the issue is back after I disabled HW accel. It just took about 5 minutes of editing and now I don't have menu rendering again. It happened after I tried to change a stubborn Liberation Sans font back to the font I'm using (which is perhaps a different, less severe bug? I set the whole document to Fira Sans).
Comment 7 Eric 2016-03-07 17:33:18 UTC
Relevant lshw bits:

     *-cpu
          product: Intel(R) Core(TM) i7-3517U CPU @ 1.90GHz
          vendor: Intel Corp.
          physical id: 1
          bus info: cpu@0
          size: 2933MHz
          capacity: 3GHz
          width: 64 bits
          capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp x86-64 constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida arat epb pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms xsaveopt cpufreq
     *-pci
          description: Host bridge
          product: 3rd Gen Core processor DRAM Controller
          vendor: Intel Corporation
          physical id: 100
          bus info: pci@0000:00:00.0
          version: 09
          width: 32 bits
          clock: 33MHz
          configuration: driver=ivb_uncore
          resources: irq:0
        *-display
             description: VGA compatible controller
             product: 3rd Gen Core processor Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 09
             width: 64 bits
             clock: 33MHz
             capabilities: msi pm vga_controller bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:28 memory:f7800000-f7bfffff memory:e0000000-efffffff ioport:f000(size=64)
Comment 8 Joel Madero 2016-03-07 17:39:06 UTC
(In reply to Eric from comment #6)
> Uh oh, the issue is back after I disabled HW accel. It just took about 5
> minutes of editing and now I don't have menu rendering again. It happened
> after I tried to change a stubborn Liberation Sans font back to the font I'm
> using (which is perhaps a different, less severe bug? I set the whole
> document to Fira Sans).

How did you install 5.1? PPA or from libreoffice.org?
Comment 9 Eric 2016-03-07 21:25:54 UTC
> Hi, I got an Asus laptop too with LO 5.1.0.3 and cannot reproduce with hardware acceleration checked. Is it with a brand new document or an existing one? Sophie

Sophie -- I think maybe the hw-accel setting didn't propagate until I restarted my computer. I just restarted for something unrelated and I can't reproduce anymore.

> How did you install 5.1? PPA or from libreoffice.org?

Joel -- I installed from the website. 

LibreOffice 5.1.0.3 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737



Anyway, I'll mark this is a duplicate of #94691. Is that right?

*** This bug has been marked as a duplicate of bug 94691 ***
Comment 10 Joel Madero 2016-03-07 21:39:53 UTC
> 
> > How did you install 5.1? PPA or from libreoffice.org?
> 
> Joel -- I installed from the website. 
> 
> LibreOffice 5.1.0.3 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737


It's *highly* suggested to use ppa with Ubuntu.

https://launchpad.net/~libreoffice/+archive/ubuntu/ppa