Bug Hunting Session
Bug 98512 - The Undo action after that insert a new input field before an old input field should not delete the old input field
Summary: The Undo action after that insert a new input field before an old input field...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0 target:5.1.4
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-08 03:52 UTC by Haidong
Modified: 2016-10-25 19:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Just include an input field in this odt (7.98 KB, application/vnd.oasis.opendocument.text)
2016-03-08 03:52 UTC, Haidong
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Haidong 2016-03-08 03:52:25 UTC
Created attachment 123395 [details]
Just include an input field in this odt

Follow the below steps, you can reproduce the bug:
1.Open attached document
2.Insert an input field before the field named "input field 1"(Insert->Fields->Other->Functions->Input field)
3.Press Ctrl+Z trigger the Undo action
4.two input fields all disappear :(

this bug may cause the data losing of input field.
Comment 1 Commit Notification 2016-04-27 11:48:41 UTC
HaidongWu committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ed81bf39dd3431d28860fed6a2d4e8814126cc61

tdf#98512 Fix the Undo action of insert an input field.

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 2 Commit Notification 2016-04-29 22:26:19 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b44e70e3d17c79eaf78f9bfe8bd0275d7ed9325f

tdf#98512: sw: remove duplicate undo history add

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2016-05-03 09:45:45 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=20ae3d14187dacce2c2a1d2eab389e6110fe8442

tdf#98512 sw: add unit test

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2016-05-05 14:40:06 UTC
HaidongWu committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9197d8219e4b3ba4612c777710d65d325170de82&h=libreoffice-5-1

tdf#98512 Fix the Undo action of insert an input field.

It will be available in 5.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Marco Filippozzi 2016-06-16 08:34:25 UTC
Works for me on:

Version: 5.3.0.0.alpha0+
Build ID: a8bd44573b75d1399257d6f5d052611439607189
CPU Threads: 2; OS Version: Linux 4.1; UI Render: default;
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 
2016-06-13_23:46:49
Locale: it-IT (it_IT.UTF-8)
OS:    openSUSE Leap 42.1 (x86_64)

Version: 5.2.0.0.beta2
Build ID: ae12e6f168ba39f137fc110174a37c482ce68fa4
CPU Threads: 2; OS Version: Linux 4.1; UI Render: default;
Locale: it-IT (it_IT.UTF-8)
OS:    openSUSE Leap 42.1 (x86_64)

Version: 5.1.3.2
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
CPU Threads: 2; OS Version: Linux 4.1; UI Render: default;
Locale: it-IT (it_IT.UTF-8)
OS:       openSUSE Leap 42.1 (x86_64)

Version: 5.0.6.3
Build ID: 490fc03b25318460cfc54456516ea2519c11d1aa
Locale: it-IT (it_IT.UTF-8)
OS:   openSUSE Leap 42.1 (x86_64)

Status: NEW -> RESOLVED, WORKSFORME