Bug 98521 - Font in tablecontrol isn't shown in right format
Summary: Font in tablecontrol isn't shown in right format
Status: RESOLVED DUPLICATE of bug 93372
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 111420 114902 (view as bug list)
Depends on:
Blocks: RenderContext
  Show dependency treegraph
 
Reported: 2016-03-08 15:40 UTC by Robert Großkopf
Modified: 2018-10-08 11:28 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Open the form and have a look - fonts of tablecontrols should be different ... (13.63 KB, application/vnd.oasis.opendocument.database)
2016-03-08 15:40 UTC, Robert Großkopf
Details
Writer with "Bibliography" form (25.02 KB, application/vnd.oasis.opendocument.text)
2017-08-01 09:17 UTC, Andreas Säger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2016-03-08 15:40:16 UTC
Created attachment 123404 [details]
Open the form and have a look - fonts of tablecontrols should be different ...

Open the attached database.
Open the form.
You see two tablecontrols.
Font in first tablecontrol should be Arial standard 9, font in second tablecontrol should be Arial bold 12. Format for both tablecontrols is set in the properties of the tablecontrols.

Works right up to LO 4.4.7.2, fails with LO 5.0.0.5 and all newer versions up to 5.1.1.3.
Comment 1 raal 2016-03-10 13:16:18 UTC
This seems to have begun at the below commit.
Adding Cc: to Tomaž Vajngerl; Could you possibly take a look at this one? Thanks
 a04e3c4bdda7130ea4b8075e47e1962bb76b5471 is the first bad commit
commit a04e3c4bdda7130ea4b8075e47e1962bb76b5471
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Jun 5 02:29:19 2015 -0500

    source b4bbb5e5d7b31caad2fbcc00382ad27df3c81001

    source b4bbb5e5d7b31caad2fbcc00382ad27df3c81001
author	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2015-05-17 13:56:46 (GMT)
committer	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2015-05-18 02:22:49 (GMT)
commit b4bbb5e5d7b31caad2fbcc00382ad27df3c81001 (patch)
tree 8ac345712ff92a9b33a7d54651ed27ad88f1ec67
parent 2ca7795a6a723c701f295323fcc3f6c52ad37976 (diff)
refactor how font, fg. and bg. are applied in widgets/controls
Comment 2 frofa 2016-04-30 01:57:51 UTC
"Works right up to LO 4.4.7.2, fails with LO 5.0.0.5 and all newer versions up to 5.1.1.3."

I can confirm this problem on my Mac OSX 10.11.4 setup (as quoted above).

NOTE: A number of apparently NEW interface BUGS have appeared in LO 5.x which as far as I can see have not been seen before - such as bug numbers 93185 and 97731 - and which in my view have significantly degraded the usability of the Base component compared with the version 4.x series (to the point where I felt it necessary to back-grade to this earlier version). I really hope these new bugs will be addressed soon.
Comment 3 Alex Thurgood 2016-05-20 16:26:12 UTC
(In reply to frofa from comment #2)


> NOTE: A number of apparently NEW interface BUGS have appeared in LO 5.x
> which as far as I can see have not been seen before - such as bug numbers
> 93185 and 97731 - and which in my view have significantly degraded the
> usability of the Base component compared with the version 4.x series (to the
> point where I felt it necessary to back-grade to this earlier version). I
> really hope these new bugs will be addressed soon.

With nobody to work on them, it will either be by chance or a miracle that they get fixed.
Comment 4 frofa 2016-06-01 00:19:44 UTC
Please, would someone look at this RECENTLY INTRODUCED bug and try and fix it. For me (as a Mac user), it is a fairly MAJOR interface bug because the FONTS on all my Base form TABLE LISTINGS (carefully set-up under previous versions of LO) now default to some very small and hard-to-read size making if VERY difficult for me to actually see the content. For this reason, I believe this bug should be 'escalated' to a higher priority.

All the forms I use have been affected by the complete inability to set the font and font-size in the TABLE CONTROL grid. In other words, whatever value I set in the Table Control properties is SAVED by does not affect the display font and font-size of the TABLE GRID!

Is anyone else so affected? And could anyone suggest a 'work-around' to use in the meantime?
Comment 5 frofa 2016-08-03 23:54:04 UTC
This bug is still evident in LO 5.2.0.4 (under MacOS 10.11.6). If only someone would look at this recently introduced bug. The small default font-size is hard to read. Is there a work-around?
Comment 6 Robert Großkopf 2016-08-11 15:24:24 UTC
(In reply to frofa from comment #5)
> This bug is still evident in LO 5.2.0.4 (under MacOS 10.11.6). If only
> someone would look at this recently introduced bug. The small default
> font-size is hard to read. Is there a work-around?

The only possibility is to start the form in zoomed to more than 100%.

I haven't permission to set the importance of a bug higher than "normal". But the tablecontrol-bugs since the beginning of LO 5.* had decided many Base-users to go back to LO 4.4.7.2.
Comment 7 frofa 2017-03-08 21:05:13 UTC
This annoying interface bug is still present with LO 5.3.0 (reported one year ago now). Any chance that someone might look at it?
Comment 8 Andreas Säger 2017-08-01 09:17:34 UTC
Created attachment 135044 [details]
Writer with "Bibliography" form

The input form is linked to the "Bibliography" example database.
Comment 9 Alex Thurgood 2017-08-01 10:44:39 UTC
Bug still present in 

Version: 5.3.4.2
Build ID: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3
Threads CPU : 8; Version de l'OS :Mac OS X 10.12.6; UI Render : par défaut; Moteur de mise en page : nouveau; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 10 Alex Thurgood 2017-08-01 10:50:12 UTC
@Tomaž : I guess reverting the problematic commit is out of the question, given that it touches VCL refactoring ?
Comment 11 Robert Großkopf 2017-08-07 06:35:01 UTC
*** Bug 111420 has been marked as a duplicate of this bug. ***
Comment 12 jorojmaqui 2018-01-10 20:34:13 UTC
*** Bug 114902 has been marked as a duplicate of this bug. ***
Comment 13 jorojmaqui 2018-07-08 23:09:31 UTC
I'm doing a program in libreoffice base and this error is conditioning me, it looks so small the letter that it is impossible for me not to wear glasses
Who would be able to fix this problem?

I consider this problem important.

Thank you
Comment 14 Julien Nabet 2018-07-09 07:03:48 UTC
Version must correspond to the oldest one
Comment 15 jorojmaqui 2018-07-10 13:31:22 UTC
I have a program in libreoffice 6.0.5 made in Libreoffice Base and in the grid (subforms) when changing the size of the fonts it does not appear changed.
And in Openoffice 4.1.5 if it is changed.
Why is this?

Thank you
Comment 16 Xisco Faulí 2018-10-08 11:28:14 UTC
This is fixed in

Version: 6.2.0.0.alpha0+
Build ID: 4854acc7929ea58632c5d0f7f80a4adc3c62b8cd
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

Closing as a duplicate of bug 93372

*** This bug has been marked as a duplicate of bug 93372 ***