Bug 98524 - Automatic Spell Checker leads to display errors on neighboring cells
Summary: Automatic Spell Checker leads to display errors on neighboring cells
Status: RESOLVED DUPLICATE of bug 96546
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-08 17:20 UTC by peter
Modified: 2016-03-10 19:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peter 2016-03-08 17:20:26 UTC
With the most recent version of LO Calc, when automatic spell checking (German) is enabled, and a cell contains an unknown word, that cell and neighbouring ones are not displayed properly. Their content turn (partially) white and is not displayed. Changing the zoom level or scrolling away and back again makes the content reappear. If the cell is then selected, the content disappears again.

The error is reproducible on two machines, with the same version of LO:
Version: 5.1.0.3 (x64)
Build-ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.1; UI Render: GL;
Gebietsschema: de-AT (de_AT)

At least one machine in question uses Intel HD graphics. Another machine with AMD graphics does not have this problem.

This bug only appears when automated spell checking is enabled.
Comment 1 m.a.riosv 2016-03-09 00:26:10 UTC
Hi @Peter, thanks for reporting.

Please test disabling the option:
Menu/Tools/Options/LibreOffice/View - Graphics Output - Use OpenGL...
Comment 2 peter 2016-03-09 14:29:20 UTC
Deactivating OpenGL worked. 
Some questions arise:
1. Is this a bug of yours that will be fixed in future updates?
2. What are the side effects of deactivating OpenGL?
3. Can OpenGL be deactivated via MST installer transform for network deployment?

Here is some information about the graphics hardware/driver of the 2 affected work stations:

Intel(R) HD Graphics 2000

Report Date:			3/9/2016
Report Time[hh:mm:ss]:		15:25:26
Driver Version:			9.17.10.3347
Operating System:		Microsoft Windows 7 Professional (6.1.7601)
Default Language:		German (Austria)
DirectX* Version:		11.0
Physical Memory:		8079 MB
Processor:			Intel(R) Core(TM) i5-2400 CPU @ 3.10GHz
Processor Speed:		3093 MHz
Vendor ID:			8086
Device ID:			0102
Device Revision:		09

*   Processor Graphics Information   *

Processor Graphics in Use:		Intel(R) HD Graphics 2000
Video BIOS:			2111.0
Current Graphics Mode:		1680 by 1050


Kind regards and thank you for improving the best office suite!
Peter
Comment 3 Michael Meeks 2016-03-10 18:06:07 UTC
Another failure of shipping our black-list unfortunately - so - your hardware is sufficiently old that OGL should never have been turned on there =) Thanks for the report - it is fixed in 5.1.1.3 =)
Comment 4 peter 2016-03-10 18:35:32 UTC
So if I got that right, for the given hardware setup, the default setting was wrong and setting the value manually is just the same as waiting for the update (concerning this bug)?
Is this setting per machine or per user as, as we might have roaming profiles and users switching machines?

Kind regards,

Peter
Comment 5 Buovjaga 2016-03-10 19:16:51 UTC
5.1.1 is now released.
Closing as dupe of 96546. Peter: please don't change the status.

*** This bug has been marked as a duplicate of bug 96546 ***