Bug Hunting Session
Bug 98591 - LO Base application will not start under OSX10.11.* with either Fresh or Still runs with all other OSX versions & on Windows 7, 8,10
Summary: LO Base application will not start under OSX10.11.* with either Fresh or Stil...
Status: RESOLVED DUPLICATE of bug 98491
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-10 22:41 UTC by jay Arr
Modified: 2016-03-11 11:37 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
All the files are needed in this zip to support the split database (9.16 MB, application/zip)
2016-03-10 22:41 UTC, jay Arr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jay Arr 2016-03-10 22:41:59 UTC
Created attachment 123479 [details]
All the files are needed in this zip to support the split database

The attached SPLIT .odb LO database file will not startup & run with either the latest FRESH or STLL version of LO whilst running under OSX10.11.*.

The database WIL start up and run with either the latest FRESH or STILL version of LO whilst running under any OSX10.* (as long as it's NOT 10.11.*) AND it will run UNCHANGED on Windows 7,8 or 10 with LO FRESH or STILL.

Symptoms

The GUI appears
the bottom line of the window is completed with the URL of the database
a blue line flashes across the bottom of the windows for about 5 seconds
the application and LO freezes. Cannot do a force quit - have to run Apple's ActivityMonitor where the LO process is using over 100% of the cpu and quit from there.

I hace tried
various JRE combinations both latest 1.8.0_73(66) wit and without Apple's last java download javaforosx.dmg dated 31-Aug-2015. I've delete my user profile dir from the '4'  sub-dir and restsrted LO. None of which worked.

I have tried putting trace calls to msgbox in the first macro that's run by the application called SETUP in the 'embedded' module - they are never called. I think the problem relates to the OSX10.11.* and the initialisation that LO goes through prior to initiating a database. 

The attached file is a stripped down core of the free production application you can find at www.secretarybird.info.  NB on the website the AppleMAC installation files have been disabled for OSX10.11

When the .odb file does run you will see the application's splash form and then a switchboard form with empty buttons.
Comment 1 Alex Thurgood 2016-03-11 11:37:02 UTC

*** This bug has been marked as a duplicate of bug 98491 ***