Bug 98600 - LO cannot read some svm pictures from old ODT file
Summary: LO cannot read some svm pictures from old ODT file
Status: RESOLVED DUPLICATE of bug 98622
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.1.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0 target:5.1.3
Keywords: bibisected, bisected, regression
: 99008 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-03-11 11:59 UTC by Rpnpif
Modified: 2016-10-25 19:08 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
The SVM file which is not seen in LO5.1.1 (223.00 KB, image/x-svm)
2016-03-11 12:01 UTC, Rpnpif
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rpnpif 2016-03-11 11:59:00 UTC
How I reproduce this bug ?
Only LO 5.1.1 as this bug, not LO 5.0.

I open an 2013 old ODT file. Some embedded pictures are not found and not displayed.

I unzipped this file and I saw on the Pictures directory :
$ file *
2000042E00004A5E000059F494333287.svm: StarView MetaFile, version 512, size 838860800
2000054700004AF2000069CB593B6F14.svm: StarView MetaFile, version 512, size 838860800
200007C800004B9E000061C99F1CEF28.svm: StarView MetaFile, version 512, size 838860800
2000099B00004B6C00006A7C68229C9B.svm: StarView MetaFile, version 512, size 838860800
20000FED000048780000683B4AEE4DA4.svm: StarView MetaFile, version 512, size 838860800

After recording again the ODT file with a new name with LO 5.0, all work fine with LO 5.1.1.

The new Pictures directory is :
file *
2000042E00004A5E000059F4C4424137A7FBDF29.svm: StarView MetaFile, version 256, size 822083584
2000054700004AF2000069CBDEC0E9C2EEBB1F12.svm: StarView MetaFile, version 256, size 822083584
200007C800004B9E000061C92F9913E376FC71F2.svm: StarView MetaFile, version 256, size 822083584
2000099B00004B6C00006A7C4A772FCF6BCECBD0.svm: StarView MetaFile, version 256, size 822083584
20000FED000048780000683B26A91213264BBCEE.svm: StarView MetaFile, version 256, size 822083584

Expected :
The old ODT file should display all the pictures in LO 5.1.1 as in LO 5.0.
Comment 1 Rpnpif 2016-03-11 12:01:44 UTC
Created attachment 123496 [details]
The SVM file which is not seen in LO5.1.1

In attachment, a SVM file that LO5.1.1 cannot display
Comment 2 Dennis Roczek 2016-03-11 12:27:08 UTC
This might be related to bug 92925
Comment 3 MM 2016-03-11 12:45:03 UTC
Unconfirmed with v5.0.5.2 under ubuntu 14.04 x64.
Confirmed with v5.1.1.3 under ubuntu 14.04 x64.

Inserting the image doesn't work any longer with v5.1.

Bug 92925 is about export, not import.
Comment 4 Rpnpif 2016-03-11 14:20:13 UTC
After Debian Jessie-backports, I have just tried in MS Windows that get the same issue.
Comment 5 raal 2016-03-11 14:22:35 UTC
This seems to have begun at the below commit.
Adding Cc: to Noel Grandin; Could you possibly take a look at this one? Thanks

86334d4aee98252413f81e7fe4e2e0fbd01346de is the first bad commit
commit 86334d4aee98252413f81e7fe4e2e0fbd01346de
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Nov 12 10:00:12 2015 -0800

    source sha:db17d3c17c40d6b0e92392cf3c6e343d1d17b771

    source sha:db17d3c17c40d6b0e92392cf3c6e343d1d17b771


author	Noel Grandin <noel@peralex.com>	2015-11-10 11:36:34 (GMT)
committer	Noel Grandin <noelgrandin@gmail.com>	2015-11-11 07:16:20 (GMT)
commit	db17d3c17c40d6b0e92392cf3c6e343d1d17b771 (patch)
tree	9d562fcf764e7717df9585ef0e735a12ea4aaa16
parent	2ce9e4be4a438203382cb9cca824ce3e90647f3a (diff)
new loplugin: memoryvar
Comment 6 Commit Notification 2016-03-15 09:10:04 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c5bee7b8c1055e5052a261c8755bdb150fb27494

tdf#98600 and tdf#98622 fix metafile parsing

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Armin Le Grand 2016-03-17 17:19:38 UTC

*** This bug has been marked as a duplicate of bug 98622 ***
Comment 8 Armin Le Grand 2016-03-17 17:25:33 UTC
@noel: Have you seen that there were more VersionCompat related changes in db17d3c17c40d6b0e92392cf3c6e343d1d17b771...? Are all turned back? VersioCompat does important things in it/s con/de-structor(s)
Comment 9 Commit Notification 2016-03-23 08:48:23 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d4163c17ef47fdbc7d45adc5803b9844739b3324

tdf#98600 and tdf#98622 fix metafile parsing (part2)

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-03-24 10:28:05 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ceedd3c624873cd5dbdd76456a1540560a128a01&h=libreoffice-5-1

tdf#98600 and tdf#98622 fix metafile parsing

It will be available in 5.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2016-03-24 10:28:16 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e3d06146f648faf35b475d536f3a9c6fd55ea188&h=libreoffice-5-1

tdf#98600 and tdf#98622 fix metafile parsing (part2)

It will be available in 5.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 raal 2016-04-06 06:54:05 UTC
*** Bug 99008 has been marked as a duplicate of this bug. ***